1. Basic Interface
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“ The Rhino Screen
E Rhino divides its window into six areas that supply information or prompt you for input.
= Screen Area Description
Menu Bar Access commands, options, and help.
i Command area Lists prompts, commands you enter, and information displayed by the command.
*E Toolbars Acecess shoricuts to commands and options.
& Graphics area Displays the open model. Several viewporis can be displayed. The default viewport layout displays four
viewpors (Top, Front, Right, and Perspective).
Viewports Displays different views of the model within the graphics area.
Status bar Displays the coordinates of the pointer, the status of the model, options, and oggles.
Watch the command line to find
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= Press F1 at any time to access Rhino Help. In addition to finding information about each command, Rhine help has
conceptual information as well as many examples and graphics to help you complete your model, When you are
confused or unsure about what to do, the first place you should look is the help file. You can also access help for a
i specific command by starting the command and press F1.
*E In addition, the CommandHelp command displays the halp topics in a dockable window and displays help for the
2 current command.
Most of the commands include short video clips that show how the command and the options work,
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5 If Auto-update is checked, the help for the current command displays. If Auto-update is unchecked,
“2 you can type the name of the command that you want displayed and press enter to display
the information.

Notes:
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3 Customizing Rhino
b The toolbar layout
(=
1"3_’ The toolbar layout is the arrangement of toclbars containing command buttons on the scresn. The toolbar layout
=, is stored in a file with the .tb extension that you can open and save. Rhino comes with a default toolbar collection

and automatically saves the active toolbar layout before closing unless the .tb file is read-only. You can create

your own custom toolbar collections and save them for later use.

You can have more than one toolbar collection open at a tima. This allows greater flexibility to display toolbars

for particular tasks.

Rhino’s customization tools make it easy to create and modify toolbars and buttons. Adding to the flexibility is

the ability to combine commands into macros to accomplish more complex tasks. In addition to toolbar

customization, it is possible to set up command aliases and shortcut keys to accomplish tasks in Rhino,
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Comments

Open the model
ZoomLights.3dm.

From the Tools menu, click
Toolbar Layout.

Highlight the Default toolbar
collection.

From the Toolbars dialog
File menu, click Save As.

Type Level 2 Training in
the File name box and
click Save.

A copy of the current default
toolbar collection has besn
saved under the new name.

Exercise 2—Customizing Rhino’s interface

To create a custom toolbar collection:
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In this exercise we will create buttons, toolbars, macros, aliases, and shortcut keys that will be available to use
throughout the class.
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Toolbar collections are saved with a .th extension. You will use this new toolbar collection to do some

customization.

In the Toolbars dialog all the open toclbar collections are listed along with a list of all the individual toolbars
for the selected toolbar collection. Check boxes show the current state of the toolbars. A checked box
indicates that the toolbar is displayed.

Notes:

Edit Toolbar Layout
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4 In the Import Options dialog, select the file you just saved.
5 For the Options to import, click Aliases, Appearance, or any othar options you wish to import. if}_
The saved options are imported,
Shortcut keys
The same commands, command strings, and macros that you can use for buttons are also available for keyboard
shortcuts, Shortcuts are commands and macros that are activated by a function key, Ctrl, Alt, and Shift
combinations, and an alphanumeric key on the keyboard.
To make a shortcut key:
1 From the Tools menu, click Options. % Riina Optiom |
2 In the Rhino Options dialog, on the TR g
Keyboard page, you can add command o e o
3 [E] | _h=p =
strings or macros. o F2 [T CommasdHaiar
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11 To make the Curves layer the only visible layer,
from the Edit menu, click Layers then click
One Layer On. Sezlect the Curves layer,
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12 From the File manu, click Notes. raier 5

Dacimal inches

2 Type the details about this templats.
= 13 From the File menu, click Save As Template and navigate to the templates Lol aomining 2emipl s zmphsee
E‘ d]I'E'CtOI"\-'. Units=Inches
7] T ; Grid=0.1 inches
Name the template Small Objects —-Decimal Inches - 0.001.3dm. Snap=0.1 inches

s . - e : . . ; Absolute Tolerance=0 001 inches
This file with all of its settings is now available any time you start a new model.

i Pages

To set a default template:

1 From the File menu, EX Open Template Fite x|

click New.
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3 Inthe Open
Template File dialog,
check the Use this
file when Rhino
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To draw line segments:
1 From the Curve menu, click Line, and then click Line
Segments to begin the Lines command.
Pick a point in a viewport.
Pick another point in a viewport.
A line segment appears betwsen the two peints.
Pick another point.
Conftinue to pick points,
Additional segments appear.
Each segment meets but is not joined to the previous segment.
Press Enter to end the command.

To use the Close option:

1 Repesat the Lines command.
2 Pick a Start point.

3 Pick 3 or £ more points.

4 Click Close.

The last line will end at the original start point. Line segments are individual lines that meet at a commen
endpeint.

To draw a polyline:

1 From the Curve menu, click Polyline, and then click Polyline to
begin the Polyline command.

2 Pick a start point.

3 Pick 3 or € more points.

4 Press Enter when done.

This makes an open polyline. A polyline is made of line segments
that are joined together. It is one object.
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Notes:

Drawing Free-form Curves

The InterpCrv and Curve commands draw free-form curves. The InterpCrv command draws a curve through
the points you pick. The Curve command uses control points to create a curve,

Bockmarks

Option Description
Close Closes the shape by drawing from the last point picked fo the first point picked. This ends the
command.

Signatures

EndTangent  After choosing a peint on another curve, the next segment will e tangent to the point you
picked and end the command.

Unda Deletes the last point picked.
Cegres ‘f'ou can set the degree of the curve.
Knots Determines how the interpolated curve is parameterized.

‘When you draw an interpolated curve, the points you pick are converted info knot values on
the curve. The parameterization means how the intervals between knots are chosen.

Sharp When you make a closed curve, it will come to & point instead of making & smooth closure as
it normally does

Model Tree

E Exercise 4—Drawing interpolated curves

1 From the Curve menu, click Free-form, and then click
Interpolate Points.

2 Pick a Start point.

Conftinue picking points.

)

Curve: Interpolate Points

L

4 Click Close to make a closed curve or, press Enter to end the
command.

Attachments
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Exercise 5—Drawing curves from control poinis

1 From the Curve menu, click Free-form, and then click Control
Points.
Pick a Start point.
Conftinue picking points.

Click Close to make a closed curve or, press Enter to end the
command.

Modeling Aids

Modes are modeling aids that you can toggle on or off by pressing shortcut keys, a function key, typing a single
letter command, or clicking a button.

| Snap | Ortho | Panar [Osnap | Record History |

Click the Snap, Ortho, Planar or History panes on the status bar to toggle these modeling aids on and off.

Snap
Forces the marker to snap on grid intersections.
You can also toggle Snap on and off by pressing F9 or typing the letter S and pressing Enter.

Ortho

Restricts cursor movement to the points 2t a specified angle from the last peint created, The default angle is 50
degrees.

You can also toggle Ortho on and off by pressing F8 or pressing and holding the Shift key down.

If Ortho is set to on, hold down the Shift key to toggle Ortho off, If Orthe is off, hold down the Shift key to togale
Ortho on. F8 or Shift.
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Planar

Thiz is a modeling aid similar to Ortho. This helps you model planar objects by forcing input to be on a plane
parallel to the construction plane that passes through the last point that you picked.

You can also toggle Planar COn-Off by typing the letter P and pressing Enter.

History

Records history and updates history-aware cbjects, With History recording and Update turned on, a lofted surface
can be changed by editing the input curves.

In general, it is best to leave the Record option st to No and use the Record History status bar pane to
selectively record history. Recording history uses computer resources and makes saved files larger,

Grid

Pressing FT hides or shows a reference grid in the current viewgort of the araphics screen at the consiruction plane.

Exercise 6—Drawing lines and curves using mode functions

1 Toggle Snap on and draw some lines,
The marker snaps to each grid intersection.
2 Toggle Snap off, toggle Ortho on and draw some lines and curves.

You can only input points that are at 20 degree intervals from the last point. Using Snap and Orthe toggles
you can draw with precision. We will discuss sther ways to get precision in a later session.
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Notes:
£ Model Setup
" In Rhino you can create full-size models using precise measurements. You might nesd to changs the modeling
B envirenment depending on the type of medel you are creating; the default options may nct always work.
&
[=]
A To change the options:
1 From the File menu, click Properties. If
E 2 Inthe Document Properties dialog box, under Rhine Options, click Modeling Aids. Document Properties
5
E Modeling Aids lets you control Orthe, Object Snap, Grid Snap, and other mede options.
o 3 Chanage the Ortho option to snap every 30 degress.
In the Document Properties dialog box, click Grid.
5 In Grid properties, changs the following settings.
You can change the appearance of the modeling environment by changing the grid elements. The gnd
spacing, the frequency of the "na_]ol lines, and the number of grid elements can be changed. The Grid dialog
box lets you configure grid settings.
8 6 Change the Grid Extents setting to 10. The value for Grid extents is for
= 4 il : each quadrant
% 7 Change the Minor grid lines every zatting to 1. ¥
= 8 «Changs the Major lines every setting to 4. 30°
= . .
9 Change the Snap Spacing setting to .25, and click OK.
2 10 Draw some more lines and curves with Snap and Ortho on. 50
Notice that the marker now snaps between the grid intersections L _i_ 35
and that Ortho snaps at every 30 degrees. 1.0 15
11 Try to draw the closed polyline to the right with Snap and Ortho J L
surned an. 30 30—+ 30 b
4]
=
E To reset the modeling aids options:
ﬁ 1 From the Tools menu, click Options.
2 In the Rhino Options dizlog box, click Modeling Aids.
3 Changs the Ortho options to snap every 90 degrees.
2
E
B
[=]
o
Robert MchNeel & Azzocistes 35 |
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£ Saving Your Work e
-\E Save your work periodically during a session to keep it from being acodentally deleted.
8
m
To save your model: H
» From the File menu, click Save. NG
ﬂ Or, click one of the cther opticns. You will have an opportunity to save your work.
5
2 Command Description
-u%" - It Is good prachice fo save your
Save Saves your model and keeps it open. model in stages under different
SaveSmall Save your medel without render or analysis meshes and preview image to minimize file names, using the Save As
size command. This lsis you go back
i . i fo an eanier version of your
IncrementalSave Save sequentially numbered versions of your mode!.
q ¥ L3 maodel for modifications i
Savels Saves your model o a specified file name, location, and format. necessary.
SavelsTemplate Save as a template.
b
=g
o
2
=l Layers
: Rhino layers work like CAD layering systems. By creating objects on different layers, yvou can edit and view related
portions of @ model separately or as a composite, You can create as many layers as you like,
You can display all layers simultaneously or turn any of them off. You |Seesiaities G
can lock layers so they are displayed but cannot be selected. Each n N . Edit Layers
layer has a color, You can assign a name to each layer (for example, o Befry Ly | Lestren
Base, Body, Top) to organize the model or you can use preset layer e T
names (Default, Layer 01, Layer 02, Layer 03). mac
E The Layers window manages layers. Use it to set up layers for your
g maodel,
=
[=]
=
b
n
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E
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= Exercise 7—Layers
E
=
a To create a new layer:
m
1 From the Edit menu, click Layers, and then click Edit Layers. Layers - MLiyers
. . Bhoxa s @50
o 2 In the Layers window, click New. (s x,i 0 T
5 3 The new layer, Layer 06, appears in the list. Type Line and ':“‘T ¥ Ctma -
i press Enter. o I BB
f?," 4 Click New, et Tyl
5 The new layer, Layer 06, appears again, Type Curve and press s ks
Enter.
The Default layer is created automatically
when you start & new model with no
template. If you use a standard Rhino
B template, a few additional layers are also
e created.
o
-l
(=]
=
To assign a color to a layer:
1 Click the Color patch on the Line row in the list.
2 In the select Color dizlog box, click Red from the list. Hue is controlled by moving the
The right half of the sample rectangle turns red. :Jl;r:ecavrjaund;he’amu.'a! paitian of
] - e color wheel
gjuee::'iz:_, Val are the hue, saturation and value components of e A B T T IO
R ' as a scale ranging from red
» f{ |_-._: and B are the red, green and blue components of the through }-’ef.folrfg?een s Bice
E -'3!9' . and then circulariy hack fo red.
il 3 Click OK. . . ) Saturation and Value ars
8 4 In the Layers window, the new coler appears in the color bar controlied by moving the smali
< on the Line row of the layer list. circle around in the sguare
5 Repeat steps 1-3 to make the Curve layer Blue., ﬂir::f I e b e ol
*E 6 Click OK to close the dizlog box, Calrlic s e vidness oF
& hue. Value is the relafive
£ lightness or darkness of a color.
3
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To make a layer current:

1 In the Status Bar, click the Layer pane.
2 In the Layer popup, click Line.
3 Draw some lines.
The lines are cn the Line layer and they are colored red,
4 To make a different layer current, click the Layer pane of the status bar,
5 Click Curve.
6 Draw some curves.
They are on the Curve layer and are colored blue.
7 Draw more lines and curves on each layer,
Clicking the name or
the checkbox sets the
current layer.

To lock a layer:
1 In the Status Bar, click the Layer pane.

2 Inthe Layer popup, click the Lock icon on the row for the Line layer.

Locking a laver turns it into 3 reference only layer. You can see and snap to objects on locked layers. You
cannct select any objects on locked layers. You cannot make a locked layer current without unlocking it.

To turn a layer off:

1 In the Status Bar, click the Layer pane.

2 In the Layer popup, click the On/Off icon (light bulb} in the row for Curve.
Turning 2 layer off makes all objects on it invisible.

]
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Precision Modeling

So far you have been drawing imprecise lines. Now you will try drawing lines at specific places. To do this you will
use coordinates.

Whenever you draw a curve, or create a solid primitive, Rhine asks you for a series of points. You can tell that
Rhino is azking for point input two ways: the command prompt has a prompt like Start of line, Start of
polyline, Start of curve, or Mext point and the arrow-shaped cursor turns into a cross-shaped cursor

You can enter a point two ways: pick a peint in a viewport with the mouse, or type coordinates at the command
line.

Rhino uses a fixed Cartesian cocrdinate system called the world coordinate system (WCS), based on three axes
(the x-, y-, and z-axes) that define locations in three-dimensional space.

Each viewport has a construction plane that defines coordinates for that viewport. We will work in the Top and
Perspective viewports where the two coordinate systems are the same,
Absolute Coordinates

The first forms of ceordinates you will use are called abselute coordinates. Absclute coordinates are exact
locations relative to the x-, y-, and z-axes.

Exercise 10—Setting up a model
1 From the File menu, click New.
2 Click small Object - Millimeters.3dm, and then click Open.
3 from the File menu, click Save As. Name the model BOXES.
Use the BOXES.3dm model to learn how to draw with absolute coordinates,

Notes:

Set the units and folerance of the
model before you begin.

‘You can change the folsrance
after you starf, buf objects
created before the change still
have the oid folsrance value

1
Cross-shaped cursor

Fobert McNesl & Azzocistes

49

I4d 4 |©wGsofss) b Pl | @

| =

ﬁ Untitled - Rhinoceros ...

% Adobe Photoshop | (2 3.POLUTEXNEIO

Sl -
OEL f@@u 5:07
- L




/- Adobe Acrobat Professional - [Rhino Level 1 v4.pdf] =)=
-f'__ File Edit View Document Comments Tools Advanced Window Help

= f e 9 oy - . = =
X B A = E {a‘ ﬁ Search |- E Create PDF ~ Ac'j Comment & Markup = @57 Send for Review = lﬂslecure - Z Sign = |S=| Forms +

¥ - % =) % |- s 32
'—'-‘_(D\_J Ll r1 © | 90% GB

L)

X! |- @ Heb -

Notes:
Exercise 11—Entering absolute coordinares

1 Double-click the viewport title to maximize the Top viewport, 0,5 ‘/—5 5 h

2 From the Curve menu, click Polyline, and then dick Polyline. Polyline
3 To Start bype 0 and press Enter. Left Click
If vou are going to start at the origin of the sheet (0,0,0) you can

simply type 0 as a shortcut,

For the Next point type 5,0 and press Enter.

For the Next point type 5,5 and press Enter.

For the Next point type 0,5 and press Enter. 0,0
Click Close to close the polyline.

Bockmarks

Signatures

5.0

b -, -

Relative Coordinates
Absolute coordinates can be slow and cumbersome, but they do work, Most of the time, relative coordinates are
easier to use

Every time you select a point, Rhine saves that point as the last
paint,

Relative coordinates are based on the last point entered, instead of
on the origin (0,0,0) of the construction plane.

Model Tree

Preceds the x,y,z coordinates with a single R (upper or lowsr case) to
enter relative coordinates. Use the @ symbel instead of an R to start
relative coordinates if you prefer.

Exercise 12—Entering relative coordinates

1 From the Curve menu, click Polyline, and then click Polyline. R-5.0
2 To Start typs 8,0 and press Enter.
These are absolute coordinates.
3 For the Next point type R5,5 and press Enter,
These are relative coordinates
4 For the Mext point type R-5,0 and press Enter,

R5.5

o
=
E
=
[=]
=
b=

Comments

5 Click Close to close the polyline.

M

E
=
[=]
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Notes:
£ Polar Coordinates
= Polar coordinates specify a point that is a distance and direction away from 0,0 in the current construction
o plane.
Vector directions in Rhino start with Zero degress at 3 o'clock on a standard clock, They change in an anti-
clockwise direction as illustrated below.
E For example, if you want a point Mext Point z 3
E four units away from the a &
= construction plane origin, at a 45° )
“ angle anticlockwise from the Distancs 59 P
constructicn plane x-axis, bype Angle
4<45, and press Enter, 1
- - 180 0
Relative polar coordinates are Ll :
preceded by R or @; absolute polar Last Point
cocrdinates are not, Instead of using x-, y-, and =- o 2
o coordinates, enter relative polar s (7}
= coordinates like this: Rdistance<angle.
3 F 3 0%
=l -
o o™
= .
i Exercise 13—Entering polar coordinates
1 From the Curve menu, click Polyline, and then click Polyline. R&<180 /—R5<9[}
2 To Start typs 0,8 and press Enter.
3 For the Next point type R5<0 and press Enter.
4  For the Next point type R5<90 and press Enter.
@ 5 For the Next point type R5<180 and press Enter.
[+ 6 Click Close to close the polyline.
E
G
B 0.8 R5<0
b
n
=
E
B
[=]
o
|
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i Notes: e
E Distance and Angle Constraint Entry =
E
“g‘ Using distance constraint entry, you can specify a point by typing a distance and pressing Enter, Then as you
o maowe your cursor in any direction, the distance from the last point will be constrained, This is a good way to
specify a line length quickly.
Using angle constraint entry, vou can specify an angle by typing < followed by 2 value and pressing Enter. The
ﬂ next peint is constrained to lines at multiples of the angle relative to the x-axis you specified.
5
E. Using the shift key to toggle Ortho on and off:
i When Ortho is off, hold the Shift key down to toggle it on. This method is an efficient way to draw perpendicular
lings. In the following example, draw a line five units long using distance constraints,
Exercise 14—Distance consiraint entry
1 From the Curve menu, click Polyline, and then click Polyline.
$ 2 To Start typs 8,8 and press Enter.
% 3 For the Next point type 5 and press Enter.
E 4 Held the Shift key down and pick a peint to the right.
= Ortho constrains the marker to 0 degrees.
=t 5 For the Next point type 5 and press Enter,
6 Hold the shift key down and pick a point up. < istance COHSUBI-N—F'I
Ortho constrains the cursor to 90 degrees
7 For the Next point type 5 and press Enter.
Hold the Shift key down and pick a point to the left.
Ortho constrains the cursor to 180 degrees.
" 9 Click Close to close the polyline.
=
E
=
(%)
=
b=
n
=
£
E
[=]
o
[ e
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Exercise 15—Distance and angle constraint entry
1 From the Curve menu, click Polyline, and then click Polyline.
2 To Start type 16,5 and press Enter.

3 For the Next point type 5 and press Enter, then type <45 and press
Enter.

As you drag your cursor around, the marker snaps to a distance of 5
and an angle of 45 degress.

Pick a point down and to the right.

The angle constraint sets the angle.

For the Next point type 5 and press Enter, then typs =45 and press
Enter.

Pick a peint up and to the right.
The angle constraint sets the angle.

For the Next point type 5 and press Enter, then type <45 and press
Enter.

8 Pick a point up and to the left.
The angle constraint sets the angle.
9 Click Close to close the polyline.
10 Save your model, You will use this model for another exercise.
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Notes:
Object Snaps

Object Snaps are tools for specifying points on existing objects. Use osnaps for precision modeling and to get
accurate data. Object snaps are often referred to as osnaps. In Rhino, reliable modeling and easy editing depends
on objects actually meeting at specified points. Objects snaps give you precision you cannot get using the
"eyeball™ method

Bockmarks

To open the Osnap toolbar

¥ Click the Osnap pane in the status bar.

This toolbar controls persistent object snaps. Use persistent objects snaps to maintain an object snap through
choosing several points without having to reactivate the object snap.

[TEnd [ Mear Point [ Mid [T cen [ int [TPep [ Tan [ Quad [ Knot _ [Project _|STrack _|Disable

Signatures

When an object snap is active, moving the cursor near an eligible point on an cbject causes the marker to jump to
that point and a tooltip to appear.

E Check a box to turn on the object snap. You can place the toolbar anywhere on your desktop.
17.; Command Button Description
= g End I, End snaps to the end of a curve, surface edge comer or polyline segment end.
Mear A Near snaps to the nearest point on an existing curve or surface edge.
Paint z Point snaps o a control point or point object.
Mid m Midpoint snaps to the midpoint of a curve or surface edge.
Cen @ Center snaps to the center point of a curve. This works best with circles and ares.
Imt _/_ Intersection snaps to the intersection of two curves.
-E Perp h_ Perpendicular To snaps fo the point on a curve that makes a perpendicular o the last selected point. It
E doesn't work on the first point that a command prompts you to pick.
K Tan pr Tangent To snaps to the point on a curve that makes a tangent to the last selected point. It doesn't work
B on the first point that a command prompts you to pick.
<I Quad Q Quad snaps to the quadrant point. The quadrant point i the maximum or minimum direction on a curve
in the x or y construction plane direction.
Knot (p Knot snaps to knot points on curves or surface edges.
E Project “!: Projects the snap point to the construction plane.
E SmartTrack :_'_-;-i{ SmariTrack is a system of temporary reference lines and points that i drawn in the Rhino viewport
S + using implicit relationships among various 3-D points, other geometry in space, and the coordinate axes'
directions.
Dizable @ Temporarily tums off persistent cbject snaps, retaining settings
|4
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Exercise 21 — Project Constraint

By default 2-D geometry is created on the active construction plane. Object snaps cverride this behavier and
snapping to objects that are not on the construction plane will cause the geometry to be non-planar. The Project
constraint igneres objects snaps and pushes zll the geometry ento the active construction plane,

To use the Project Constraint:

1 We will again work with the Constraints.3dm
file as previcus.

2 Make sure that the Ortho constraint is On,

3 Turn Layer 01 off and turn Layer 02 on.
The surfaces on Layer 02 are located at different
elevations.
Working in Top viewport, draw 2 Polyline
arcund the perimeter of the three rectangles.

Motice how the how the planar nature of the
palyiine is overnidden by the objeck snaps.

Delete the Palyline.

Turn on the Project constraint on the Osnap
toolbar,

Again, working in Top viewport, draw a
Polyline arcund the perimeter of the three
rectangles.

Look in the Perspective viewport as you draw
the polyline and note how the object snaps for
the endpeints of the green and blue rectangles
are projected to the construction plane.

The Project constraint forces all the segments of the polyline onto the
construction plane. The resulting polyline is planar.

8 Save the File
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Exercise 22 — Planar Constraint

The Planar constraint limits successive picked locations to the same construction plane elevation as the previous
location, For example a command such as Polyline can be started off the construction plane and the Planar
constraint will override Rhino's default behavior of snapping back to the construction plane.

To use the Planar Constraint:
We will first look at what happens with the Planar constraint Off. Then, we will turn the Planar constraint ©n to see
what changes.

;i !

We will again work with the Constraints.3dm
file as previous.

Turmn off the Ortho and Planar constraints.
Start the Polyline command.

Working in the Top Viewport, start the Polyline
at the lower left corner of the Green rectangle.
Add some mors segments without snapping to
any of the objects,

Lock at the Perspective viewport and notice how
the polyline pulls back onto the construction
plane after the initial point.

To override this behavior and create a planar
curve delete the Polyline and turn on the
Planar constraint.

Draw the Polyline agzin,

Nots how it now remains planar,

Delete the Polyline.
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: Editing Objects
6
]
=
c
1=
L Once you create objects, you can move and edit them to produce complex and detailed varations.
Fillet
Fillet connects two lines, arcs, circles, or curves extending or trimming them to touch or to join with a circular arc,
Option Description
B Radius Sets the fillet radius. A radius of 0 exdends or tims the curves to a corner, but does not create a filet.
% Join Yes, joins the fillet to the curves.
2 Mo, does not join the fillet to the curves
= Trim Yes, tims the curves to the fillet arc
Mo, does not frim the curves.
Exercise 33—Filler
»  Open the model Fillet.3dm. Rules to follow when fileting
curnves:
The curves must be coplanar.
2 The created fillet is determined
E f"’ by picking on the curve portion to
o keep.
B !/- f/- The radius cannot be so large
<t ///"' that it runs past the end of the
' curve.
o)
=
E
E
[=]
o
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To fillet lines at a zero radius:

1 From the Curve menu, click Fillet Curves,
2 Click Radius to change the radius.
3 Type 0, and press Enter.

change it.
Select an outer vertical line.

Select an adjacent horizental line,

6 Press Enter to repeat the command.
7 Fillet the other corners, as shown.

To join the filleted objects:
1 Select lines you just filleted.
2 From the Edit menu, click Join.

The objects are joined together, Curves join
only if they touch.

This Radius option remains the default until you

The ends of the lines are trimmed to a corner.

Fillet Curves

Remember to pick on the part of
the line that you want fo ksep.
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To fillet circles:

1 From the Curve
menu, click
Fillet Curves.
Type 3 and press
Enter.

Select the rnght
edge of a circle,
Select the rnight

edge of the
cther circle,

Repeat the command for the left side of the
circles,

Select the two fillets you just created.
From the Edit menu, click Trim.

For the objects to trim pick on the inner edge of
each circle,

To fillet and join arcs and lines:
1 From the Curve menu, click Fillet Curves.
Set Join=Yes and Trim=Yes.
2 Select the line in the lower |2ft part of the (

viewport,

Make sure you pick on the left half of the line. AS""

Repeat this procedure for the two arcs below /’]}-
the line and the arc you just filleted.
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“ Notes:
= To fillet the corners of a closed polyline:
£
= - i "
E 1 Select the closed polyline. l} L!.

2 From the Curve menu, click Fillet Corners. | Fillet corners
3 For the Fillet radius, type 2 and press Enter. D D |

All comers are filleted at once.

Signatures

Blend
E Blending is ancther method to connect lines, arcs, or curves. There are two blend commands that work on curves,
T Blend (default blend)} znd BlendCrev (adjustable blend). Blend offers many additional options for how the curves
B connect,
= .
sz Option Description
I Perpendicular When Conbinuity=Tangent or Curvature, allows you to blend a curve to a surface edge perpendicular to the
surface with confinuity.
AtAngle When Centinuity=Tangent or Curvature, crients the direction of the blend curve other than perpendicular to
the edge.
Continuity ‘Continuity describes the relationship between curves and surfaces. Types of confinuity: Position (GO},

Tangent (G1), and Curvature (G2},

To blend two curves:

1 From the Curve menu, click Blend Curves,

Attachments

2 Select the Curves to blend near the ends that you want to connect. Blend Curves
The arcs are connected with a smooth curve. The default continuity is
Curvature,

3 Delete the blend curve.

Comments

m
=
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To blend two curves with Adjustable curve blend:

1 Since there is no menu pick for this command, type . ]
BlendCrv on the d li lect the Adjustabl i T
on the command line or s&l e Adju e h_@qi _iL] (‘} 93

curve blend icon from the Curve Tools toolbar, ! } .
ﬁt@& gt E .E.F.tf_'lumhla rurve blend
fRese @i
o e
Lo )

Select the Curves to blend near the ends that

you want to connect.
You will sse a preview of the default blend with

control peints displayed.
For the control point to adjust, select the point
(1) and drag it further up the curve and click.

For the next control point to adjust, select the
point to the right of {2), drag it closer to (2) and
click.

After maang your adjustments, press Enter to
make the blend.
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Bockmarks

Signatures

Model Tree

Attachments

Comments

To add a knot:

Adding a knot or two to the curve will put more points near the end so that the third point can be nearer the end.
Knots are added to curves and surfaces with the InsertKnot command.

1 Undo your previous adjustments.
2 Start the InsertKnot command (Edit menu: Control Points > Insert

Knot),
’__---'h-‘-
3 Select the magenta curve. ’_BH\
Pick a location on the curve to add a knot in between the first two points.

In general a curve or surface will tand to behave better in point editing if |
new knots are placed midway between existing knots, thus maintaining a —
more uniform distribution.

Adding knots also results in added control points.

Knots and Contel Points are not the same thing and the new control points will not be added at exactly the
new knot location.

The Automatic option automatically inserts a new knot exactly half way
between each span between existing knots.

If you only want to place knots in some of the spans, you should place
these individually by clicking on the desired locations along the curve.

Existing knots are highlighted in white.

%

5 Match the curves after inserting a
knot into the magenta curve.
Inserting knots closer to the end
of curves will chanae how much
Match changes the curve.

—x

Notes:

y

Insert Knot

| 4 4 | evofar
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To make a lofted surface with closed curves:

Change to the Surfaces layer,

Select the two sguares in the upper left part of
the Top viewport.

Change to the Perspective viewport.,

From the Surface menu, click Loft.

The two squares show a seam direction arrow.
They should point the same direction.

If the seams don't line up at corresponding
points on the two curves, drag the seam point
until it does.

Press Enter.

1In the Loft Options dialog box, click OK.

A surface is generated between the two closed
polylines.

Repeat the procedure for the rounded sguares.
In the Loft Options dialog box, click OK.
Save your madel.

B
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Notes:

To make a lofted surface with open curves:

1 Repeat the Loft command for the three open
curves,

Bockmarks

2 In the Loft Options dialog box, change the
Style to Loose, click Preview,

Signatures

: Pages

3 Change the Style to Straight sections, click Preview.

4 Change the Style to Normal.

Model Tree

5 For the Cross-section curve options, change
to Rebuild with, change the number of
control points to 12, click Preview.

Change to Refit within, click Preview.

Attachments
-]

Comments
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Exercise 52—Control point editing

Boockmarks

In this exercise we are going to experimant with moving control points. Understanding how curves and lines react
when control points are moved is very important to understanding NURES modeling.

To edit control points:

1 Open the model Control Point.3dm. o

There are pairs of curves with different degrees
in the medel.

2  Turmn Ortho and Snap on.

3 From the Edit menu, click Select Objects, and
then click Curves.

Signatures

Control Points On

4 From the Edit menu, click Control Points, and
then click Control Points On. (Press F10.)

5 In the Front viewport, select the middle row of

_— e

points. |

6 Drag the points vertically, 8 units.
MNotice that the degree 1 curves (polylines) come
to a point at each moved control point and the
control peints are exactly on the curve, I
The degree 3 and 5 curves are smooth. The |
degrees 3 curves have more curvature than the o |
degree 5 curves

Individual peints have more influsnce on & small area of the curve with degree 3 curves, while points have
greater influence over a wider span of the curve with degree 5 curves,

Model Tree

2]

8]
=
E
=
[=}
=
I

Comments 4
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To make a lofted surface:

Select the curves.

From the surface menu, click Loft.

In the Loft options dizlog box, click OK.

Because the degree 1 curves were included in the loft, 2 polysurface is created
with a seam at each kink.

Select the surface.

Turmn on the contrel points.

The points do not turn on and the following message is displayed on the
command line: Cannot turn on points for polysurfaces.

Undo the loft.

To change the polylines into curves without kinks:

Select both polylines.
From the Edit menu, click Rebuild,
In the Rebuild Curve dialeg box change the

point count to 11 and the degree to 3, and
click OK.

& degree 3 curve cannot have kinks. The curve
smoothes and changes shape.
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Nudge Controls

Another method to move control points and other geometry in @ more subtle way is to use the Nudge keys. The
nudge keys are the arrow keys on the keyboard activated with the Alt, Ale+Ctrl, and alt+5Shift keys.

To change the nudge settings:

1 From the Tools menu, click Options.

2 In the Options dialog box, on the
Modeling Aids pages, note the Nudge
settings.

Any of these values can be changed.
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To use Nudge keys to move contrel points:

1 Select one or two control points in the Front
viewpaort,

2 Held down the Alt key down and press an arrow
key.

Matice that it moves (nudges) the point a small
amount.

Hold the Alt and the Ctrl key down and press
another arrow key,

The movement is much smaller.

Hald the Alt and the shift key down and press
ancther arrow key.

The movement is magnified.

5 Held the Alt and press the PageUp or PageDown key to nudge in the Z direction,

To use set points to adjust points:

1 Select all the
points in one
row along the
top of the
surface.
From the
Transform
menu, click Set
Points, 1
Cancel
e [ ] emen |
Points dizlog
box, check
Set 2, and uncheck Set X and Set Y.
In the Right viewport move the points and click.
The control points are aligned in the World Z direction.
Repeat this on some of the other rows of points.
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Trim

Trim cuts and deletes poitions of an object to make it end precisely at its intersection with another object.

Bockmarks

Exercise 44—Trim

In this exercise, we will to pre-sslect the cutting objects,

To trim curves:
1 Open the model Trim-Split.3dm.

2 Zoom Window around the grid in the lower left Zoom Window
corner of the Top viewport.

Signatures

3 Pre-select the cutting objects by selecting the
two outside vertical lines in the grid.

4 From the Edit menu, click Trim.

&

5 Select each of the horizontal lines at their left
and right ends.

The lines are trimmed to the cutting edges.
Press Enter.

b
=
o
B
=,

i

To trim surfaces:

1 Zoom Window around a sphere and surface in
the Perspective viewport.

2 Select the surface that intersects the sphere in
the Perspective viewport as the cutting
object.

Attachments

Trim
3 From the Edit menu, click Trim.

Comments
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5 Press Enter.

4  For the Object to trim, pick the right side of the sphere.
The zphere is trimmed at the surface.
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u Split
m
1 Splits one object with ancther into objects, splits a curve at a point you specify. The Split command breaks the
E object where it intersects the cutting object but does not delete anything.
Exercise 45—Split
E In this exercise, we will to pre-select the object or objects we are going to split.
=
.L% To split a curve:
1 Zoom Window around the closed curve in the
lower right corner of the Top viewport,
2 Select the closed curve, EE
3 From the Edit menu, click Split. Spit
4 Select the lines and press Enter.
E The curve is separated into four curves precisely
E where the lines intersect it
B
= a
To split a surface;
5 From the View
menu, click
Zoom, and then
= click Extents
L All.
G 6 From the Edit
E menu, click
split.
7 Select the
n sphere, and
E press Enter.
E =
8 8 Select the surface that intersects the sphere and press Enter.
The sphere is separated inte two pieces precisely whers the surface intersects it.
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g @ E |14 4 [ 2uscsg|p bl | © © | |d | =

"'| % Untitled - Rhinaceros ... “ % Adobe Photoshop “ (5 3.POLUTEXNEIO g8 Rhino Level 1v4ipdf TR %Qu 5:21




A= Ad i v, |

W _ ’ > |
2 F R T S @ seren || T crsoeror + ] comnent arup + o Send forReview + (£ secure + s - [ Fom +
| soket g (B | L e © (0% @ | D v | @b

Extend

Extend lengthens an object to make it end precisely at its intersection with another cbject or you can lengthen an
object when there is no intersection,

Exercise 46—Extend
1 Open the model Extend.3dm.
2 From the Curve

menu, click

Extend Curve, s

and then click

Extend Curve. D r\-—
For the /.v-"'"""""-\ /.-4""'_'"‘-\

boundary
objects, select
the line at the
left and the
curve at the
right.

Press Enter.
For the curve to extend, select the left end of the line and the middle curve.
The line and curve extend to touch the boundary edge on the left.

For the next curve to extend, click
Type=Natural on the command line.

Change to Type=Line. ﬁ
Select left end of the bottom curve and the [ =
right end of the lins.
The curve and line extend to touch the ‘ﬁ’ﬁ

boundary. The extension is a straight segment,
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9 For the next curve to extend, click Type=Line
on the command line.

10 Changes to Type=Arc.
11 Select the right end of the middle curve.

The curve extends with a tangent arc to touch
the boundary.

12 For the next curve to extend, click Type=Arc
on the command line.

13 Chanage to Type=Smooth.
14 Select the right side of the bottom curve,

The curve extends with a curvature (GZ)
continuous extension to touch the boundary.

15 Press Enter to end the command.

To extend with a set extension length:
1 From the Curve menu, click Extend Curve,
and then click Extend Curve,

2 Enter extension length, typs 4 and press
Enter.

Select the upper end of the curve on the right.
The curve extends exactly 4 units.

Press Enter to end the command.
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Offset

Offset creates an object parallel or concentric to another object. Use Offset to creste speoalized copies, such as
parallel lines, concentric circles, and concentric arcs, through specified points or at pre-set distances.

Exercise 47—0Offsetr

Open the mode! Offset.3dm.

Maximize the Top viewport.

Select the line.

From the Curve menu, click Offset Curve,

For the Side to offset, pick on the upper right
side of the line.

A parallel line is created.

To offset with the through point option:

Turm on the End osnap.
Select the aircle.
From the Curve menu, click Offset Curve,

For the Side to offset, pick click
Throughpoint on the command line.

For the Thoughpeoint, snap to the lower right
end of the line you offset.

A concentric circle is created that goss through
the endpoint of the line.
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To offset a surface:

1 Select one of the open surfaces.
2 From the surface menu, click Offset Surface.

3 Place your cursor over the surface and click your
left mouse button.

Notice that the direction of the arrows changed.
The normal direction of the surface was flipped by
the mouse click. If you have a pesitive number for
offset distance, the surface will be offset in the
direction of the normal. If you have a negative
number it will offset the opposite direction.

The normals shouwld point teward the concave side of the
surface.

Press Enter.
The surface is offset in the direction of the normals.
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To offset a surface to a solid:

Select the other open surface.

From the Surface menu, click Offset Surface.

Click on the surface to change the normal direction if necessary.

Choose the Solid option.

Pr?sds Enter to create the offsst surface and the surfaces needed to make the
solid.

To offset a polysurface:
Offsetting polysurfaces ususlly doesn't give the desired results. In this example we will demonstrate some of the
preblems.

Select the cylinder.
From the Surface menu, click Offset Surface.

The normals on a closed pelysurface will always
point to the outside.

Press Enter.

Each surface of the polysurface is offset as a
separate piece.
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: Pages

Model Tree

Attachments

Comments

To create the blend surface between the head and body:

1 From the surface menu, click Blend Surface.

2 For the segment for first edge, pick the edge curve at the bottom of the
head.

3 If the whole edge iz not selected, click All on the command line.
4 Press Enter to go to the next stage of the command.

5 For the Segment for second edge, pick the esdae curve at the top of the hole
in the body.

6 If the wheole edge is not selected, click All on the command line.
7 Press Enter to go to the next stage of the command.

8 In the Blend Bulge dialog box, check the x|
Preview check box. | 7
The blend surface between the body and the 2 i T
head is displayed.

9 Make any adjustments you desire by moving i e o) I
the slider bars in the dialog box, click OK when | came | W
finished.

If you check the box at the |eft of the sliders the
surface adjustments are symmetrical.
10 Save your model.

To join the parts:
1 Select the body the blend surface and the back of the head.
2 From the Edit menu, click Join.

The three surfaces are joined into one. The bill is left separate for rendering
pUrposes.

Notes:

Blend Surface

Join

b
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Exercise 58—Lofted surfaces

Open the model Loft.3dm.
Window select all of the curves.

From the Surface mznu, click Loft.
A surface is fitted over the curves.

In the Loft Options dialog box, switch
Style to Straight sections, and then click
Preview.

A surface is fitted through the curves, but
the sections are straight between the
curves,
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In the Loft Options dialog box, switch
Style to Loose, and then click Preview,

A surface is created that uses the same
control points as the curves, The surface
follows the curves more loosely.

Use this opticn when you want the surface
to conform to the contrel points of the input
curve,

In the Loft Options dialog box, switch
Style to Normal, and then click OK.

Mirror the surface to create the
other half.

Join the two halves.,

To make a seat:

1 Tum the Hull Curves layer off and
turn the Seat Curves, and Seat
layers on.

Make the Seat Curves layer
current.

In the Front view, select the
rounded rectangles.

From the Curve menu, click Curve
From Objects, and then click
Project.

Project uses the current construction plane to determine the direction of projection. Make sure you select the
curves and surface to project onto in the Front viewport.
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For the Surface to project onto,
select the hull.

The curves will be projected to both
sides of the hull surface.
Select the curves on the surface.

From the Surface menu, click Loft. QH
In the Loft dialog, click OK. B

A surface is fitted over the curves that fits exactly with the shape of the hull,

To create section curves from the surfaces:

Select the hull,
Change to the Sections layer.

From the Curve menu, click Curve
From Objects, and then clhick
Section.

For the Start of section, in the Top
viewport, pick a point to the left at
the center of the hull.

For the End of section, with Ortho on, drag 2 line to the right and pick.
A curve is generated on the surface. Repeat this at various locations,
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To create contour curves across the hull surfaces:

Select the hull.
Change to the Contours layer.

From the Curve menu, click Curve
From Objects, and then click
Contour.

For the Contour base point, snap to
the l=ft end of the canoe.

For the Direction perpendicular to contour planes, snap to the other
end of the canoce.

For the Distance between contours, type 12 and press Enter.
A curve is generated every foot along the hull.

To create an edge curve from the surfaces:

Change to the Top Rail layer.
From the Curve menu, click Curve
From Objects, and then clhick
Duplicate Edge.

Pick the top edge of the hull.

Pick the other top edge and press
Enter.

Two curves are generated at the
edges of the hull
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One cross-section:

Open the meodel 1 Rail Sweep.3dm.

Select the two curves on the left.

From the Surface menu, click Sweep 1 Rail.
In the Sweep 1 Rail Options dialog, click OK.

Two cross-sections:

Select the three curves in middle.
From the Surface menu, click Sweep 1 Rail.

In the Sweep 1 Rail Options dialog, check
Global shape blending.

In the Sweep 1 Rail Options dialog, dick OK.

Multiple cross-sections:

Select the four curves on the right.
From the Surface menu, click Sweep 1 Rail.

In the Sweep 1 Rail Options dialog, uncheck
Global shape blending.

In the Sweep 1 Rail Options dialog, click OK.

Exercise 6§7—Using 1-rail sweeps 1o crearte surfaces
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To create a 1-rail sweep to a point:

1 Make Surface 02 layer group current
and turn off Surface 01 layer group.
2 From the Surface menu, click
Sweep 1 Rail.
For the Rail, select the open free-
form curve.
For the Select cross section
curves, select the three closed curves,
then click Point on the command
line,

For the Pick end point, snap to the End of the free-form curve,
In the Sweep 1 Rail Options dialog, click OK.

To create a roadlike 1-rail sweep:

1 Make Surface 03 layer group current
and turn off Surface 02 layer aroup.

Select the helix.
From the Surface menu, click
Sweep 1 Rail.
Faor the Select cross section

curves, select the closed curve, press
Enter.

Change the style to Roadlike Right,
click Preview.

Change the style to Roadlike Front,
click Preview.

Change the style to Roadlike Top,
click Preview, click OK.
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Notes:

Exercise 62—Using 2-rail sweeps 1o creale surfaces

¥ Open the model 2 Rail Sweep.3dm.

Bockmarks

To create the base —Part 1:

In the first part of this exercise, we will explore one of the SweepZ options. To
illustrate the option we will use one cross-section, In the second part we will use
the same rail curves with two cross-sections, Lastly, we will use two rails that
converge to a single point.

Signatures
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Change to the Base Surface layer,

From the Surface menu, click Sweep 2 Rails.
Select the two rail curves (1).

Select the cross-section curve (2).

Model Tree
[T, - VI S

Press Enter twice,

Since we only picked one cross-section, the
surface doesn't conform to the circle at the top
of the sweep.

Fad e Ehe
AR
o T
By |
-

6 In the Sweep 2 Rail Options dialeg, check
Maintain height, click Preview.
Notice that the cross-section maintains the
same height thoughout the swesp.

7 In the Sweep 2 Rail Options dialog, click
Cancel.

Attachments

Comments
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Notes:
To create the base—Part 2:

1 Select the two rail curves (1),

Bockmarks :

From the Surface menu, click Sweep 2 Rails.
Select both cross-section curves (2],

Press Enter twice,

In the Sweep 2 Rail Options dialog, click OK.

& surface is created whose edges match the rail curves and the cross-section
curves,

[, B I I N

Signatures

To create the housing:

: Pages

-

Turmn the Housing Surface, Housing Curves,
and Mirror layers on.

Make the Housing Surface layer current.
From the Surface menu, click Sweep 2 Rails.
Select the two rail curves (1),

Model Tree
(%, R U ¥

For the cross-section, select the outer edge of
the cylinder, press Enter twice.

In the Sweep 2 Rail Options dialog, click OK.
A surface is created.

=]

To join the two parts:

1 Select the base
and the
housing
surfaces.

2 From the Solid

menu, click
Union.

Use FilletEdge
with a radius of
.25 to round the
intersecting
edge.

Attachments

Comments
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