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1  Before You Start 

 

This course guide accompanies the Level 1 training sessions. Level 1 shows you how to produce 3-D models using 
NURBS geometry. 

In class, you will receive information at an accelerated pace. For best results, practice at a Rhino workstation 
between class sessions, and consult your Rhino reference manual and the Help file for additional information. 

Duration: 

3 days 

Course Objectives 

In Level 1, you learn how to: 

 Utilize the features of the Rhino user interface 

 Customize your modeling environment 

 Create basic graphic objects—lines, circles, arcs, curves, solids, and surfaces 

 Model with precision using coordinate input, object snaps, and SmartTrack tools 

 Modify curves and surfaces with edit commands 

 Use control point editing to modify curves and surfaces 

 Analyze your model 

 Display any portion of the model 

 Export and import models to and from different file formats 

 Render the model 

 

 

 

The Rhino for Windows Interface 

Rhino uses NURBS for all curve 
and surface geometry. 
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Example Schedule 

Day 1 Topic 

8-10AM Introduction, Rhino Interface 

10AM-12PM Rhino Interface, Panning & Zooming 

12-1PM Lunch 

1-3PM Creating geometry 

3 -5PM Creating geometry 

Day 2 Topic 

8-10AM Editing 

10AM-12PM Editing 

12-1PM Lunch 

1-3PM Editing 

3 -5PM Control point editing, modeling with 

solids 

Day 3 Topic 

8-10AM Surfacing 

10AM-12PM Surfacing 

12-1PM Lunch 

1-3PM Modeling practice 

3 -5PM Import-Export, Rendering, 
Dimensioning, Printing, Customization 
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2  Rhino Basics 

The Rhino for Windows Interface 

Before learning individual tools, we will be acquainted with the Rhino interface. The following exercises examine 
the interface elements used in Rhino: the Rhino window, viewports, menus, toolbars, and dialog boxes.  

There are many ways to access the commands in Rhino—the keyboard, menus, and toolbars. We will focus on the 
menus in this class. 

To open Rhino: 

 Double-click the Rhino icon from the Windows desktop. 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



    

Notes: 

Robert McNeel & Associates 6 

The Rhino Screen 

Rhino divides its window into six areas that supply information or prompt you for input.  

Screen Area Description 

Menu Bar Access commands, options, and help. 

Command area Lists prompts, commands you enter, and information displayed by the command. 

Toolbars Access shortcuts to commands and options. 

Graphics area Displays the open model. Several viewports can be displayed. The default viewport layout displays four 
viewports (Top, Front, Right, and Perspective). 

Viewports Displays different views of the model within the graphics area.  

Status bar Displays the coordinates of the pointer, the status of the model, options, and toggles. 

 

 
Rhino screen 

Menu bar 

Command 
history window 

Command 

prompt 

 

Standard toolbar 

 

Graphics area 

 

World axes icon 

 

Viewport title 

 

Main1 and Main2 

toolbars 

 

Osnap Toolbar 

 

Status bar 

Watch the command line to find 
out what is happening. 
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Menus 

Most of the Rhino commands can be found in the menus. 

 

Rhino View menu 

Toolbars 

Rhino toolbars contain buttons that provide shortcuts to commands. You can float a toolbar anywhere on the 
screen, or dock it at the edge of the graphics area 

Rhino starts up with the Standard toolbar docked above the graphics area and the Main1 and Main2 toolbars 
docked on the left. 
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Tooltips 

Tooltips tell what each button does. Move your pointer over a button without 

clicking it. A small yellow tag with the name of the command appears. In 
Rhino, many buttons can execute two commands. The tooltip indicates which 
buttons have dual functions.  

To start a Polyline, click the 
LMB, to start the Line Segments 
command click the RMB. 

Flyouts  

A button on a toolbar may include other command buttons in a 

flyout toolbar. Usually the flyout toolbar contains variations on 
the base command. After you select a button on the flyout, the 
flyout disappears.  

Buttons with flyouts are marked with a small white triangle in 
the lower right corner. To open the flyout toolbar, hold down 
the left mouse button for a moment or press the right mouse 
button.  

 

 
The Lines toolbar is linked to the Main1 toolbar.  
After the flyout is open you can pick any of the 
buttons on the toolbar to start a command. 

 

Graphics Area  

The Rhino graphics area, holding the viewports, can be customized to suit your preferences. The position of 
viewports can be arranged in different configurations. 
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Viewports 

Viewports are windows in the graphics area that show you views of your model. To move and resize viewports, 
drag the viewport title or borders. You can create new viewports, rename viewports, and use predefined viewport 
configurations. Each viewport has its own construction plane that the cursor moves on and a projection mode. 

To toggle between a small viewport and one that fills the graphics area, double-click the viewport title. 

 
Rearranged Rhino screen. Command line at the bottom, single maximized viewport, and toolbars  
docked in different locations. 
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Viewport tabs 

Viewport titles can be shown in tabs. The bold face tab designates the active viewport. Tabs make it easy to 
switch between viewports when using maximized or floating viewports. To activate Viewport Tabs: From the View 
menu, click Viewport Layout, and then click Show Viewport Tabs. 

 
The tabs are located below the graphics area. 
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Command Area 

The command area displays commands and command prompts. It can be docked at the top or the bottom of the 
screen or it can float anywhere. The command window shows two lines by default. To open a window that displays 

the command history, press F2. The text in the Command History window can be selected and copied to the 
Windows clipboard. 

The Mouse  

In a Rhino viewport, the left mouse button selects objects and picks locations. The right mouse button has several 
functions including panning and zooming, popping up a context-sensitive menu, and acting the same as pressing 
the Enter key. Use the left mouse button to select objects in the model, commands or options on the menus, and 
buttons in the toolbars. Use the right mouse button to complete a command, to move between stages of 

commands, and to repeat the previous command. The right mouse button is used to initiate commands from some 
toolbar buttons. 

Drag with the right mouse button to pan and rotate in viewports. Use the mouse wheel or hold down the Ctrl key 
and drag with the right mouse button to zoom in and out in a viewport. You must press and hold the right mouse 
button down to activate this feature.  

Entering Commands 

Use the command line to type commands, pick command options, type coordinates, type distances, angles, or 
radii, type shortcuts, and view command prompts. 

To enter information typed at the command line, press Enter, Spacebar, or right mouse button over a viewport. 

Note: Enter and Spacebar perform the same function. 

Shortcuts are customizable key combinations. You can program the function keys and Ctrl key combinations to 
perform Rhino commands. 

Clickable options 

To use command options, click the option on the command line or type the underlined letter of the option and 
press Enter. (The interior capitalization is meaningless.)  
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Autocomplete command name 

Type the first few letters of a command name to activate the autocomplete 

command list. When enough letters of the command are typed so that it is 
unique, the command name completes on the command line. Press Enter to 
activate the command once the full command name appears. As you type 
command names, the autocomplete command list appears. As you type more 
letters, the list is narrowed down to the possible commands. Left click on the 
command in the list to start it. 

 

 

Repeating commands 

To repeat the last command, right-click in a viewport, press Enter, or press the spacebar. To repeat previous 
commands, right-click in the command line window and select from a list. 

Canceling commands 

To cancel a command, press Esc or enter a new command from a button or a menu. 
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Help 

Press F1 at any time to access Rhino Help. In addition to finding information about each command, Rhino help has 
conceptual information as well as many examples and graphics to help you complete your model. When you are 

confused or unsure about what to do, the first place you should look is the help file. You can also access help for a 
specific command by starting the command and press F1. 

In addition, the CommandHelp command displays the help topics in a dockable window and displays help for the 
current command. 

Most of the commands include short video clips that show how the command and the options work. 

 
If Auto-update is checked, the help for the current command displays. If Auto-update is unchecked, 

you can type the name of the command that you want displayed and press enter to display  

the  information. 
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View the Command Line History 

The command history window lists the last 500 

command lines from the current Rhino session. Press 
F2 to view the command history. 

 

View Recent Commands 

Right-click the command line to view recently used commands. To repeat 
the command, select it from the popup menu. 

The number of commands listed is set in Rhino Options. The default limit 
is twenty commands. When you use your twenty-first command the first 

one drops off the list. 
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Exercise 1—Rhino basics 

To get started: 

1 On the Rhino Help menu, click Learn Rhino, Open Tutorial Models. 

2 Double-click the Level 1 folder.  

3 In the Open dialog box, select Start.3dm. 

You will find this model in the Training folder. If you haven’t copied the files to your hard drive from the 
Training folder on the Rhino CD, you should do this before you proceed. 

  
Two parallel viewports and one perspective viewport. 

This model contains five objects: a cube, a cone, a cylinder, a sphere, and a rectangular plane. 

 
Open 
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4 From the View menu, click Viewport Layout, and then click 4 Viewports. 

  
Three parallel viewports and one perspective viewport 

5 In the Status Bar, click Snap to turn on the grid snap. 

Grid snap may already be on in your system. Be careful that you do not turn it off instead of on. If grid snap is 
on, the word ―Snap‖ will be black in the status bar. If it is off, the word ―Snap‖ will be gray. 

 

Note: This is an important step. Grid snap only lets your cursor move in certain intervals. In this model, by 

default, grid snap is set to one half of a grid line. Grid snap helps you line up your objects as if you were 
building with LEGO blocks. 

 

 

 
4  Viewports 
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6 Click the mouse in the Perspective 
viewport to make it active. 

The viewport title highlights when it is 
active. The active viewport is the viewport 
where all your commands and actions take 
place. 

7 Click with the Right Mouse Button 
(RMB) on the Perspective viewport title, 
and then click Shaded.  

The objects appear shaded. A shaded 

viewport lets you preview the shapes. The 
viewport will remain shaded until you 
change it back to a wireframe view.  

You can change any viewport to shaded 
mode. Later we will discuss the other 
viewport display options. 

 

 

Shaded display. 

8 From the Render menu, click Render.  

Rendering the model opens a separate render window. The 

model displays in render colors previously assigned to the 

objects. You can also set lights and a background color. You will 
learn about doing this later.  

You cannot manipulate the view in the render display window 
but the image can be saved to a file. 

9 Close the render window. 

 

Render. 

 

 
Shaded Viewport 

 
Render 
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10 In the Perspective 
viewport, click and 
drag with your right 
mouse button held 

down to rotate the 
view. 

The plane helps you 
stay oriented. If the 

objects disappear, 
you are looking at 
the bottom of the 
plane. 

11 Right click on the 
Perspective 
viewport title, and 
then click X-ray. 

 

Rotate the view in shaded display. 

 

X-Ray shaded display. 

12 Right click on the 
Perspective 
viewport title, and 

then click Ghosted. 

13 Right click on the 
Perspective 

viewport title, and 
then click 

Rendered. 

 

Ghosted shade display. 

 

Rendered display 

 

 

 
X-Ray Viewport 

 
Rendered Viewport 

 
Ghosted Viewport 
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14 Change to 
Wireframe mode. 

15 To rotate your view, 
drag from the 
bottom of the view 

toward the top. 

You are now under 
the objects looking 
up. 

16 Change to Shaded 
mode. 

The plane obscures 
the objects. In 
shaded mode, the 
plane helps you see 
when your viewpoint 
is below the objects. 

 

Looking at the objects from the bottom in 
wireframe mode. 

 

Looking at the objects from the bottom in 
shaded mode. 

 

To get back to your original view: 

 Press the Home key to undo your view changes. 

If you are ―lost in space‖ in the perspective view: 

 From the View menu, click Viewport Layout, and then click 4 Viewports twice. 

This takes you back to the default viewport settings. 

 

 

 

 
Wireframe Viewport 
Right Click 
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Navigating Around the Model 

You have used the right mouse button to rotate in the Perspective viewport. You can hold Shift and drag with 
the right mouse button to pan. Dragging the right mouse button to move around does not interrupt any 

commands in progress.  

To pan in a viewport: 

1 In the Perspective 
viewport, hold the 
Shift and drag with 

the right mouse 
button to pan the 

view. 

2 Pan the view in the 
parallel viewports by 

dragging with the 
right mouse button. 

In the parallel 
viewports it’s not 

necessary to press 
the Shift key. Panning with Shift and the right 

mouse button. 

 
Panning in a parallel view with the right 
mouse button. 

What if … 

Instead of panning or rotating, 
something funny happened. 

If you right-click quickly once in 
viewport, the last command 
starts again. You must hold the 
right mouse button down while 
panning or rotating.  
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Zooming in and out 

Sometimes you want to get closer to your objects or move back so you can see more. This is called zooming. As 
with many things in Rhino, there are several ways to do this. The easiest way is to turn the mouse wheel to zoom 
in and out. If you don’t have a wheel mouse,  hold down the Ctrl key and drag up and down in a viewport with 
the right mouse button.  

To zoom in and out: 

1 In the Perspective Viewport, roll the wheel on your mouse 
forward to zoom in, roll it backward to zoom out.  

The camera zooms at cursor position. 

2 In the Perspective viewport, hold the Ctrl key, click and hold 

the right mouse button, and drag the mouse up and down.  

Drag up to zoom in. 

Drag down to zoom out. 

 
Zooming with ctrl and the right mouse 
button. 

 

Zooming extents 

The Zoom Extents command, displays a viewport so the objects fill up the viewport as much as possible. You can 
use this command to make everything visible.  

To zoom extents in a viewport: 

 From the View menu, click Zoom, and then click Zoom Extents. 

If you get lost, it is often handy to zoom extents in all your viewports at once, so there is a command to do 
just that. 

To zoom extents in all viewports: 

 From the View menu, click Zoom, and then click Zoom Extents All. 

 

  
Zoom Extents 
Left Click 

  
Zoom Extents All Viewports 
Right Click 
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Move Objects 

Dragging follows the construction plane of the current viewport. 

Now drag the objects around. You can drag in any viewport. In this model, Snap is set to one-half of a grid line. 
Using this snap, you should be able to line objects up with each other. 

To move objects: 

1 Click the cone and drag it. 

The cone highlights to show it is selected. 

 

 
The selected cone highlights. 

 

2 Drag the cone in the Perspective viewport until it lines up with 

the cylinder. 

It will be inside the cylinder. 

The cone moves on the base that is represented by the grid. This 
base is called a construction plane. Each viewport has its own 
construction plane. When you start Rhino, the Perspective 
viewport has the same construction plane as the Top viewport. 
You will learn more about using construction planes later. 

 
Drag the cone to move it. 
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3 In the Front viewport, drag the cone to the top of the cylinder. 

Watch what happens in the Perspective viewport. 

There are many times when you have to watch what is happening 
in other viewports to accurately place your objects. 

 
Move the cone in the Front viewport. 

 

4 Click in the Perspective viewport. 

5 Change the viewport to a Rendered Display. 

 
Rendered Display. 

Try on Your Own 

1 Re-open the model. Do not save changes. 

2 Drag the objects around. 

Use the Front viewport to move the objects vertically and the Top or Perspective viewport to move them 
horizontally. 
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Copy Objects 

To create more objects, copy the shapes.  

To start with a new model: 

1 From the File menu, click Open. 

2 Do not save the changes. 

3 In the Open dialog box, select Start.3dm. 

To copy objects: 

1 Click the box to select it. 

2 From the Transform menu, click Copy. 

3 Click somewhere in the Top viewport. 

It usually helps to click a spot that relates to the object like the 
middle or near a corner. 

 

 
Select and copy the box. 

 

4 Click where you 
want the first copy. 

Zoom in closer if 
you like.  

5 Click other places 
to make more 
copies of the box. 

6 When you have 

enough copies, 
press Enter.  

  

 

 
Copy 
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Try on Your Own 

 Make copies of more objects and move them around. See if you 

can build something. 

 

 

Changing the View of Your Model 

When you add detail to your models, you will need to see different parts of your model with different 
magnifications. You can use the view commands, the mouse, and the keyboard to change the view in a viewport. 

Each view corresponds to the view through a camera lens. The invisible target of the camera is located in the 
middle of the viewport. 

Viewports  

With Rhino, you can open an unlimited number of viewports. Each viewport has its own projection, view, 

construction plane, and grid. If a command is active, a viewport becomes active when you move the mouse over 
it. If a command is not active, you must click in the viewport to activate it.  

Most viewport controls can be accessed through the viewport popup menu.  

To open the popup menu, right click the viewport title. 

Parallel vs. Perspective Projection  

Unlike other modelers, Rhino lets you work in both parallel and perspective views.  

To toggle a viewport between parallel and perspective view: 

1 Right-click the viewport title, click Viewport Properties.  

2 In the Viewport Properties dialog box, click Parallel or Perspective, and then click OK.  
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Panning and Zooming  

The simplest way to change the view is to hold down the Shift key and drag the mouse with right mouse button 
held down. This pans the view. To zoom in and out, hold down the Ctrl key and drag up and down or use the 

mouse wheel. 

You can also use the keyboard to navigate: 

Key Action + Ctrl  

Left Arrow Rotate left Pan left 

Right Arrow Rotate right Pan right 

Up Arrow Rotate up Pan up 

Down Arrow Rotate down Pan down 

Page Up Zoom in  

Page Down Zoom out  

Home Undo View Change  

End Redo View Change  

You can change your view in the middle of a command to see precisely where you want to select an object or 

select a point. 

There are additional Zoom controls that will be discussed in other exercises. 

Resetting Your View  

If you get lost, four view techniques can help you get back to a starting place. 

To undo and redo view changes: 

 Click in a viewport, press your Home or End key on your keyboard to undo and redo view changes. 

To set your view so you are looking straight down on the construction plane: 

 From the View menu, click Set View, and then click Plan. 

To bring all your objects into view: 

 From the View menu, click Zoom, and then click Zoom Extents. 

To bring all your objects into view in all viewports: 

 From the View menu, click Zoom, and then click Zoom Extents All. 
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Exercise 2—Display options 

 Open the model 

Camera.3dm.  

You will use this to practice 
changing views. You will 
create views from six 

directions and an oblique 
perspective view. 
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To change the number of viewports: 

1 Make the Top viewport 
active. 

2 From the View menu, click 
Viewport Layout, and then 

click Split Horizontal. 

3 Make the Front viewport 
active. 

4 From the View menu, click 
Viewport Layout, and then 

click Split Vertical. 

5 Repeat this step for the Right 
Viewport. 

6 Right click on the Top 
viewport title at the top, click 
Set View, then, click 

Bottom. 

7 Right click on the Front 
viewport title on the left, click 
Set View, then, click Left. 

8 Right click on the Right 

viewport title on the right, 
click Set View, then, click 
Back. 

 
Each viewport is Split down the middle either horizontally or vertically. 

 

To change the shape of viewports: 

1 Move your cursor to the edge of a viewport until you see the resizing  or  cursor, hold the left mouse 

button down, and drag the bar. If two viewports share the edge, both resize. 

2 Move your cursor to the corner of a viewport until you see the resizing  cursor, hold the left mouse, and 

drag the intersection in any direction. If several viewports touch at that corner, all resize. 

 
Split Viewport Horizontally 
 

 
Split Viewport Vertically 
 
 
 

 
Bottom View 
 

 
Left View 
 

 
Back View 
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To synchronize the viewports: 

1 Adjust the size shape of the 
viewports. 

2 Make the Front viewport 
active. 

3 From the View menu, click 
Zoom, and then click Zoom 
Extents. 

4 Right click on the Front 

viewport title, click Set 

Camera, and then click 
Synchronize Views. 

5 Change the viewport displays 
to one of the shaded viewport 

settings. 

 
All the views are sized to the same scale as the active viewport and aligned 

with each other. 

 

To zoom to a window:  

1 From the View menu, click Zoom, 

and then click Zoom Window. 

2 Click and drag a window around a 
portion of the model. 

  

 
Synchronize Views 

 
Zoom Window 
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To zoom a selected object:  

1 Select the shutter release. 

2 From the View menu, click Zoom, 
and then click Zoom Selected. 

The view zooms to the selected 
object. 

  

To rotate the view: 

1 In a perspective viewport, drag with right mouse button. 

2 In a parallel viewport, use the arrow keys. 

To maximize and restore a viewport: 

1 Double-click the viewport title to maximize it. 

2 Double-click the title of the maximized viewport to restore it to its smaller size and reveal the other viewports. 

 

 

 
Zoom Selected 



 

 

Part Two: 
Creating Geometry 
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3  Creating Two-Dimensional 
Objects 

Drawing Lines 

The Line, Lines, and Polyline commands draw straight lines. The Line command draws a single line segment. 
The Lines command draws multiple end-to-end line segments. The Polyline command draws a series of straight 
joined segments (a single linear curve with multiple segments).  

Option Description 

Close Closes the shape by drawing a segment from the last point picked to the first point picked. This 
ends the command. 

Undo Deletes the last point picked. 
 

Exercise 3—Drawing lines 

1 From the File menu, click New.  

Do not save changes. 

2 In the Template File dialog box, double click Small Object - Millimeters.3dm. 

3 From the File menu, click Save As. 

4 In the Save dialog box, type Lines, and then click Save. 
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To draw line segments: 

1 From the Curve menu, click Line, and then click Line 
Segments to begin the Lines command. 

2 Pick a point in a viewport. 

3 Pick another point in a viewport. 

A line segment appears between the two points. 

4 Pick another point. 

5 Continue to pick points. 

Additional segments appear.  

Each segment meets but is not joined to the previous segment. 

6 Press Enter to end the command. 

 
 

To use the Close option: 

1 Repeat the Lines command. 

2 Pick a Start point. 

3 Pick 3 or 4 more points. 

4 Click Close. 

The last line will end at the original start point. Line segments are individual lines that meet at a common 

endpoint. 
 

To draw a polyline: 

1 From the Curve menu, click Polyline, and then click Polyline to 

begin the Polyline command. 

2 Pick a Start point. 

3 Pick 3 or 4 more points. 

4 Press Enter when done. 

This makes an open polyline. A polyline is made of line segments 

that are joined together. It is one object. 

 

 

  
Line Segments 
Right Click 

  
Polyline 
Left Click 
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To use the Undo option: 

1 Repeat the Polyline command. 

2 Pick a Start point. 

3 Pick 3 or 4 more points. 

4 Click Undo on the command line.  

Notice that your cursor moves back to the previous point and one segment of the polyline is removed. 

5 Continue to pick points.  

6 Press Enter or click Close to end the command. 

To draw a single line segment: 

1 From the Curve menu, click Line, and then click Single Line to 
begin the Line command. 

2 Pick a Start point. 

3 Pick an End point. 

The command ends after one segment is drawn. 

 

 

To use the Bothsides option: 

1 From the Curve menu, click Line, and then click Single Line to 
begin the Line command. 

2 Click Bothsides on the command line. 

3 Pick a Middle point. 

4 Pick an End point. 

A segment is drawn with equal length on both sides of the middle 
point. 

 

  
Line 
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Drawing Free-form Curves 

The InterpCrv and Curve commands draw free-form curves. The InterpCrv command draws a curve through 
the points you pick. The Curve command uses control points to create a curve. 

Option Description 

Close Closes the shape by drawing from the last point picked to the first point picked. This ends the 
command. 

EndTangent After choosing a point on another curve, the next segment will be tangent to the point you 
picked and end the command. 

Undo Deletes the last point picked. 

Degree You can set the degree of the curve. 

Knots Determines how the interpolated curve is parameterized. 

When you draw an interpolated curve, the points you pick are converted into knot values on 
the curve. The parameterization means how the intervals between knots are chosen. 

Sharp When you make a closed curve, it will come to a point instead of making a smooth closure as 
it normally does. 

 

Exercise 4—Drawing interpolated curves 

1 From the Curve menu, click Free-form, and then click 
Interpolate Points. 

2 Pick a Start point. 

3 Continue picking points. 

4 Click Close to make a closed curve or, press Enter to end the 
command. 

 

 

 

 

 

 

 

 
Curve: Interpolate Points 
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Exercise 5—Drawing curves from control points 

1 From the Curve menu, click Free-form, and then click Control 
Points. 

2 Pick a Start point. 

3 Continue picking points. 

4 Click Close to make a closed curve or, press Enter to end the 
command. 

 

 

 

Modeling Aids    

Modes are modeling aids that you can toggle on or off by pressing shortcut keys, a function key, typing a single 
letter command, or clicking a button.  

 

Click the Snap, Ortho, Planar or History panes on the status bar to toggle these modeling aids on and off. 

Snap 

Forces the marker to snap on grid intersections.  

You can also toggle Snap on and off by pressing F9 or typing the letter S and pressing Enter. 

Ortho 

Restricts cursor movement to the points at a specified angle from the last point created. The default angle is 90 
degrees. 

You can also toggle Ortho on and off by pressing F8 or pressing and holding the Shift key down.  

If Ortho is set to on, hold down the Shift key to toggle Ortho off. If Ortho is off, hold down the Shift key to toggle 

Ortho on. F8 or Shift. 

 

 

 

 

Notice that most of the points 
you pick are off the curve as 
control points. 

 
Control Point Curve 
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Planar 

This is a modeling aid similar to Ortho. This helps you model planar objects by forcing input to be on a plane 
parallel to the construction plane that passes through the last point that you picked. 

You can also toggle Planar On-Off by typing the letter P and pressing Enter. 

History 

Records history and updates history-aware objects. With History recording and Update turned on, a lofted surface 
can be changed by editing the input curves. 

In general, it is best to leave the Record option set to No and use the Record History status bar pane to 
selectively record history. Recording history uses computer resources and makes saved files larger. 

Grid 

Pressing F7 hides or shows a reference grid in the current viewport of the graphics screen at the construction plane. 

Exercise 6—Drawing lines and curves using mode functions 

1 Toggle Snap on and draw some lines. 

The marker snaps to each grid intersection. 

2 Toggle Snap off, toggle Ortho on and draw some lines and curves. 

You can only input points that are at 90 degree intervals from the last point. Using Snap and Ortho toggles 
you can draw with precision. We will discuss other ways to get precision in a later session. 
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Model Setup  

In Rhino you can create full-size models using precise measurements. You might need to change the modeling 
environment depending on the type of model you are creating; the default options may not always work.  

To change the options: 

1 From the File menu, click Properties. 

2 In the Document Properties dialog box, under Rhino Options, click Modeling Aids. 

Modeling Aids lets you control Ortho, Object Snap, Grid Snap, and other mode options.  

3 Change the Ortho option to snap every 30 degrees. 

4 In the Document Properties dialog box, click Grid. 

5 In Grid properties, change the following settings. 

You can change the appearance of the modeling environment by changing the grid elements. The grid 
spacing, the frequency of the major lines, and the number of grid elements can be changed. The Grid dialog 
box lets you configure grid settings. 

6 Change the Grid Extents setting to 10. 

7 Change the Minor grid lines every setting to 1. 

8 Change the Major lines every setting to 4. 

9 Change the Snap Spacing setting to .25, and click OK. 

10 Draw some more lines and curves with Snap and Ortho on. 

Notice that the marker now snaps between the grid intersections 
and that Ortho snaps at every 30 degrees. 

11 Try to draw the closed polyline to the right with Snap and Ortho 
turned on. 

3.0

5.0

3.0

1.0 1.5

30°

3.5

3.0

 

To reset the modeling aids options: 

1 From the Tools menu, click Options. 

2 In the Rhino Options dialog box, click Modeling Aids. 

3 Change the Ortho options to snap every 90 degrees. 

  
Document Properties 

The value for Grid extents is for 
each quadrant. 
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Saving Your Work 

Save your work periodically during a session to keep it from being accidentally deleted.  

To save your model: 

 From the File menu, click Save. 

Or, click one of the other options. You will have an opportunity to save your work. 

Command Description 

Save Saves your model and keeps it open. 

SaveSmall Save your model without render or analysis meshes and preview image to minimize file 
size. 

IncrementalSave  Save sequentially numbered versions of your model. 

SaveAs Saves your model to a specified file name, location, and format.  

SaveAsTemplate Save as a template. 

 

Layers  

Rhino layers work like CAD layering systems. By creating objects on different layers, you can edit and view related 
portions of a model separately or as a composite. You can create as many layers as you like. 

You can display all layers simultaneously or turn any of them off. You 

can lock layers so they are displayed but cannot be selected. Each 
layer has a color. You can assign a name to each layer (for example, 
Base, Body, Top) to organize the model or you can use preset layer 
names (Default, Layer 01, Layer 02, Layer 03).  

The Layers window manages layers. Use it to set up layers for your 
model. 

 

 
Save 

It is good practice to save your 
model in stages under different 
names, using the Save As 
command. This lets you go back 
to an earlier version of your 
model for modifications if 
necessary. 

 
Edit Layers 
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Exercise 7—Layers  

To create a new layer: 

1 From the Edit menu, click Layers, and then click Edit Layers. 

2 In the Layers window, click New. 

3 The new layer, Layer 06, appears in the list. Type Line and 

press Enter. 

4 Click New. 

5 The new layer, Layer 06, appears again. Type Curve and press 
Enter. 

 
The Default layer is created automatically 

when you start a new model with no 
template. If you use a standard Rhino 
template, a few additional layers are also 
created. 

 

To assign a color to a layer: 

1 Click the Color patch on the Line row in the list. 

2 In the Select Color dialog box, click Red from the list. 

 The right half of the sample rectangle turns red. 

Hue, Sat, Val are the hue, saturation and value components of 
the color.  

R, G, and B are the red, green and blue components of the 
color. 

3 Click OK. 

4 In the Layers window, the new color appears in the color bar 
on the Line row of the layer list. 

5 Repeat steps 1–3 to make the Curve layer Blue. 

6 Click OK to close the dialog box, 

 

Hue is controlled by moving the 
line around the circular portion of 
the color wheel. 

Hue is the color that is referred to 
as a scale ranging from red 
through yellow, green and blue 
and then circularly back to red. 

Saturation and Value are 
controlled by moving the small 
circle around in the square 
portion in the middle of the color 
wheel. 

Saturation is the vividness of 
hue. Value is the relative 
lightness or darkness of a color. 
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To make a layer current: 

1 In the Status Bar, click the Layer pane. 

2 In the Layer popup, click Line. 

3 Draw some lines. 

The lines are on the Line layer and they are colored red. 

4 To make a different layer current, click the Layer pane of the status bar. 

5 Click Curve. 

6 Draw some curves. 

They are on the Curve layer and are colored blue. 

7 Draw more lines and curves on each layer. 

Clicking the name or 

the checkbox sets the 
current layer. 

 

To lock a layer: 

1 In the Status Bar, click the Layer pane. 

2 In the Layer popup, click the Lock icon on the row for the Line layer. 

Locking a layer turns it into a reference only layer. You can see and snap to objects on locked layers. You 
cannot select any objects on locked layers. You cannot make a locked layer current without unlocking it.  

 

To turn a layer off: 

1 In the Status Bar, click the Layer pane. 

2 In the Layer popup, click the On/Off icon (light bulb) in the row for Curve. 

Turning a layer off makes all objects on it invisible. 
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Exercise 8—Selecting objects  

To select a single object: 

 Move your pointer arrow over the object and left-click. 

The object turns yellow, which is the default highlight color. 

 

To select more than one object: 

1 Move your pointer arrow over the first object and left-click. 

2 While holding the Shift key down, move your pointer over another object and left click. 

 

To select more than one object using a window: 

1 Move your pointer arrow into an open area to the left of the objects you want to select.  

2 Hold your left mouse button down and drag diagonally to the right until you have several objects inside the 

selection box.  

The window selection box is a solid rectangle. 

3 Release your mouse button. 

All objects completely inside the selection box will be selected. 

4 To add to your selection set, hold the Shift key down while making another selection. 

 

To select more than one object using a crossing window: 

1 Move your pointer arrow into an open area to the right of the objects you want to select. 

2 Hold your left mouse button down and drag diagonally to the left until you have several objects inside or 

touching the box.  

The crossing selection box is a dotted rectangle. 

3 Release your mouse button. 

All objects inside or touching the box will be selected. 

4 To add to your selection set, hold the Shift key down while making another selection. 
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To hide an object: 

1 Select an object. 

2 From the Edit menu, click Visibility, and then click Hide. 

The object becomes invisible. 

 

To show hidden objects: 

 From the Edit menu, click Visibility, and then click Show. 

The Show command redisplays all hidden objects. 

 

To lock an object: 

1 Select an object. 

2 From the Edit menu, click Visibility, and then click Lock. 

The object becomes shaded gray. You can see the locked object, you can snap to it, but you cannot select it. 

 

To unlock locked objects: 

 From the Edit menu, click Visibility, and then click Unlock. 

The Unlock command redisplays all locked objects. 

 

To change an object from one layer to another: 

1 Select an object. 

2 From the Edit menu, click Layers, and then click Change Object Layer. 

3 In the Layer for object dialog box, select the new layer for the object, and 

click OK. 

 

 

  
Hide Objects 
 

  
Show Objects 

  
Lock Objects 
 

  
Unlock Objects 

 
Change Object Layer 



 

Notes: 

Robert McNeel & Associates 45 

Selecting Objects 

Delete removes selected objects from the model. Use Delete to practice selecting objects. 

Exercise 9—Practice using selection options 

1 From the File menu, click Open. 

2 In the Open dialog box click Delete.3dm and click Open, or 
double-click Delete.3dm to open the model. 

3 Select the square and the circle. 

4 From the Edit menu, click Delete or press the Delete key. 

The objects disappear. 
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To start the first practice: 

1 Select one of the lines on the hexagon in the Top viewport. 

Because there are several curves superimposed on each other, 
the selection menu appears, allowing you to select one of the 
curves. 

2 Select the top curve from the list.  

3 From the Edit menu, click Delete. 

Observe one disappear in the Perspective viewport. 

 

4 In the Top viewport, use a crossing box to select the surface 
and the polyline in the top right part of the drawing. 

Both objects are selected.  

5 From the Edit menu, click Delete.  

6 Make a window to select the polyline and the cylinder in the 
lower right part of the drawing. 

Only those objects that are completely inside the window are 
selected. 

 

7 Hold the Ctrl key down and click on the cylinder to remove it 
from the selection set. 

8 From the Edit menu, click Delete. 

9 Continue deleting objects in the drawing.  

Practice using different selection methods to select and deselect 
objects. Use crossing and window. The Shift key while selecting 
will let you add to your selection set. The Ctrl key while selecting 
will let you to remove objects from your selection set. 
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To undo and redo deletions: 

1 From the Edit menu, click Undo. 

Each time you click, Undo takes you back one command. 

2 From the Edit menu, click Redo. 

Each time you click, the previous Undo is reinstated. 

3 Undo all the deletions you made in the previous exercise. 

Additional selection options 

In addition to the selection options we just practiced, there are several other useful tools for selecting objects. In 
the next exercise we will use some of these tools. 

Command Button Menu Label Description 

SelAll 
 

All Objects (Ctrl+A) Select all objects. 

SelNone 
 

None (Esc) Deselect all objects. Note: SelNone does not run inside a command to clear pre-
selected objects. 

Invert 
 

Invert Deselects all selected objects and selects all visible objects that were not previously 
selected. 

SelPrev 
 

Previous Selection Re-selects the previous selection set. 

SelLast 
 

Last Created 
Objects 

Selects the last changed objects. 

SelPt 
 

Points Select all point objects. 

SelCrv 
 

Curves Select all curves. 

SelPolyline 
 

Polylines Select all polylines.  

SelSrf 
 

Surfaces Select all surfaces. 

SelPolysrf 
 

Polysurfaces Select all polysurfaces. 
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To select objects using select tools: 

1 From the Edit menu, click Select Objects, and then click Curves. 

All the curves are selected. 

2 From the Edit menu, click Select Objects, and then click Invert. 

Everything but the previously selected curves is selected. 

3 From the Edit menu, click Select Objects, and then click None. 

Everything is unselected. 

4 From the Edit menu, click Select Objects, and then click Polylines. 

All of the polylines are selected. 

5 From the Edit menu, click Select Objects, and then click Surfaces. 

The single surface is added to the selection set. 

6 From the Edit menu, click Select Objects, and then click Polysurfaces. 

The polysurfaces are added to the selection set. 

7 From the Edit menu, click Select Objects, and then click None. 

8 Draw a few lines and curves. 

9 From the Edit menu, click Select Objects, and then click Last Created Objects. 

The things you just created are selected. 

 

 

 

 

 

 

 

 

 

  
Select Curves 
 

  
Invert Selection 
 

  
Select Polylines 
 

  
Select Surfaces 
 

  
Select Polysurfaces 
 

  
Select None 
 

  
Select Last Created Object 
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4  Precision Modeling 

 

So far you have been drawing imprecise lines. Now you will try drawing lines at specific places. To do this you will 
use coordinates.  

Whenever you draw a curve, or create a solid primitive, Rhino asks you for a series of points. You can tell that 
Rhino is asking for point input two ways: the command prompt has a prompt like Start of line, Start of 
polyline, Start of curve, or Next point and the arrow-shaped cursor turns into a cross-shaped cursor.  

You can enter a point two ways: pick a point in a viewport with the mouse, or type coordinates at the command 
line.  

Rhino uses a fixed Cartesian coordinate system called the world coordinate system (WCS), based on three axes 
(the x-, y-, and z-axes) that define locations in three-dimensional space. 

Each viewport has a construction plane that defines coordinates for that viewport. We will work in the Top and 

Perspective viewports where the two coordinate systems are the same.  

Absolute Coordinates 

The first forms of coordinates you will use are called absolute coordinates. Absolute coordinates are exact 
locations relative to the x-, y-, and z-axes.  

Exercise 10Setting up a model  

1 From the File menu, click New. 

2 Click Small Object - Millimeters.3dm, and then click Open. 

3 From the File menu, click Save As. Name the model BOXES. 

Use the BOXES.3dm model to learn how to draw with absolute coordinates.  

Set the units and tolerance of the 
model before you begin. 
 
You can change the tolerance 
after you start, but objects 
created before the change still 
have the old tolerance value. 

  
Cross-shaped cursor 
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Exercise 11—Entering absolute coordinates 

1 Double-click the viewport title to maximize the Top viewport. 

2 From the Curve menu, click Polyline, and then click Polyline. 

3 To Start type 0 and press Enter. 

If you are going to start at the origin of the sheet (0,0,0) you can 
simply type 0 as a shortcut. 

4 For the Next point type 5,0 and press Enter. 

5 For the Next point type 5,5 and press Enter. 

6 For the Next point type 0,5 and press Enter. 

7 Click Close to close the polyline. 

0,5 5,5

5,00,0  

Relative Coordinates 

Absolute coordinates can be slow and cumbersome, but they do work. Most of the time, relative coordinates are 

easier to use. 

Every time you select a point, Rhino saves that point as the last 

point.  

Relative coordinates are based on the last point entered, instead of 
on the origin (0,0,0) of the construction plane.  

Precede the x,y,z coordinates with a single R (upper or lower case) to 

enter relative coordinates. Use the @ symbol instead of an R to start 

relative coordinates if you prefer. 

Next Point

Last Point

Change in Y

Change in X  

Exercise 12—Entering relative coordinates 

1 From the Curve menu, click Polyline, and then click Polyline. 

2 To Start type 8,0 and press Enter. 

These are absolute coordinates. 

3 For the Next point type R5,5 and press Enter. 

These are relative coordinates. 

4 For the Next point type R-5,0 and press Enter. 

5 Click Close to close the polyline. 
5
.0

0

R5,5

8,0

R-5,0

5.00  

 
Polyline 
Left Click 
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Polar Coordinates 

Polar coordinates specify a point that is a distance and direction away from 0,0 in the current construction 

plane.  

Vector directions in Rhino start with Zero degrees at 3 o'clock on a standard clock. They change in an anti-
clockwise direction as illustrated below.  

For example, if you want a point 

four units away from the 
construction plane origin, at a 45° 
angle anticlockwise from the 

construction plane x-axis, type 
4<45, and press Enter.  

Relative polar coordinates are 
preceded by R or @; absolute polar 
coordinates are not.  

 

Next Point

Last Point

Angle
Distance

 

Instead of using x-, y-, and z-

coordinates, enter relative polar 
coordinates like this: Rdistance<angle. 

120

300

27
0

210

150

9
0

60

30

0

330

24
0

180

 

Exercise 13—Entering polar coordinates 

1 From the Curve menu, click Polyline, and then click Polyline. 

2 To Start type 0,8 and press Enter. 

3 For the Next point type R5<0 and press Enter. 

4 For the Next point type R5<90 and press Enter. 

5 For the Next point type R5<180 and press Enter. 

6 Click Close to close the polyline. 

R5<180

0,8 R5<0

R5<90
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Distance and Angle Constraint Entry 

Using distance constraint entry, you can specify a point by typing a distance and pressing Enter. Then as you 
move your cursor in any direction, the distance from the last point will be constrained. This is a good way to 

specify a line length quickly. 

Using angle constraint entry, you can specify an angle by typing < followed by a value and pressing Enter. The 
next point is constrained to lines at multiples of the angle relative to the x-axis you specified. 

Using the Shift key to toggle Ortho on and off: 

When Ortho is off, hold the Shift key down to toggle it on. This method is an efficient way to draw perpendicular 
lines. In the following example, draw a line five units long using distance constraints. 

Exercise 14—Distance constraint entry 

1 From the Curve menu, click Polyline, and then click Polyline. 

2 To Start type 8,8 and press Enter. 

3 For the Next point type 5 and press Enter. 

4 Hold the Shift key down and pick a point to the right. 

Ortho constrains the marker to 0 degrees.  

5 For the Next point type 5 and press Enter. 

6 Hold the Shift key down and pick a point up. 

Ortho constrains the cursor to 90 degrees 

7 For the Next point type 5 and press Enter. 

8 Hold the Shift key down and pick a point to the left. 

Ortho constrains the cursor to 180 degrees. 

9 Click Close to close the polyline. 

Distance Constraint
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Exercise 15—Distance and angle constraint entry 

1 From the Curve menu, click Polyline, and then click Polyline. 

2 To Start type 16,5 and press Enter. 

3 For the Next point type 5 and press Enter, then type <45 and press 
Enter. 

As you drag your cursor around, the marker snaps to a distance of 5 
and an angle of 45 degrees. 

4 Pick a point down and to the right.   

The angle constraint sets the angle. 

5 For the Next point type 5 and press Enter, then type <45 and press 

Enter. 

6 Pick a point up and to the right. 

The angle constraint sets the angle. 

7 For the Next point type 5 and press Enter, then type <45 and press 
Enter. 

8 Pick a point up and to the left. 

The angle constraint sets the angle. 

9 Click Close to close the polyline. 

10 Save your model. You will use this model for another exercise. 

Angle Constraint
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Exercise 16—Practice using distance and angle constraint entry 

1 Start a new model, use the Small Objects - Millimeters.3dm template. Save as Arrow. 

Since the object is symmetrical, you will only draw the lower half of the model. 

 

2.00

2.00 1.00

1.00
2.00

6.0011.008.00

START MODEL AT -11,0

 

Draw the arrow with a polyline, using a combination of absolute coordinates (x,y), relative coordinates (Rx,y), 
polar coordinates (Rdistance<angle), and distance constraint.  

The following is an example of the command line input that you might use: 

Absolute x,y 

2 From the Curve menu, click Polyline, then click Polyline. 

3 For the Start of Polyline type -11,0. 

Relative x,y 

4 For the Next point, type r-2,-2. 

Distance constraint 

5  For the Next point, type 8 and press Enter, turn Ortho on and then pick to the right. 

Relative x,y 

6  For the Next point, type r1,1. 

Relative polar 

7  For the Next point, type r11<0. 

Distance constraint 

8  For the Next point, type 1 and press Enter, turn Ortho on and then 
pick down. 

Relative x,y 

9  For the Next point, type r6,2. 

10  For the Next point, press Enter to end the command. 

11 Save your model. 
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To make a copy of the polyline: 

1 Select the polyline. 

2 From the Transform menu, click Copy. 

3 For the Point to copy from, pick a point near the polyline. 

4 For the Point to copy to, type 6 and press Enter, turn Ortho on and 
pick above the selected polyline. 

 

 

To make a mirror image of the polyline: 

1 Select the original polyline. 

2 From the Transform men, click Mirror 

3 For the Start of mirror plane, type 0 and press Enter. 

4 For the End of mirror plane, turn Ortho on and then pick to the right. 

 

 

To make it 3-D: 

1 Select the original polyline and the mirror copy. 

2 From the Solid menu and click Extrude Planar Curve, click Straight. 

3 For the Extrusion distance, type 1 and press Enter.  

 

 
Copy 

 
Mirror 

 
Revolve 
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Your arrow is now a three-

dimensional model. 

To make it 3-D (alternate): 

1 Select the copy of the polyline. 

2 On the Status bar, click Osnap. 

3 On the Osnap toolbar check End. 

 

4 From the Surface menu, click Revolve. 

5 For the Start of revolve axis, select the end of the polyline. 

6 For the End of revolve axis, select the other end of the polyline along 
the centerline. 

 

7 Press Enter to use the default Start angle. 

8 Press Enter to use the default Revolution angle. 

  
Your arrow is now a three-
dimensional model. 
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Exercise 17—Practice using distance and angle constraints 

1 Start a new model using the Small 
Objects – Millimeters.3dm 

template. Save as V-Block. 

2 Double-click the viewport title in the 
Front viewport to maximize it. 

 Create the following model in the 
front construction plane. 

3 Draw the object below using a 

combination of absolute coordinates 
(x,y), relative coordinates (rx,y), 

and relative polar coordinates 
(rdistance<angle). 

4 Start your model at 0 in the Front 

viewport.  

120°

45°

4

4

18

4

20

20

88

2010 10

6.54

4

60

4

 

 Try to create the model using a single polyline. 

 

5 Double-click the viewport title of the Front viewport to restore your views. 

6 Select the polyline. 

7 From the Solid menu, click Extrude Planar Curve, and then click Straight. 

8 For the Extrusion Distance type 60 and press Enter. 

You can view the model as a three-dimensional object in the Perspective 
viewport. 

9 Save your model. 

 

 
Extrude Planar Curve 
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Object Snaps 

Object Snaps are tools for specifying points on existing objects. Use osnaps for precision modeling and to get 
accurate data. Object snaps are often referred to as osnaps. In Rhino, reliable modeling and easy editing depends 

on objects actually meeting at specified points. Objects snaps give you precision you cannot get using the 
―eyeball‖ method 

To open the Osnap toolbar 

 Click the Osnap pane in the status bar.  

This toolbar controls persistent object snaps. Use persistent objects snaps to maintain an object snap through 
choosing several points without having to reactivate the object snap.  

 

When an object snap is active, moving the cursor near an eligible point on an object causes the marker to jump to 
that point and a tooltip to appear. 

Check a box to turn on the object snap. You can place the toolbar anywhere on your desktop.  

Command Button Description 

End 
 

End snaps to the end of a curve, surface edge corner or polyline segment end. 

Near 
 

Near snaps to the nearest point on an existing curve or surface edge. 

Point 
 

Point snaps to a control point or point object. 

Mid 
 

Midpoint snaps to the midpoint of a curve or surface edge. 

Cen 
 

Center snaps to the center point of a curve. This works best with circles and arcs.  

Int 
 

Intersection snaps to the intersection of two curves. 

Perp 
 

Perpendicular To snaps to the point on a curve that makes a perpendicular to the last selected point. It 
doesn't work on the first point that a command prompts you to pick. 

Tan 
 

Tangent To snaps to the point on a curve that makes a tangent to the last selected point. It doesn't work 
on the first point that a command prompts you to pick. 

Quad 
 

Quad snaps to the quadrant point. The quadrant point is the maximum or minimum direction on a curve 
in the x or y construction plane direction. 

Knot 
 

Knot snaps to knot points on curves or surface edges. 

Project 
 

Projects the snap point to the construction plane. 

SmartTrack 
 

SmartTrack is a system of temporary reference lines and points that is drawn in the Rhino viewport 
using implicit relationships among various 3-D points, other geometry in space, and the coordinate axes' 
directions. 

Disable 
 

Temporarily turns off persistent object snaps, retaining settings 
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Exercise 18—Using object snaps 

1 Open the model Osnap.3dm. 

2 Toggle Snap and Ortho off. 

Using End and Midpoint object snaps: 

1 Click the Osnap pane on the status bar. 

You can leave the Osnap toolbar displayed. 

 
Osnap bar with End and Mid on. 

2 Check End and Mid. 

You can check and clear individual object snaps to make modeling with precision easy. 

3 From the Curve menu, click Polyline, and then 
click Polyline. 

4 For the Start of Polyline, move your cursor 
close to the end of the line at the lower left 
corner of the first square and pick when the 

marker snaps to the end of the line. 

The line starts exactly at that corner. 

5 For the Next point, move your cursor close to 
the midpoint of the vertical line at the right side 

of the square on the right, pick when the 
marker snaps to the midpoint.   

The marker snaps to the midpoint of the line that the cursor touches, making the new line cross to the exact 
midpoint of that side. 

6 For the Next point, move your cursor close to the end of the line at the upper 
left corner of the first square, pick when the marker snaps to the end of the 
line. 

The marker snaps to the end of the line.  

7 Press Enter to end the command. 
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Using Near and Perpendicular to object snaps: 

1 In the Osnap toolbar check Near and Perp, 
clear End and Mid. 

2 From the Curve menu, click Line, and then 
click Single Line. 

3 For the Start of line, pick on the lower edge of 
the circle at the top right. 

The marker snaps to the point on the circle 
nearest to where the cursor is positioned. 

4 For the End of line, pick the top horizontal 
edge of the second square.  

  

The marker snaps to a point making a perpendicular to the previous point. 

 

Using Intersection and Tangent to object snaps: 

1 In the Osnap toolbar check Int and Tan; clear 

Near and Perp. 

2 From the Curve menu, click Line, and then 
click Single Line. 

3 For the Start of line, pick the intersection 
where the diagonal line crosses the vertical line 
on the first square. 

The marker snaps to the intersection between 
the two lines. 

  

4  For the End of line, pick the top, left edge of the circle on the right. 

The marker snaps to a point tangent to the circle. 
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Using Center of object snap: 

1 In the Osnap toolbar check Cen, clear Int and 
Tan. 

2 From the Curve menu, click Line, and then 
click Single Line. 

3 For the Start of line, pick on the edge of a 
circle. 

The marker snaps to the center of the circle. 

4  For the End of line, pick on the edge of the 

other circle. 

The marker snaps to the center of the circle.   

 

Using Quadrant of object snap: 

1 In the Osnap toolbar check Quad, clear Cen. 

2 From the Curve menu, click Polyline, and then 
click Polyline. 

3 For the Start of Polyline, pick a point on the 

top edge of the first circle. 

The marker snaps to the quadrant point of the 
circle. 

4 For the Next point, pick the left edge of the 
circle. 

The marker snaps to the quadrant point of the 
circle. 

  

5 For the Next point, pick the bottom edge of the circle. 

6 For the Next point, pick the right edge of the circle. 

7 Click Close to finish. 

8 Use the SaveAs command to save the model. Name it Analyze. We will use it for a later exercise. 
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Other modeling aids 

As well as allowing the user to work in a completely unconstrained free-form manner Rhino has a number of 
modeling aids and constraints that help with precision modeling. This section outlines these aids and constraints. 

Exercise 19—Smart Track 

Smart Track creates a set of temporary reference lines and points that work in conjunction with Rhino’s object 

snaps. Using Smart Track obviates the need to create dummy reference lines and points. Smart Track works on 2-
D and 3-D objects. It can be used in conjunction with the Project and Planar constraints described later in this 
section. 

To use the Smart Track tool: 

1 Open the Constraints.3dm model and maximize the Top Viewport. 

2 Make sure that the following object snaps are turned on: End, Near, Point, Mid, Cen and Int. 

3 Turn on Smart Track on the Osnap toolbar. 

4 From the Curve menu, click Point Object, 
then click Single Point. 

5 Hover the cursor over the lower left corner of 
the green rectangle, the End snap will be 

displayed and a white marker point becomes 
visible. 

6 Repeat this process on the bottom left hand 

corner of the gold rectangle. 

  

7 Now move the cursor towards the apparent 
intersection point of these two corners. Two 
temporary construction lines are displayed. 

The point is positioned on the intersection of 
these two construction lines. 

8 Click to place the Point Object. 

Smart Track will work with any of the available 
object snaps. Experiment with some 
alternatives.  
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Exercise 20 – Tab Constraint 

The Tab constraint allows the user to fix a direction to a reference point and thereby constrain cursor movement. 
The following example shows a simplistic use of the Tab constraint. 

To use the Tab Constraint: 

1 We will work with the Constraints.3dm file as 
previous and again maximize Top view.  

2 Turn off Smart Track. 

3 From the Curve menu click Line, then click 
Single Line. 

4 For the Start of Line snap to the End of the 
bottom left hand corner of the gold rectangle. 

5 For the End of Line, hover the mouse over the 
bottom left hand corner of the green rectangle, 
when the End snap appears press the Tab 

key. 
  

Note that the line now becomes white and the 
direction is constrained. 

6 For the End of Line, drag your mouse to the 
desired location and click. 

The Tab constraint will work in conjunction 

with all object snaps and all tools that require a 
directional input, for example Move, Copy, 
and Rotate. 
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Exercise 21 – Project Constraint 

By default 2-D geometry is created on the active construction plane. Object snaps override this behavior and 
snapping to objects that are not on the construction plane will cause the geometry to be non-planar. The Project 
constraint ignores objects snaps and pushes all the geometry onto the active construction plane. 

To use the Project Constraint: 

1 We will again work with the Constraints.3dm 
file as previous.  

2 Make sure that the Ortho constraint is On. 

3 Turn Layer 01 off and turn Layer 02 on. 

The surfaces on Layer 02 are located at different 

elevations. 

4 Working in Top viewport, draw a Polyline 
around the perimeter of the three rectangles.   

Notice how the how the planar nature of the 
polyline is overridden by the object snaps. 

  

5 Delete the Polyline. 

6 Turn on the Project constraint on the Osnap 
toolbar. 

7 Again, working in Top viewport, draw a 
Polyline around the perimeter of the three 

rectangles. 

Look in the Perspective viewport as you draw 
the polyline and note how the object snaps for 
the endpoints of the green and blue rectangles 
are projected to the construction plane. 

  

The Project constraint forces all the segments of the polyline onto the 
construction plane. The resulting polyline is planar. 

8  Save the File 
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Exercise 22 – Planar Constraint 

The Planar constraint limits successive picked locations to the same construction plane elevation as the previous 
location. For example a command such as Polyline can be started off the construction plane and the Planar 
constraint will override Rhino’s default behavior of snapping back to the construction plane.  

To use the Planar Constraint: 

We will first look at what happens with the Planar constraint Off. Then, we will turn the Planar constraint On to see 
what changes. 

1 We will again work with the Constraints.3dm 

file as previous.  

2 Turn off the Ortho and Planar constraints. 

3 Start the Polyline command. 

4 Working in the Top Viewport, start the Polyline 
at the lower left corner of the Green rectangle. 

5 Add some more segments without snapping to 
any of the objects. 

Look at the Perspective viewport and notice how 
the polyline pulls back onto the construction 
plane after the initial point. 

  

6 To override this behavior and create a planar 

curve delete the Polyline and turn on the 
Planar constraint. 

7  Draw the Polyline again.  

Note how it now remains planar. 

8 Delete the Polyline. 
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To create a Planar curve that starts above the active construction plane and references object snaps at 

different heights: 

First we will draw a polyline without the Project constraint activated. Then we will use the Planar constraint in 
conjunction with the Project constraint to see what changes. 

1 Turn the Planar constraint On. 

2 In the Top viewport, draw a new Polyline starting again at one of the corners 
of the Green rectangle.  

3 Create some additional points this time snapping to some of the Blue and 

Gold rectangle corner points. 

Look at the Perspective view and note how the object snaps override the 
Planar constraint. 

4 Delete the Polyline. 

 

 

5 In the Perspective viewport, draw a new 
Polyline starting again at one of the corners 

of the Green rectangle.  

6 After making the first point, turn the Project 
constraint On. 

7 Create some additional points, snapping to 
some of the Blue and Gold rectangle corner 

points. 

Note that the points stay planar to the first 

point, even though you are snapping to points 
that are at different elevations.   
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Viewports and Construction Planes 

In the following exercise, we will practice using Osnaps while learning more about Viewports and Construction 
planes.  

Exercise 23—Viewports and construction planes 

 Open the Chair.3dm model. 

Viewports 

Viewports are windows in the Rhino graphics area that show you a view of your model. To move and resize 
viewports, drag the viewport title or borders. The cursor moves along a construction plane, which is defined for 

each viewport. You can create new viewports, rename viewports, and use predefined viewport configurations. To 

activate a viewport click anywhere in the viewport and the title highlights. If you are in a command sequence, you 
simply have to move your cursor into a viewport to activate it. 

Construction planes 

The construction plane is the guide used for modeling Rhino objects. Points you pick are always on the 
construction plane unless you use coordinate input, elevator mode, or object snaps. 

Each construction plane has its own axes, a grid, 

and an orientation relative to the world coordinate 
system. 

The grid is a plane of perpendicular lines lying on 

the construction plane. On default grids, every fifth 
line is slightly thicker. The red line represents the 
construction plane x-axis. 

The green line represents the construction plane y-
axis. The red and green lines meet at the 
construction plane origin. 

The icon in the left hand corner always shows world 

coordinates, which are different from the 
construction plane axes.  

Default construction planes are provided with the 
default viewports.  

 The Top construction plane x- and y-axes align with the world x- and y-axes. 

 The Right construction plane (x- and y-axes) align with the world y- and z-axes.  

 The Front construction plane (x- and y-axes) align with the world x- and z-axes.  

 The Perspective viewport uses the Top construction plane. 
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Next, we will turn on layers that illustrate how the default construction planes relate to each other. Each layer 

contains an image for a chair. Later in this exercise we will create our own chair.  

 Turn the CP-Top, CP-Front, CP-Right layers 

on. 

Each of the layers contain an image of a 
view of a tubular chair. 

 

Notice that all the Chair images intersect at 
the origin of the model (0,0,0). 

 

When you draw on any viewport the 

geometry will be located on the construction 
plane, unless you use Osnaps, Planar mode, 
or Elevator mode. 
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Exercise 24—Modeling in 3-D space 

Rhino makes it easy to draw in 3-D space. You can draw on a different 

construction plane by simply moving your cursor into a different viewport. 
Another useful tool for modeling in 3-D space is elevator mode.  

In the following exercise we will draw in different viewports and use elevator 
mode to move some points in 3-D space. 

Elevator mode lets you pick points that are off the construction plane. 

Elevator mode requires two point picks to completely define the point. The 
first specifies the base point. The second specifies how far the final point is 
above or below the base point. 

After the base point is specified, the marker is constrained to a tracking line 

perpendicular to the construction plane that passes through the base point. 

Pick a second point to specify the coordinate of the desired point. You can 
pick a point with the mouse, or type a single number to specify the height 
above the construction plane. Positive numbers are above the construction 
plane; negative numbers are below. 

You will use Snap, Ortho and Elevator mode to draw in different viewports. 
 

 

1  Toggle Planar off and Snap on. Toggle Ortho 
on as needed. 

2 Turn on the Point osnap. 

3 From the Curve menu, click Polyline, and then 
click Polyline. 

4 Move your cursor into the Front viewport. 

5 To Start click at the lower left side of the 
tubular chair image. 

6 Use coordinate input and the image to draw the 
first part of the chair frame.   

7 After you complete the profile lines, move your cursor to the Right viewport to draw a horizontal line. 
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8 Move your cursor to the Front viewport until it 
snaps to the point at the lower end of the 
diagonal line. Don’t click at this time. 

9 While the cursor is locked onto the point, hold 
down the Ctrl key, and pick. 

Holding the Ctrl key while clicking with the left 
mouse button activates elevator mode. 

10 Release the Ctrl key, move your cursor to the 
Perspective viewport and drag the point until 
it snaps to the last point, and pick. 

  

11 Continue drawing the rest of the chair frame 
using the same technique.  

Snap to the next point in the Front viewport, 
activate elevator mode, then move your mouse 
to the Perspective viewport to position the point. 

  

12 For the last segment you can click Close on the 
command line or snap to the start point and 
click. 
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To make a custom construction plane: 

We now want to draw along the chair back, so we will change the construction plane. 

1 On the Status Bar, click Osnap, and check 
End. 

2 Change to the Perspective viewport and turn 
on the Grid, if necessary, by pressing F7. 

3 From the View menu, click Set CPlane, and 

then click 3 Points. 

4 For the CPlane origin, pick vertex (1). 

5 For X axis direction, pick vertex (2).  

  

6 For the CPlane orientation, pick vertex (3). 

The construction plane is aligned with the back 
of the chair. 

  

 

To create a named construction plane 

1 From the View menu, click Set CPlane, then click Named CPlanes. 

2 In the Named CPlanes dialog, click Save. 

3 In the Save CPlanes dialog, type ChairBack, then click OK. 

You have a custom cplane that can be restored as needed. This custom cplane is saved to the file. 

 

 

 

 

 
Set Cplane by 3 points 

 
Named CPlanes 
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To create a named view: 

1 From the View menu, click Set View, click 
Plan. 

The view changes. You are looking straight down 
on the new construction plane.  

2 From the View menu, click Set View, click 
Named Views. 

3 In the Named Views dialog, click Save. 

4 In the Save Views dialog, type ChairBack, 

then click OK. 

This creates a custom view that can be restored 
as needed. 

  

5 Change back to the Perspective view. 

6 From the View menu, click Set View, then click Perspective. 

7 Draw some lines on the new construction plane. 

 

 

 

 

 
 

To make it solid: 

1 Change to the Chair Frame layer. 

2 Select the chair frame. 

3 From the Solid menu, click Pipe. 

4 For the Start and End Radius, type 3 and press Enter. 

 The chair has a solid frame. 

5 Save the model. 

 

 
Plan View of CPlane 
 

 
Edit Named Views 

 
Perspective View 

 
Pipe 
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On your own: 

Try some variations and add some features. 
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Analysis Commands 

Rhino provides analysis tools for finding lengths, angles, areas, distances, and the volume and centroid of solids. 
Additional commands let you analyze curve curvature, determine continuity between curves, and find unjoined 
edges. 

Command Description 

Distance Displays the distance between two points. 

Length Displays the length of a curve object or surface edge. 

Angle Displays the angle between two lines. 

Radius Measures the radius of curvature of a curve, circle, or arc at the point where you pick the curve 
and displays it on the command line. 

EvaluatePt The Cartesian coordinates of the point, in both world and construction plane coordinates are 
displayed on the command line in x,y,z format. 

To find the distance between two points: 

1 Open the Analyze.3dm that you saved from an earlier exercise. 

If you didn’t get a chance to save the model, open the Analyze-01.3dm 
instead. 

2 From the Analyze menu, click Distance. 

3 Pick the intersection where a diagonal line intersects a vertical line. 

4 Pick the intersection where the other diagonal line intersects the same 
vertical line.  

Use object snaps. 

5 Press F2 to display the information. 

CPlane angles and deltas:  xy = 90 elevation = 0   
dx = 0 dy = 3.077 dz = 0 

 

World angles and deltas: xy = 90 elevation = 0   
dx = 0 dy = 3.077 dz = 0 

Distance = 3.077 millimeters 

To find the length of a line: 

1 From the Analyze menu, click Length. 

2 Select the line between the centers of the circles. 

Length = 8.000 millimeters 

 

 
Distance 

 
Length 
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To measure the angle between two lines: 

1 From the Analyze menu, click 
Angle. 

2 Select a point that defines the vertex 
of an angle line. 

3 Select a point that defines the end of 
an angle line. 

Use object snaps as appropriate. 

4 Select a point that defines the vertex 

of the second angle line. 
  

5 Select a point that defines the end of the second angle line. 

The angle displays on the command line in the following format: Angle = 21.7711 

To measure the radius of a circle: 

1 From the Analyze menu, click Radius. 

2 Select one of the circles. 

This also measures the radius of a point on a curve. 

The radius displays on the command line in the following format:  
Radius = 2.5 

 

To evaluate a point: 

1 From the Analyze menu, click Point. 

2 Snap to the end point of the tangent line. 

 The x,y,z point is displayed for the world coordinate plane and the current 
construction plane. 

 Point in world coordinates = 8.203,11.488,0.000 

 CPlane coordinates = 8.203,11.488,0.000  

 

 

 
Angle 

 
Radius 

 
Evaluate Point 
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Drawing Circles 

You can create circles using a center point and radius, center point and a diameter, two points on the diameter, 
three points on the circumference, and tangent points to two coplanar curves and a radius.  

Button Command Description 

 
Circle Draw a circle using the center and radius. 

 
Circle 3Point Draw a circle through three points on its circumference 

 
Circle Diameter Draw a circle using two diameter points. 

 
Circle Tangent, 
Tangent, Radius 

Draw a circle tangent to two curves with a given radius. 

 
Circle Tangent to 3 
Curves 

Draw a circle tangent to three curves. 

 
Circle AroundCurve Draw a circle perpendicular to a curve at the chosen point. 

 
Deformable Draws an approximation of a circle with a defined number of control points.. 

 
Vertical Draw a circle perpendicular to the construction plane. 

Exercise 25—Drawing circles 

 Open the Circles.3dm.  
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To draw a center, radius circle: 

1 From the Curve menu, click Circle, and then click Center, Radius. 

2 For the Center of circle snap to the intersection of the centerlines. 

3 For the Radius type 4 and press Enter. 

A circle is created around the centerline intersection. 

 

 

 

To divide a curve by the number of segments:  

For the next part of this exercise, we need to find some specific points to 
locate the two of the circles. We will use the Divide command to create the 

points. 

1 From the Curve menu, click Point Object, then click Divide Curve by, 
and then click Number of segments. 

2 Select the bottom line as the curve to divide, press Enter. 

3 For the Number of segments type 4 and press Enter. 

A line is divided into four segments with a point at the end of each 
segment.  

 

To draw a diameter circle: 

1 Turn On the Point osnap. 

2 From the Curve menu, click Circle, 
and then click 2 Points. 

3 For the Start of diameter pick snap 
to the second point from the left end 
of the line you divided. 

4 For the End of diameter type 4 and 
press Enter, then turn Ortho on and 
pick to the straight up. 

  

A circle is created with the two points you picked as the diameter, and the diameter was constrained to a 
value of 4. 

5 Repeat these steps for the second diameter circle. 

 
Circle: Center, Radius 

 
Circle: Diameter 
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To draw a tangent, tangent, radius circle: 

1 From the Curve menu, click Circle, 
and then click Tangent, Tangent, 
Radius. 

2 For the First tangent curve, select 

the top line. 

3 For the Second tangent curve, 
select the left line. 

4 For the Radius, type 2 and press 
Enter. 

A circle is created that is tangent to 

the two lines you selected with a 
radius of 2. 

  

5 Repeat these steps for the second TTR circle. 

 

 
Circle: Tangent, Tangent, Radius 
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To make it 3-D: 

1 Select the lines that form the rectangle. 

2 From the Solid menu, click Extrude Planar Curve, and then click 
Straight. 

3 For the Extrusion Distance, type 2 and press Enter.  

The rectangle generates a box. 

 

4 Select the four smaller circles. 

5 From the Solid menu, click Extrude Planar Curve, and then click 
Straight. 

6  For the Extrusion Distance type, -6 and press Enter. 

The circles generate cylinders. 

 

7 Select the large circle in the center. 

8 From the Solid menu, click Extrude Planar Curve, and then click 

Straight. 

9  For the Extrusion Distance ,type 4 and press Enter. 

The circle generates a cylinder. 
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Exercise 26—Using circle-related object snaps 

1 Open the Link.3dm. 

2 Complete the model as shown. 

 

 

3 Draw the three large circles first. 

Snap to the centerline intersections to place the 
circles. 

4 Draw the small holes next. 

Use object snaps to snap to the centers of the 
large circles 
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To draw the tangent lines: 

1 From the Curve menu, click Line, and then 
click Tangent to 2 Curves. 

2 For the first tangent point pick on the edge of 
one of the circles near where you want the 

tangent line to attach. 

3 For the second tangent point pick on the 
edge of another circle. Rhino will find the 
tangent points for you. 

4 Continue to use this command to complete the 
model. 

  

Drawing Arcs 

You can create arcs using various points on the arc and construction geometry. 

You can continue an existing curve with an arc to an existing curve, to a point or by an angle. 

Button Command Description 

  
Arc Draw an arc from the center, start, and angle. 

 

  
Arc : Start, End, Point on Arc Draw an arc from three points. 

  
Arc: Start, End, Direction Draw an arc from start point, end point, and the direction from the start 

point. The direction can be entered after the start point is entered or 
after the end point is entered. 

  
Arc: Tangent, Tangent, Radius Creates an arc from tangents and radius. 

 
Arc: Start End Radius Creates an arc from start point, end point, and radius. 

 
Convert Output=arcs Converts a curve to arc segments that are joined together. 

Arc options 

Option Description 

Deformable Creates an arc shaped NURBS curve 

Extension Extend a curve with an arc. 

 
Line Tangent to 2 Curves  
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Exercise 27—Practice drawing arcs (1) 

 Open the model 

Arc1.3dm. 

 

R3.00

R6.00

Extend Curve: 

By Arc to a Point

Extend Curve:

By Arc

Arc: Start, End, Radius

Arc: Center, Start, End

Arc: Start, End, Direction

4
.0

0

7.002.00

R2.00

Ø2.00

R2.00

R2.00

Arc: TTR

 

 

 

To draw a center, start, end or angle arc: 

1 From the Curve menu, click Arc, and then click Center, Start, Angle. 

2 For the Center of arc snap to the center of the circle at the lower left. 

3 For the Start of arc snap to the end of the line. 

4 For the End point or angle snap to the end of the other line. 

 

 

 

 

 

 

 

 

 
Arc: Center, Start, Angle  
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To draw a start, end, direction arc: 

1 From the Curve menu, click Arc, and then click Start, End, Direction. 

2 For the Start point snap to the upper end of the vertical line. 

3 For an End point snap to the adjacent end of the horizontal line at the 
top. 

4 Toggle Ortho on and drag straight up for the tangent at the start point 
and pick. 

 

5 Make another Direction Arc at the upper right. 

6 For the Start point snap to the right end of the horizontal line. 

7 For an End point type R2,-2 and press Enter. 

8 Toggle Ortho on and drag straight down for the tangent at the start point 
and pick. 

 

 

To add more arc segments using extension option: 

1 From the Curve menu, click Arc, and then click Center, Start, Angle. 

2 Click Extension on the command line. 

3 For the Select near curve end pick near the end of the arc you just 
made. 

4 For the End of arc, type 4 and press Enter. 

5 With Ortho on pick a point below the first point. 

The arc will be tangent to the curve you chose. 

 

 

 
Arc: Start, End, Direction at Start 

 
Arc: Center, Start, Angle 



 

Notes: 

Robert McNeel & Associates 84 

To add more arc segments using the extension option: 

1 From the Curve menu, click Arc, and then click Center, Start, Angle. 

2 Click Extension on the command line. 

3 For the Select near curve end pick near the end of the arc you just 
made. 

4 For the End of arc, snap to the end of the horizontal line. 

 

 

To draw a tangent, tangent, radius arc: 

1 From the Curve menu, click Arc, and then click Tangent, Tangent, 
Radius. 

2 For the First tangent curve pick the lower right side of the top circle. 

3 For the Radius type 3 and press Enter. 

4 For the Second tangent curve pick the upper right side of the lower 

circle. 

5 Move your cursor and pick when the correct arc is displayed. 

 

6 From the Curve menu, click Arc, and then click Tangent, Tangent, 
Radius. 

7 For the First tangent curve pick the upper left side of the top circle. 

8 For the Radius type 6 and press Enter. 

9 For the Second tangent curve pick the lower left side of the lower 

circle. 

10 Move your cursor and pick when the correct arc is displayed. 

 

 

 

 
Extend: By Arc to Point 

 
Arc Tangent, Tangent, Radius 
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To make it solid: 

First you will have to trim the two small circles, then you can extrude the remaining curves. 

1 Select the two arcs you just 
completed. 

2 From the Edit menu, click Trim. 

3 For the objects to trim pick on the 
inner edge of each small circle.  

You will be left with a slot. 

4 Use the Circle command to draw the 
circle concentric to the arc on the 

right. 
  

5 Select all the curves. 

6 From the Solid menu, click Extrude Planar Curve, and then click 
Straight. 

7 For the Extrusion distance type 1 and press Enter.  

The curves have been extruded and capped. 
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Exercise 28—Practice drawing arcs (2) 

Draw construction centerlines first: use their intersection point to draw your arcs and circles. 

1 Start a new model, use the Small Objects - 
Inches.3dm template. Save as Arc2. 

2 Create this model using object snaps and the 

Line, Circle, and Arc commands. 

 

 

 

To make it solid: 

1 Select the curves. 

2 From the Solid menu, click Extrude Planar Curve, and then click 

Straight. 

3 For the Extrusion distance type 1 and press Enter.  

The curves have been extruded and capped. 
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Drawing Ellipses and Polygons 

You can draw ellipses from the center or by the ends. You can draw polygons from a center point or an edge. You 
can draw a rectangle from diagonal corners or by choosing three points. 

Ellipses 

Button Command Description 

  
Ellipse Draw an ellipse by specifying the center point and axis ends. 

 
Ellipse Diameter Draw an ellipse by specifying the axis ends. 

 
Ellipse FromFoci Draw the ellipse from the focus points 

 
AroundCurve Draw an ellipse whose axis is perpendicular to a curve. 

Polygons 

Button Command Description 

  
Polygon Creates a polygon from its center and radius. 

 
Polygon Edge Draw a polygon by specifying the ends of one edge. 

 
Polygon Star Draw a star from a polygon. 

Polygon options 

Option Description 

NumSides Specify the number of sides for the polygon. 

Circumscribed Draw a polygon that is circumscribed about a radius. The default is to draw a polygon that is inscribed in a 
specified radius. 

Rectangles 

Button Command Description 

  
Rectangle Draw a rectangle using opposite corners. 

  
Rectangle Center Draw a rectangle from center and a corner. 

 
3Point Draw a rectangle through three points. 

 
Vertical Draw a rectangle that is perpendicular to the construction plane. 

 
Rounded Create a rectangle with rounded corners (arc or conic). 
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Exercise 29—Practice drawing ellipses and polygons 

 Start a new model, 

use the Small 
Objects - 
Millimeters.3dm 
template. Save as 
Toy. 

 

89 104

14

8

5

19

18

20

R1.5 for all
polygons

 

 

To draw a rectangle from diagonal corners: 

1 From the Curve menu, click Rectangle, and then click Corner to 
Corner. 

2 For the First Corner, type -10,-5 and press Enter. 

3 For the Length, type 20 and press Enter. 

4 For the Width, type 10 and press Enter. 

 

 

 
Rectangle 
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Draw rectangles from a center point with a length and width, and rounded corners:  

1 From the Curve menu, click Rectangle, and then click Center, Corner. 

2 Type R, and press Enter to give the rectangle rounded corners. 

3 For the Center of rectangle, type 0 and press Enter. 

4 For the Length, type 19 and press Enter. 

5 For the Width, type 9 and press Enter. 

6 For the Radius, type 1, and press Enter. 

If you are creating a rounded rectangle, you can choose to select a point 
in the corner to set its curvature instead of typing a radius value. 

 

To change the type of corner, click Corner on the command line to toggle from circular rounded corners to 
conic rounded corners. 

7 Repeat these steps for a second rounded rectangle with a length of 18 and a width of 8 with .5 radius 
corners. 

To draw an ellipse from its center and axis ends:  

1 From the Curve menu, click Ellipse, and then click From Center. 

2 For the Ellipse center, type 0 and press Enter. 

3 For the End of first axis, type 4, and press Enter. 

4 Toggle Ortho on and pick to the right. 

5 For the End of second axis, type 2.5, and press Enter. 

6 Pick a point. 

 

To draw a polygon from its center and radius:   

1 From the Curve menu, click Polygon, and then click Center, Radius. 

2 Click NumSides on the command line, type 3 and press enter to change 
the number of sides for the polygon. 

3 For the Center, type -7,-2 and press enter to locate the center point for 

the polygon. 

4 For the Corner, type 1.5, and press Enter. 

5 Pick a point to orient the polygon. 

6 Continue drawing the rest of the polygons. Use the same radius for each 
one.  

 
Rectangle: Center, Corner 

 
Ellipse 

 
Polygon 
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To make the rounded rectangles solid:  

1 Select the larger rounded rectangle. 

2 From the Solid menu, click Extrude Planar Curve, and then click 
Straight. 

3 Drag it down to set the thickness and click.  

4 Select the smaller rounded rectangle. 

5 From the Solid menu, click Extrude Planar Curve, and then click 
Straight.  

6 Click Bothsides on the command line. 

7 Drag it down until it is slightly above the previous solid and click. 

The smaller rounded rectangle is protruding out of the larger one. 

 

 

 

To make the rounded rectangle hollow: 

1 Select the solid outer rounded rectangle. 

2 From the Solid menu, click Difference. 

3 Select the inner rounded rectangle, and press Enter. 

 

 

 
Extrude closed planar curve 

 
Boolean Difference 
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To make the rectangle solid: 

1 Select the rectangle. 

2 From the Solid menu, click Extrude Planar Curve, and then click 
Straight. 

3 Set the Bothsides option to No. 

4 Drag it up to set the thickness and click. 

 

 

To make the ellipse solid: 

1 Select the ellipse. 

2 From the Solid menu, click Extrude Planar Curve, and then click 
Straight. 

3 Set the Bothsides option to Yes. 

4 Pick to set the thickness. 

 

 

To cut the ellipse solid from the rectangle: 

1 Select the solid rectangle. 

2 From the Solid menu, click Difference. 

3 Select the solid ellipse, and press Enter. 
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To extrude the polygons: 

1 Select the polygons. 

2 From the Solid menu, click Extrude Planar Curve, and then click 
Straight. 

3 Pick to set the thickness. 

 

 

To cut holes with the solid polygons: 

1 Select the solid rectangles. 

2 From the Solid menu, click Difference. 

3 On the command line click DeleteInput. 

4 For the second set of surfaces or polysurfaces, select the solid 
polygons and press Enter. 

Holes will be cut, but the objects will remain. 
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Modeling Free-Form Curves 

The use of free-form curves allows more flexibility to create complex shapes.  

Button Command Description 

  
Curve Curve by control points draws a curve from specified control points. Control 

points mostly do not lie on the curve, but they determine its shape. 

  
InterpCrv Interpolated curve creates a curve going through specified interpolate points. 

These points lie on the curve and determine its curvature. 

 
Conic Draws a conic curve, which is part of an ellipse, parabola, or hyperbola. 

 

Option Description 

Undo Allows you to back up one point. 

Close Makes a closed curve. 

Autoclose Move the cursor close to the start point of the curve, and pick. 

The curve will close automatically. Press ALT to suspend autoclose. 

Sharp If Yes, when you make a closed curve, it will have a kink at the start/end point instead of making a 
smooth (periodic) closure. 

Degree Allows you to set the degree of the curve. 

Exercise 30—Practice drawing curves (1) 

1 Open the model Curve.3dm. 

In this exercise, you will learn how to make a curve by control points, an interpolated curve, and a conic curve 
to compare the differences between the three methods. 

A common method to create with free-form curves is to draw lines that are accurately measured to use as 
guidelines or a background image made from a sketch or a photograph. In this exercise the guidelines have 
been created for one of the exercises and an image has been included for the other exercise. 

2 In the Osnap toolbar, check End and Near, clear all others. 

If you click End with your right mouse, it will clear all the others. 

3 Toggle Ortho and Snap off. 
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To draw a curve by control points: 

1 From the Curve menu, click Free-form, and then click Control Points. 

2 For the Start of Curve, snap to the end point of the polyline guideline. 

3 For the Next point, snap on the polyline guideline using the Near object 
snap. 

4 Continue to snap to the guideline until you get to the end. 

5 Press Enter. 

A free-form curve is drawn. The control points, while on the guideline, 
were not on the curve itself except at the two ends.  

 

To draw a curve interpolate through points:  

1 Change to the Interpolated Curve layer. 

2 From the Curve menu, click Free-form, and then click Interpolate 
Points. 

3 For the Start of Curve, snap to the intersection of the centerline and the 
image using the Near object snap. 

4 For the Next point, continue to pick points along the edge of the image 

until you get to the other end, then use the Near object snap to snap to 
the intersection of the centerline and the image. 

5 Press Enter. 

A free-form curve is created from specified interpolate points. These 
points lie on the curve and determine its curvature. 

 

To draw a conic curve: 

1 Change to the Conic layer. 

2 From the Curve menu, click Conic. 

3 Snap to the point (1) at the lower left. 

4 Snap to the point (2) above and to the right from the previous point.  

5 Snap to the point (3) in between the previous points. 

6 Pick a point for the desired curvature. 

 

 
Control Point Curve 

Control points control the 
curvature of the curve, but the 
points are usually not on the 
curve. 

 
Curve: Interpolate Points 

 
Conic 
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To make the control point curve into a surface:  

1 Select the control point curve. 

2 From the Surface menu, click 
Revolve. 

3 For the Start of revolve axis, snap 
either end of the curve. 

4 For the End of revolve axis, snap to 

the other end of the curve.  

5 For the Start angle, click FullCircle. 

  

 

To make the interpolated curve into a surface:  

1 Select the interpolated curve. 

2 From the Surface menu, click 
Revolve. 

3 For the Start of revolve axis, snap 

either end of the curve. 

4 For the End of revolve axis, snap to 
the other end of the curve.  

5 For the Start angle, click FullCircle. 

  

 

 
Revolve 
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Modeling Helix and Spiral 

The use of free-form curves allows more flexibility to create complex shapes. If you need to control precision, you 
can make construction lines that define your overall parameters. 

Button Command Description 

 
Helix Draw a helix. User can specify a radius, the number of turns, the length and 

direction of the axis. 

 
Spiral Draw a spiral. User can specify two radii, the number of turns, the length and 

direction of the axis. 

 

Option Description 

Vertical The helix or spiral axis will be perpendicular to the construction plane in the active viewport. 

AroundCurve Select a curve for the helix or spiral to wind around to create "phone cord" shapes. 

Flat Lets you draw a planar spiral. 

Mode Determines whether the number of turns or the distance between turns is used to create the helix 
or spiral 

Turns Allows you to set the number of turns along the axis. 

Pitch Allows you to set the distance between turns along the axis. 

ReverseTwist Allows you to reverse the twist direction of the helix or spiral. 

Exercise 31—Practice drawing curves (2) 

1 Open the model Helix-Spiral.3dm. 

 In this exercise, you will learn how to make a curve by control points, an interpolated curve, and a conic 
curve to compare the differences between the three methods. 

 A common method to create with free-form curves is to draw lines that are accurately measured to use as 
guidelines. In this exercise the guidelines have been created for you. 

2 In the Osnap toolbar, check End and Point, clear all others. 

If you click End with your right mouse, it will clear all the others. 

3 Toggle Ortho and Snap off. 
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To draw a helix 

1 Change to the Helix layer. 

2 From the Curve menu, click Helix. 

3 For the Start of axis, snap to the end of the vertical line (1) in the 
Perspective viewport.  

4 For the End of axis, snap to the end of the vertical line (2) in the 
Perspective viewport. 

5 Click Mode on the command line until it is set to Mode=Turns. 

6 Click Turns on the command line. 

7 For the Number of turns, type 10 and press Enter. 
 

8 Pick the point (3) to the right of the axis line. 

A helix with 10 turns and a radius of 20 is created. 

 

To draw a spiral: 

1 Change to the Spiral layer.  

2 From the Curve menu, click Spiral. 

3 For the Start of axis, snap to the end of the other vertical line (1) in the 

Perspective viewport. 

4 For the End of axis, snap to the other end of the same line (2). 

5 Click Mode on the command line until it is set to Mode=Pitch. 

6 Click Pitch on the command line. 

7 For the Pitch, type 15 and press Enter. 

8 Click ReverseTwist on the command line until it is set to Reverse 
Twist=Yes. 

 

9 Snap the point (3) for the radius of the base of the spiral. 

10 Snap to the other point (4) for the ending radius. 

A spiral is created with a reverse twist and a pitch of 15. 

 

 

 
Helix 

 
Spiral 
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To draw a helix around a curve: 

1 Change to the HelixAlongCurve layer.  

2 From the Curve menu, click Helix. 

3 Click AroundCurve. 

4 Select the free-form curve. 

5 Click Mode=Turns. 

6 Click Turns 

7 Type 25 and press Enter. 

8 Click ReverseTwist=No. 

9 For the Radius type 5 and press Enter.  

10 Pick a point for the Start point. 

A helix is created around the curve. 

 

 
Helix 
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Exercise 32—Drawing free-form curves 

In the following exercise we will draw the guidelines and free-form curves 

for a toy screwdriver.  

1 Start a new model, use the Small Objects - Millimeters.3dm 
template. Save as Screwdriver. 

2 Create Construction and Curve layers.  

Make them different colors. 

 

 

To create the construction lines: 

1 Change to the 
Construction layer. 

2 Draw a Polyline, in the 
Top viewport, using these 
dimensions for the 
guideline. 

18
10

6

11

42 25

3

2050

8

 

A good starting point for the Polyline would be -70,0. 

 

To create the curve by control points: 

1 Change to the 
Curve layer. 

2 Use the Curve 
command to draw 
the shape for the 
toy screwdriver.  

3 Save your model. 
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To make it solid: 

1 Toggle Snap and Ortho on. 

2 Select the curve. 

3 From the Surface menu and click 
Revolve. 

4 For the Start of revolve axis, snap 
to the end of the curve. 

5 For the End of revolve axis, snap to 
the other end of the curve. 

6 For the Start angle, click FullCircle.   

Your model is now a three-dimensional surface. 

 

Add details on your own: 

Since we haven’t discussed many of the commands that you need to complete this model, use Command Help 
for assistance. Following is a list of procedures for one method to finish the model. 

1 In the Top view draw a Single Line 
that will be used to slice the flat part 
from the screwdriver blade. 

2 Extrude the line to make a surface 

that intersects the blade end. 

  

3 Use the Dir command to check the 
normal direction of the surface.  

4 Make sure the direction arrows are 

pointing toward the blade. Use the 
Flip option if needed. 

  

 
Revolve 
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5 Mirror the surface around the origin 
to get a surface for cutting both sides 
of the blade. 

 

6 Use the BooleanDifference 
command to remove the surfaces 
from the blade. 

  

7 Draw a Curve along the top of the 

handle to be used for cutting 
grooves.  

If you do this in the Front viewport, 
you will eliminate any problems that 
might arise from having one of the 
slots along the seam of the surface. 

8 Use the Pipe command to make a 
surface on the curve. 

  

9 Use the ArrayPolar command to 
make copies of the pipe around the 

handle. 
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10 Use the BooleanDifference 
command to remove the pipes from 
the handle. 

 

11 Try using the Render command to 
make a rendering of the finished 
screwdriver. 
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5  Editing Objects 

Once you create objects, you can move and edit them to produce complex and detailed variations.  

Fillet  

Fillet connects two lines, arcs, circles, or curves extending or trimming them to touch or to join with a circular arc.  

Option Description 

Radius Sets the fillet radius. A radius of 0 extends or trims the curves to a corner, but does not create a fillet. 

Join Yes, joins the fillet to the curves.  
No, does not join the fillet to the curves. 

Trim Yes, trims the curves to the fillet arc.  
No, does not trim the curves. 

Exercise 33—Fillet 

 Open the model Fillet.3dm. 

 

 

 

Rules to follow when filleting 
curves: 

The curves must be coplanar. 

The created fillet is determined 
by picking on the curve portion to 
keep. 

The radius cannot be so large 
that it runs past the end of the 
curve. 
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To fillet lines at a zero radius: 

1 From the Curve menu, click Fillet Curves. 

2 Click Radius to change the radius. 

3 Type 0, and press Enter. 

This Radius option remains the default until you 
change it. 

4 Select an outer vertical line. 

5 Select an adjacent horizontal line. 

The ends of the lines are trimmed to a corner. 

  

6 Press Enter to repeat the command. 

7 Fillet the other corners, as shown. 

To join the filleted objects: 

1 Select lines you just filleted. 

2 From the Edit menu, click Join. 

The objects are joined together. Curves join 
only if they touch. 

  

 

 

 

 

 

 

 

 

 

 

 

 
Fillet Curves 

Remember to pick on the part of 
the line that you want to keep. 

 

Join 
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To fillet lines using an arc: 

1 From the Curve menu, click Fillet Curves. 

2 Type 2 and press Enter to change the radius. 

This is another method to change the radius. 

3 Click Join to change the Join option to Yes. 

This option joins the curves as they are filleted. 

4 Select an outer vertical line. 

5 Select an adjacent horizontal line. 

The ends of the lines are trimmed to a radius. 

6 Press Enter to repeat the command. 

7 Fillet the other corners as shown. 
 

8 Press Enter to repeat the command. 

9 Type 1 and press Enter. 

This radius will be used for the smaller object. 

10 Select an inner vertical line. 

11 Select an adjacent horizontal line. 

12 Fillet the other corners as shown. 
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To fillet circles: 

1 From the Curve 
menu, click 
Fillet Curves. 

2 Type 3 and press 

Enter. 

3 Select the right 
edge of a circle. 

4 Select the right 
edge of the 
other circle. 

   

5 Repeat the command for the left side of the 
circles. 

6 Select the two fillets you just created. 

7 From the Edit menu, click Trim. 

8 For the objects to trim pick on the inner edge of 
each circle.  

 

  

 

To fillet and join arcs and lines: 

1 From the Curve menu, click Fillet Curves.  
Set Join=Yes and Trim=Yes. 

2 Select the line in the lower left part of the 
viewport. 

Make sure you pick on the left half of the line. 

3 Select the adjacent arc right above the selected 

line. 

4 Repeat this procedure for the two arcs below 
the line and the arc you just filleted. 
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To fillet the corners of a closed polyline: 

1 Select the closed polyline. 

2 From the Curve menu, click Fillet Corners. 

3 For the Fillet radius, type 2 and press Enter. 

All corners are filleted at once. 

  

Blend  

Blending is another method to connect lines, arcs, or curves. There are two blend commands that work on curves, 
Blend (default blend) and BlendCrv (adjustable blend). Blend offers many additional options for how the curves 
connect. 

Option Description 

Perpendicular When Continuity=Tangent or Curvature, allows you to blend a curve to a surface edge perpendicular to the 
surface with continuity. 

AtAngle When Continuity=Tangent or Curvature, orients the direction of the blend curve other than perpendicular to 
the edge. 

Continuity Continuity describes the relationship between curves and surfaces. Types of continuity: Position (G0), 
Tangent (G1), and Curvature (G2). 

To blend two curves: 

1 From the Curve menu, click Blend Curves. 

2 Select the Curves to blend near the ends that you want to connect. 

The arcs are connected with a smooth curve. The default continuity is 
Curvature. 

3 Delete the blend curve. 

 

 

 
Fillet corners 

 
Blend Curves 
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To blend two curves with Adjustable curve blend: 

1 Since there is no menu pick for this command, type 
BlendCrv on the command line or select the Adjustable 
curve blend icon from the Curve Tools toolbar. 

 

 

2 Select the Curves to blend near the ends that 

you want to connect. 

You will see a preview of the default blend with 
control points displayed. 

3 For the control point to adjust, select the point 
(1) and drag it further up the curve and click. 

  

4 For the next control point to adjust, select the 
point to the right of (2), drag it closer to (2) and 
click. 

5 After making your adjustments, press Enter to 
make the blend. 

  

 

 

 
Adjustable curve blend  
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To make a lofted surface with closed curves: 

1 Change to the Surfaces layer. 

2 Select the two squares in the upper left part of 
the Top viewport. 

3 Change to the Perspective viewport. 

4 From the Surface menu, click Loft. 

The two squares show a seam direction arrow. 
They should point the same direction. 

If the seams don’t line up at corresponding 
points on the two curves, drag the seam point 
until it does. 

  

5 Press Enter. 

6 In the Loft Options dialog box, click OK. 

A surface is generated between the two closed 
polylines. 

7 Repeat the procedure for the rounded squares. 

8 In the Loft Options dialog box, click OK. 

9 Save your model. 

 

  

 

 

 

 

The curves in this model are at 
two different elevations. You are 
going to connect the curves at 
different elevations with a 
surface. 

 

Loft 
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To make a lofted surface with open curves: 

1 Repeat the Loft command for the three open 
curves. 

 

2 In the Loft Options dialog box, change the 
Style to Loose, click Preview. 

 

  

3 Change the Style to Straight sections, click Preview. 

 

4 Change the Style to Normal. 

 

 

5 For the Cross-section curve options, change 
to  Rebuild with, change the number of 
control points to 12, click Preview. 

  

6 Change to Refit within, click Preview. 
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Chamfer  

Chamfer connects two curves by extending or trimming them to intersect or to join with a beveled line. Chamfer 
works on convergent or intersecting curves.  

Option Description 

Distances The first chamfer distance specifies the distance from the chamfer end on the first curve to the point where 
the two curves would intersect. The second chamfer distance specifies the distance of the chamfer end on 
the second curve to the intersection point. 

A chamfer distance of 0 trims or extends that curve to the intersection point. If the chamfer distance is non-
zero, a chamfer line is created that far from the intersection, and the curve is extended to the chamfer line. If 
you enter 0 for both distances, the curves are trimmed or extended to their intersection, but no chamfer line is 
created. 

Exercise 34—Chamfer 

 Open the model Chamfer.3dm. 

To chamfer lines: 

1 From the Curve menu, click 
Chamfer. 

2 For the Distance, type 1,1, and 
press Enter, to set the distances. 

3 Set Join=Yes. 

4 Select one of the inner vertical lines. 

5 Select an adjacent horizontal line. 

6 Continue creating chamfers on all of 
the corners.   

7 Press Enter to repeat the command. 

8 For the Distance, type 3,2 and 
press Enter. 

9 Select one of the outer horizontal 
lines. 

10 Select an adjacent vertical line. 

The first value is the distance along 
the first curve selected, the second 
value is the distance along the 
second line selected. 

  

 

 
Chamfer Curves 
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11 Continue creating chamfers on all of the corners as shown. 

 

 

To turn the curves into surfaces: 

1 Change to the Surfaces layer. 

2 From the Edit menu, click Select Objects, and 
then click Curves. 

3 From the Surface menu, click Loft. 

4 Adjust the seam line if necessary, press 
Enter. 

5 In the Loft Options dialog box, click OK. 

A surface is generated between the two 
chamfered rectangles. 

6 Save your model.    

 

 

 

 

 

 

Select Curves 
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Exercise 35—Practice with Fillet and Chamfer 

1 Open the model 
Filletex.3dm. 

 

 

 

2 Use Fillet and Chamfer to edit the 
drawing as shown. 

All fillets and rounds use a radius of 
0.5 units. 
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To make it solid: 

1 From the Edit menu, click Select Objects, and then click Curves. 

2 From the Solid menu, click Extrude Planar Curve, and then click 
Straight. 

3 For the Extrusion distance, type 1 and press Enter. 

 

 

 

To fillet the top edge of the solid: 

1 From the Solid menu, click Fillet Edge, and then click Fillet Edge. 

2 Change the CurrentRadius to 0.25. 

3 Select the edges around the top of the solid, press Enter. 
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Move 

Use Move to move objects without changing orientation or size.  

Option Description 

Vertical Moves the selected objects vertical to the current construction plane. 

Exercise 36—Move 

1 Open the model Move.3dm. 

2 Turn off both Ortho and Snap so you can move objects freely. 

3 Turn Cen object snap on. 

 

 

 

To move using object snaps for placement: 

1 Select the small circle at the bottom 

left side of the Top viewport. 

2 From the Transform menu, click 
Move. 

3 For the Point to  move from, snap 
to the center of the small circle. 

4 For the Point to move to, snap to 
the center of the arc at the lower left 

of the object. 
  

 

 
Move 
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To move using absolute coordinates: 

1 From the Edit menu, click Select 
Objects, and then click Curves. 

2 From the Transform menu, click 
Move. 

3 For the Point to  move from, snap 
to the end of the line at the lower 
part of the object. 

4 For the Point to move to, type 0,0 

and press Enter. 
  

The end of the line is exactly at point 0,0 in the Top viewport. 

 

To move using relative coordinates: 

1 Select the large slotted circle in the middle of the object. 

 You will move the slotted circle relative to the part. 

2 From the Transform menu, click Move. 

3 Pick any point in the Top viewport. 

It is usually better if you pick near the object you are going to move. 

4 For the Point to move to, type r0,-.25 and press Enter. 

The circle moved down .25 units. 
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Copy 

Copy duplicates selected objects and places them in a new location. The command can repeat to create more than 
one copy in the same command sequence. 

Option Description 

Vertical Copies the selected objects vertical to the current construction plane. 

InPlace Duplicates the object at the current location. 

Exercise 37—Copy 

To copy using object snaps for placement: 

1 Select the small circle at the lower left of the object. 

2 From the Transform menu, click Copy. 

3 For the Point to copy from, snap to the center of the small circle. 

4 For the Point to copy to, snap to the center of the arc at the upper left 
of the object. 

5 Pick to place the object, and press Enter. 

 

 

To make multiple copies: 

1 Select the small circle at the lower left of the object. 

2 From the Transform menu, click Copy. 

3 For the Point to copy from, snap to the center of the small circle. 

4 For the Point to copy to, begin picking points on the screen. 

Each time you pick, a circle will be copied to that location. 

5 Press Enter to end the command. 

6 Undo the multiple copies. 

 

 

 
Copy 
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Undo and Redo 

If you make a mistake or do not like the results of a command, use Undo. If you decide you want those undone 
results back after all, use Redo command. Redo restores the last thing undone. 

Rhino 
Button 

Mouse 
Button 

 
Command 

 
Description 

  
Left-click or Ctrl+Z Undo Cancels the effects of the last command. 

 
Right-click or Ctrl+Y Redo Restores the effects of undo.  

The number of undos kept in memory can be set in Rhino Options on the General page. 

If a command has an Undo option, type U to enter it, or click Undo on the command prompt. 

You cannot use the Undo command after you exit the modeling session or open a different model. 

 

Rotate 

Use Rotate to move objects in a circular motion around a base point. For precise rotation, enter a number of 
degrees to rotate. Positive numbers rotate counterclockwise; negative numbers rotate clockwise. 

Option Description 

Copy Duplicates the object as it is rotated 

Exercise 38—Rotate  

1 Select the large slotted circle in the middle of 
the object. 

2 From the Transform menu, click Rotate. 

3 For the Center of rotation, snap to the center 
of the slotted circle. 

4 For the Angle, type -28 and press Enter. 

  

 

 
Rotate 2-D 
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Group 

Grouping objects allows all members of the group to be selected as one. You can then apply commands to the 
entire group. 

Rhino 
Button 

Mouse 
Button 

 
Command 

 
Description 

  
Left-click or 
Ctrl+G 

Group Makes a group from selected objects. 

 
Left-click or 
Ctrl+Shift+
G 

Ungroup Removes grouping. 

 
Left-click AddToGroup To add objects to a group. 

 
Left-click RemoveFromGroup To remove objects from a group. 

 
Left-click SetGroupName To name groups 

Exercise 39—Grouping  

To group selected objects: 

1 Select the two circles that you placed. 

2 From the Edit menu, click Groups, and then click Group. 
 

To add objects to a group: 

1 Select the polyline on the left, the original circle, and the slotted circle in 
the center.  

2 On the command line type 
AddToGroup or pick the 
AddToGroup icon from the  
Grouping toolbar, press Enter. 

3 Select one of the circles in the 

previous group. 

The objects are part of the group. 

  

 

 
Group 

 
Add to group 
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To remove an object from a group: 

1 On the command line type RemoveFromGroup or pick the 
RemoveFromGroup icon from the Grouping toolbar. 

2 For the Select objects to remove from group, select the slotted circle, 
press Enter. 

The slotted circle is removed from the group. 

 

 

Mirror 

Mirror creates a copy of the objects flipped over a specified axis on the construction plane. 

Exercise 40—Mirror 

1 Select the group. 

2 From the Transform menu, click 

Mirror. 

3 Type 0,0 or snap to the end of the 
line at the lower right of the part. 

4 Toggle Ortho on and pick directly 
above the previous point. 

Since you mirrored a group, in 

addition to having a mirror image 
copy, you also have two groups. 

  

5 Select the two groups. 

6 From the Edit menu, click Groups, and then click Ungroup. 

 

 

 

 
Remove from group 

 
Mirror 

 
Ungroup 
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Join 

Join unites curves that meet at a common end, making a single curve. Join can unite curves that do not touch, if 
you select them after the command has started. As you select non-touching curves, a dialog box asks if you want 

to fill the gap. 

Exercise 41—Join 

1 Select the two polylines. 

2 From the Edit menu, click Join. 

 

Scale 

Scale changes the size of existing objects without changing their shape. This command scales three-dimensional 
objects equally along all three axes. There are also 2-dimensional, one-dimensional, and non-uniform scale 
commands. 

Option Description 

Copy Preserves the object as it creates a new scaled one. 

Scale factor Inputs a value for scale factor. Less than one reduces the size, more than one increases the size. 

Exercise 42—Scale 

1 From the Edit menu, click Select Objects, and then click Curves. 

2 From the Transform menu, click Scale, and then click Scale 2-D. 

3 For the Origin point, type 0 and press Enter. 

4 For the Scale factor, type .75 and press Enter. 

The whole part scaled to 75 percent of its original size. 

 

 
Join 

 
Scale 2-D 
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To scale using the reference point option: 

1 Select the slotted circle. 

2  From the Transform menu, click Scale, and 
then click Scale 2-D. 

3 For the Origin point, snap to the center of the 
slotted circle. 

4 For the First reference point, snap to the 

quadrant of the slotted circle. 

The radius of the slotted circle is the reference 
for the scale factor. 

  

5 For the Second reference point, type 1.375 and press Enter. 

The slotted circle now has a larger radius of 1.375. Everything else was scaled 
proportionally. 

 

 

To make it solid: 

1 From the Edit menu, click Select Objects, and then click Curves. 

2 From the Solid menu, click Extrude Planar Curves, and then click 

Straight. 

3 For the Extrusion distance, type 1 and press Enter. 
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To scale in 3-D: 

1 From the Edit menu, click Select Objects, and then click Polysurfaces. 

2 From the Transform menu, click Scale, and then click Scale 3-D. 

3 For the Origin point, type 0 and press Enter. 

4 For the Scale factor, type 1.5 and press Enter. 

The solid is larger in every dimension. 

 

 

 

To scale in one dimension: 

1 From the Edit menu, click Select 
Objects, and then click 

Polysurfaces. 

2 From the Transform menu, click 
Scale, and then click Scale 1-D. 

3 For the Origin point, type 0 and 
press Enter. 

4 For the First reference point, snap 

to the Perpendicular point at the 
top of the part.    

5 For the Second reference point, type .5 and press Enter. 

The object is half as thick. 

 

 
Scale 3-D 

 
Scale 1-D 
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Array 

Use the Array commands to make multiple copies of selected objects. Array Rectangular makes rows and columns 
of objects. Array Polar copies objects in a circle around a center point 

Exercise 43—Polar Array 

To create a polar array: 

1 Open the model Array.3dm. 

2 Select the small circle in the Top viewport. 

3 From the Transform menu, click Array, and 
then click Polar. 

4 For the Center of polar array, snap to the 
center of the large circle. 

5 For the Number of items, type 10 and press 

Enter. 

6 For the Angle to fill, check to see if it is set to 
360, press Enter.   

The small circle is arrayed around the larger one. 

7 Save your model. 

 

To make the shape for the column: 

1 Window select the circles. 

2 From the Curve menu, click Curve Edit Tools, 
then click Curve Boolean. 

3 For the Regions to keep, click inside the large 
curve. 

The inside of the circle, excluding the smaller 
circles is shaded. 

4 On the command line, click DeleteInput, click 
All, press Enter. 

  

 

 
Polar Array 

You must include the original and 
the copies as the number in the 
array. 
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To make the column: 

1 Select the new polycurve. 

2 From the Solid menu, click Extrude Planar Curve, then click Straight. 

3 For the Extrusion distance, type 14, press Enter. 

 

 

 

To make a partial polar array: 

1 Turn on the Base layer. 

2 Select the column base, the column, and the column cap. 

3 From the Edit menu, click Groups, then click Group. 

The three parts are grouped into one. 

4 Select the group. 

5 From the Transform menu, click Array, and then click Polar. 

6 For the Center of polar array, type 0, press Enter. 

7 For the Number of items, type 6 and press Enter. 
 

8 For the Angle to fill, type -180, press Enter. 

Six columns are arrayed to fill 180 degrees in the negative direction. 
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To create a rectangular array: 

1 Select the same column group as the last exercise. 

2  From the Transform menu, click Array, then click Rectangular. 

3 For the Number in X direction, type 4, press Enter. 

4 For the Number in Y direction, type 4, press Enter. 

5 For the Number in Z direction, type 1, press Enter. 

6 For the X spacing, type 12 and press Enter. 

7 For the Y spacing, type 12 and press Enter. 

The columns are visible.   

8 At this stage you can change the 
number in each direction or the 

spacing.  

If you need to make a change, click 
the option in the command line and 
then make the adjustment. 

9 Press Enter to accept. 

10 Turn on all the layers to see the 

result. 
  

 

 

 

 

 

 

 

 

 

 

 

 
Rectangular Array 
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Trim 

Trim cuts and deletes portions of an object to make it end precisely at its intersection with another object. 

Exercise 44—Trim 

In this exercise, we will to pre-select the cutting objects. 

To trim curves: 

1 Open the model Trim-Split.3dm. 

2 Zoom Window around the grid in the lower left 
corner of the Top viewport. 

3 Pre-select the cutting objects by selecting the 
two outside vertical lines in the grid. 

4 From the Edit menu, click Trim. 

5 Select each of the horizontal lines at their left 
and right ends. 

The lines are trimmed to the cutting edges. 

6 Press Enter. 

  

To trim surfaces: 

1 Zoom Window around a sphere and surface in 
the Perspective viewport. 

 

2 Select the surface that intersects the sphere in 
the Perspective viewport as the cutting 

object. 

 

3 From the Edit menu, click Trim. 

 

  

 
Zoom Window 

 
Trim 
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4 For the Object to trim, pick the right side of the sphere. 

The sphere is trimmed at the surface. 

 

5 Press Enter. 
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Split 

Splits one object with another into objects, splits a curve at a point you specify. The Split command breaks the 
object where it intersects the cutting object but does not delete anything. 

Exercise 45—Split  

In this exercise, we will to pre-select the object or objects we are going to split. 

To split a curve: 

1 Zoom Window around the closed curve in the 

lower right corner of the Top viewport.  

2 Select the closed curve. 

3 From the Edit menu, click Split. 

4 Select the lines and press Enter. 

The curve is separated into four curves precisely 
where the lines intersect it. 

  

 

To split a surface:  

5 From the View 
menu, click 
Zoom, and then 
click Extents 

All. 

6 From the Edit 
menu, click 
Split. 

7 Select the 

sphere, and 
press Enter.    

8 Select the surface that intersects the sphere and press Enter. 

The sphere is separated into two pieces precisely where the surface intersects it. 

 

 
Split 
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Extend 

Extend lengthens an object to make it end precisely at its intersection with another object or you can lengthen an 
object when there is no intersection. 

Exercise 46—Extend 

1 Open the model Extend.3dm.  

2 From the Curve 
menu, click 
Extend Curve, 

and then click 

Extend Curve. 

3 For the 
boundary 

objects, select 
the line at the 
left and the 
curve at the 
right.    

4 Press Enter. 

5 For the curve to extend, select the left end of the line and the middle curve. 

The line and curve extend to touch the boundary edge on the left. 

6 For the next curve to extend, click 
Type=Natural on the command line. 

7 Change to Type=Line. 

8 Select left end of the bottom curve and the 
right end of the line. 

The curve and line extend to touch the 
boundary. The extension is a straight segment. 

 

  

 

 
Extend Curve 



 

Notes: 

Robert McNeel & Associates 131 

9 For the next curve to extend, click Type=Line 
on the command line. 

10 Change to Type=Arc. 

11 Select the right end of the middle curve. 

The curve extends with a tangent arc to touch 
the boundary. 

 

  

12 For the next curve to extend, click Type=Arc 
on the command line. 

13 Change to Type=Smooth. 

14 Select the right side of the bottom curve. 

The curve extends with a curvature (G2) 
continuous extension to touch the boundary.  

 

15 Press Enter to end the command. 

 
  

 

To extend with a set extension length: 

1 From the Curve menu, click Extend Curve, 
and then click Extend Curve. 

2 Enter extension length, type 4 and press 

Enter. 

3 Select the upper end of the curve on the right. 

The curve extends exactly 4 units. 

 

4 Press Enter to end the command. 
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To extend a curve dynamically: 

1 From the Curve 
menu, click 
Extend Curve, 
and then click 
Extend Curve. 

2 Press Enter for a 
dynamic 
extension. 

3 Select the lower 
end of the curve 

on the right.    

The curve continues with the cursor. 

4 Click to end the extension. 

5 Press Enter to end the command. 

To extend to a surface: 

1 From the Curve menu, click Extend 
Curve, and then click Extend 
Curve. 

2 For the boundary objects, select 

the cylinder on the left and the 
surface on the right. 

3 Press Enter. 

4 Change the type to Type=Arc. 

5 Select both ends of the line and the 
curve. 

The curves extend to the surface of 
the cylinder and to the surface. 
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Offset 

Offset creates an object parallel or concentric to another object. Use Offset to create specialized copies, such as 
parallel lines, concentric circles, and concentric arcs, through specified points or at pre-set distances. 

Exercise 47—Offset 

1 Open the model Offset.3dm. 

2 Maximize the Top viewport. 

3 Select the line. 

4 From the Curve menu, click Offset Curve. 

5 For the Side to offset, pick on the upper right 
side of the line. 

A parallel line is created. 

 

  

 

To offset with the through point option: 

1 Turn on the End osnap. 

2 Select the circle.  

3 From the Curve menu, click Offset Curve. 

4 For the Side to offset, pick click 
Throughpoint on the command line. 

5 For the Thoughpoint, snap to the lower right 

end of the line you offset. 

A concentric circle is created that goes through 
the endpoint of the line. 

   

 

 
Offset Curve 
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To offset a polyline with sharp corners: 

1 Select the polyline. 

2 From the Curve menu, click Offset Curve. 

3 Type 1 and press Enter to change the offset distance. 

4 For the Side to offset, pick inside the polyline. 

The polyline is offset with sharp corners. 

 

 

To offset a polyline with round corners: 

1 Select the polyline. 

2 From the Curve menu, click Offset Curve. 

3 Click Corner=Sharp on the command line. 

4 Change the type to Corner=Round. 

5 Pick outside the polyline.  

The polyline is offset, but the corners are rounded with arcs. 

 

 Other corner options include Smooth and Chamfer. Smooth makes a tangent 
curve that is smoother than an arc at each vertex, while Chamfer makes a 

bevel at each vertex.  

To offset a curve with the bothsides option: 

1 Select the free-form curve.  

2 From the Curve menu, click Offset Curve. 

3 Click Bothsides on the command line. 

4 For Side to offset, pick on either side of the curve.  

Free-form curves are created on both sides of the selected curve. 

5 Repeat this process on the arc. 

Concentric arcs are created on both sides of the selected arc. 
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To offset a surface: 

1 Select one of the open surfaces.  

2 From the Surface menu, click Offset Surface. 

3 Place your cursor over the surface and click your 
left mouse button. 

Notice that the direction of the arrows changed. 
The normal direction of the surface was flipped by 

the mouse click. If you have a positive number for 
offset distance, the surface will be offset in the 
direction of the normal. If you have a negative 
number it will offset the opposite direction. 

 
The normals should point toward the concave side of the 
surface. 

4 Press Enter. 

The surface is offset in the direction of the normals. 

 

 

 

 
Offset Surface 
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To offset a surface to a solid: 

1 Select the other open surface. 

2 From the Surface menu, click Offset Surface. 

3 Click on the surface to change the normal direction if necessary. 

4 Choose the Solid option. 

5 Press Enter to create the offset surface and the surfaces needed to make the 
solid. 

 

 

 

To offset a polysurface: 

Offsetting polysurfaces usually doesn’t give the desired results. In this example we will demonstrate some of the 
problems. 

1 Select the cylinder. 

2 From the Surface menu, click Offset Surface. 

The normals on a closed polysurface will always 
point to the outside. 

3 Press Enter. 

Each surface of the polysurface is offset as a 
separate piece. 

  

 



 

Notes: 

Robert McNeel & Associates 137 

Exercise 48—Practice 

1 Start a new model, use the Small 
Objects - Inches.3dm template. 

Save as Gasket1. 

  

2 Use Circle, Arc, Trim, Fillet, and 
Join to create the part shown. 

3 Use Extrude Planar Curve > 

Straight on the Solid menu to 
create the 3-D part. The extrusion 
thickness is .125.  

 

Exercise 49—Practice 

1 Start a new model, use the Small Objects - Inches.3dm 

template. Save as Cam. 

  

2 Use Circle, Arc, Line, Trim, Join, and Array to draw the 

part shown. 

3 Use Extrude Planar Curve > Straight on the Solid 
menu to create the 3-D part. The extrusion thickness 
is 0.5. 
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Exercise 50—Practice 

1 Start a new model, use the Small Objects - 
Inches.3dm template. Save as Link. 

  

2 Use Line, Arc, Trim, Offset, Join, Fillet and Circle to 
draw the part shown. 

3 Use Extrude Planar Curve > Straight on the Solid 
menu to create the 3-D part. The extrusion thickness 
is 0.5. 

 

Exercise 51—Practice 

1 Start a new model, use the Large Objects - Inches.3dm 
template. Save as Building. 

2 Use Line, Arc, Trim, Offset, Curve, Fillet and Circle to 
draw the layout of the building shown. 
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6  Point Editing  

 

You can display the control points or the edit points of an object so that you can adjust the shape of an object, 
rather than manipulating the whole object at once. That is called control point editing. 

You can use point editing on meshes, curves, and surfaces, but not on polysurfaces or solids. 

Rhino’s curves are represented internally with non-uniform rational B-splines ( NURBS ). Three things determine 
the shape of a NURBS curve: 

 A list of points called control points 

 Degree 

 A list of numbers called knots 

If you change any of these things, it changes the shape of the curve. 

A few facts about control points, edit points, and knots 

 Control points do not have to be on the curve.  

 Edit points are always on the curve. 

 Rhino lets you edit curves and surfaces by moving control points and edit points. 

 Knots are parameters (that is, numbers, not points). 

 Adding knots to a curve or surface lets you control the movement of the object during control-point 
editing. 
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Exercise 52—Control point editing 

In this exercise we are going to experiment with moving control points. Understanding how curves and lines react 
when control points are moved is very important to understanding NURBS modeling. 

To edit control points: 

1 Open the model Control Point.3dm. 

 There are pairs of curves with different degrees 
in the model. 

2 Turn Ortho and Snap on. 

3 From the Edit menu, click Select Objects, and 
then click Curves. 

4 From the Edit menu, click Control Points, and 
then click Control Points On. (Press F10.) 

  

5 In the Front viewport, select the middle row of 
points. 

6 Drag the points vertically, 8 units. 

Notice that the degree 1 curves (polylines) come 
to a point at each moved control point and the 
control points are exactly on the curve.  

The degree 3 and 5 curves are smooth. The 
degree 3 curves have more curvature than the 
degree 5 curves  

  

Individual points have more influence on a small area of the curve with degree 3 curves, while points have 
greater influence over a wider span of the curve with degree 5 curves. 

 

 
Control Points On 
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To check the differences: 

1 Turn off the control points by pressing the F11 
key or use the Esc key. 

2 Turn the Plane layer on. 

3 Select the curves and the plane. 

4 From the Curve menu, click Curve from 
objects, then click Intersection. 

Lines are shown on the surface showing the 
intersections. 

 

  

5 Note the difference between the degree 3 and 5 curves.  

The higher the degree, the greater the influence over the span of a curve, 
when you edit control points. 

As you can see by the illustration, editing one point out of 11, on the 

degree 5 curve, influenced most of the curve. The degree 3 curve has a 
sharper curvature, because the influence of one point takes place over a 
shorter span.  

6 Undo twice, until you get back to seeing just the curves.  

The intersections will disappear, and the Plane layer is off. 
 

 

To continue editing control points: 

1 In the Front viewport, select the third two rows 
of points on either side of the center. 

2 Drag the points vertically, 5 units. 

3 Turn off the control points by pressing the F11 
key or use the Esc key. 

When a curve or polyline bends at a point, like 
this, it is called a kink.  

If you create a surface from a curve that has a 
kink, it will have a seam at the kink. 
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To make a lofted surface: 

1 Select the curves. 

2 From the Surface menu, click Loft. 

3 In the Loft options dialog box, click OK. 

Because the degree 1 curves were included in the loft, a polysurface is created 
with a seam at each kink. 

4 Select the surface. 

5 Turn on the control points. 

The points do not turn on and the following message is displayed on the 
command line: Cannot turn on points for polysurfaces. 

6 Undo the loft.  

 

To change the polylines into curves without kinks: 

1 Select both polylines. 

2 From the Edit menu, click Rebuild. 

3 In the Rebuild Curve dialog box change the 

point count to 11 and the degree to 3, and 
click OK. 

A degree 3 curve cannot have kinks. The curve 
smoothes and changes shape. 

 

  

 

 
Rebuild 
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To loft a surface over the curves: 

1 Select all of the curves. 

2 From the Surface menu, click Loft. 

3 In the Loft Options dialog box, click OK. 

A single surface appears over the curves. The 
surface can be edited with control points. 

4 Select the surface. 

5 Turn on the control points. 

Note that there are more control points than 
what you started with. Rhino adds control points 
to make the surface conform the original curves.   

 

To rebuild a surface: 

1 Turn off the control points. 

2 Select the surface. 

3 From the Edit menu, click Rebuild. 

4 In the Rebuild Surface dialog, change the 

point count to 8 in U direction and 13 in the V 
direction. Change the degree to 3 for both U 
and V. Check Delete input. 

The surface is smoother with fewer control 
points. 

   

 

 
Rebuild Surface  
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Nudge Controls 

Another method to move control points and other geometry in a more subtle way is to use the Nudge keys. The 
nudge keys are the arrow keys on the keyboard activated with the Alt, Alt+Ctrl, and Alt+Shift keys. 

To change the nudge settings: 

1 From the Tools menu, click Options. 

2 In the Options dialog box, on the 
Modeling Aids page, note the Nudge 
settings.  

Any of these values can be changed. 
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To use Nudge keys to move control points: 

1 Select one or two control points in the Front 
viewport. 

2 Hold down the Alt key down and press an arrow 
key. 

Notice that it moves (nudges) the point a small 
amount. 

3 Hold the Alt and the Ctrl key down and press 
another arrow key. 

The movement is much smaller. 

4 Hold the Alt and the Shift key down and press 

another arrow key. 

The movement is magnified. 

  

5 Hold the Alt and press the PageUp or PageDown key to nudge in the Z direction. 

 

To use set points to adjust points: 

1 Select all the 
points in one 
row along the 
top of the 

surface. 

2 From the 
Transform 
menu, click Set 
Points. 

3 In the Set 
Points dialog 
box, check 

   

 Set Z, and uncheck Set X and Set Y. 

4 In the Right viewport move the points and click. 

The control points are aligned in the World Z direction. 

5 Repeat this on some of the other rows of points. 

 

 
Set XYZ Coordinates 
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Exercise 53—Practice with curves and control point editing 

1 Start a new model, use the Small Objects - 
Millimeters.3dm template. Save as Glass. 

2 Use the Curve command to create a half cross-
section of the glass. 

3 Use control point editing to adjust the curve 
until you get the desired shape. 

To make it 3-D: 

1 From the Surface menu, click Revolve. 

2 Select the curve you created, and press Enter. 

3 For the Start of revolve axis, pick one end of 
the curve. 

  

4 For the End of revolve axis, pick the other 
end of the curve. 

5 For the Start Angle, click Deformable=Yes. 

This changes the structure of the revolved 
surface to make it easier to deform without 
creating kinks. 

6 For the Start Angle, click FullCircle. 

7 Save your model.  

8 Experiment with adjusting the control points to 
see what happens.  

9 Incremental Save your model. 
  

10 Delete the 
surface. 

11 Change the 
original curve 
and make 
another 

revolved 
surface.  

12 Incremental 
Save your 
model. 

 

   

 



 

  

Part Three: 
3-D Modeling and Editing 
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7  Creating Deformable Shapes 

 

When building models in Rhino, you should first determine which methods should be used for each part of the 
project. There are two basic ways to model in Rhino—free-form and accurate. Some models require more 
attention to exact dimensions because they might have to be manufactured or parts may have to fit together. 

Sometimes it is the shape of the object, not the accuracy that is important. These techniques can be merged 
together to create accurate, free-form shapes. This tutorial focuses only on the free-form, squishy aspect. The 
exact size and placement of the objects is not critical. The overall form is the main objective. 

This exercise shows: 

 Simple surface creation 

 Surface rebuilding 

 Control point editing 

 Curve creation ( drawing, projecting ) 

 Splitting surfaces with curves and surfaces 

 Blending between two surfaces 

 Lighting and rendering 

 

When you model the rubber ducky, you will use similar modeling techniques for the head and the body. You will 
create spheres that will be deformed to make the shapes.  

If you need to know more about control points and surfaces, search the Rhino Help index for ―control points.‖ 
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Exercise 54—Creating a rubber duck 

1 Start a new model, use the Small Objects - Millimeters.3dm template. Save 
as Duck. 

2 You can use layers to separate your parts, but for this model, it is not 
necessary. 

For more information about layers, look up ―layer‖ in the Rhino Help index. 

 

 

 

Create the body and head shapes 

The body and head of the ducky are created by modifying two spheres. The size and placement of the spheres 

does not need to be exact. 

To create the basic shapes: 

1 From the Solid menu, click Sphere, and then click Center, Radius. 

2 Pick a point in the Front viewport. 

3 Pick another point in the same viewport to create a sphere. 

4 Repeat this procedure for the second sphere. 

 

 

 

 
Sphere 
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To make the spheres deformable:  

1 Select both 
spheres. 

2 From the Edit 
menu, click 
Rebuild. 

3 In the Rebuild 
Surface dialog 
box, change the 
Point Count to 
8 for both U and 

V.  

 

 

4 Change the Degree to 3 for both U and V. 

5 Check Delete Input, clear Current Layer, and 

click OK.  

The spheres are now deformable. Having more 
control points allows more control over smaller 
parts of the surface. A degree-three surface will 
have a smoother shape when deformed. 

 

 
Rebuild Surface  
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To modify the body shape: 

1 Select the large 
sphere. 

2 From the Edit 
menu, click 
Control Points, 
and then click 

Control Points 
On. 

3 In the Front 
viewport select 

the control points     
 near the bottom of the sphere. 

To window select, drag a box left to right around the control points. 

4 From the Transform menu, click Set Points. 

5 In the Set Points dialog box check Set Z, and Align to World as illustrated 
above. 

6 Drag the selected control points up, snap to one of the upper most points. 

This aligns all of the selected control points to the same world z-value (vertical in 
Front viewport), flattening the surface. 

 

 

To scale the sphere shape: 

1 Turn off control points and select the body 

shape. 

2 From the Transform menu, click Scale, and 
then click Scale1D. 

3 For the Origin point, pick a point near the 
center of the body sphere. 

4 For the First reference point, with Ortho on, 

pick a point to the right in the Front viewport. 

5 For the Second reference point, pick a point 
further to the right in the Front viewport. 

The body is shaped like an ellipsoid. 
  

 

 
Control Points On  

 
Set XYZ Coordinates  

 
Scale 1D 
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To reshape the chest and tail 

1 Turn the control points on. 

2 Window select the control points at the top right 
of the body, and drag them to the right to bulge 
out the chest. 

 

  

3 Window select the control points at the upper 
left edge of the body, and drag them up to form 

the tail. 

Notice in the Top viewport that two control 
points are selected, though in the Front 
viewport, it looks like only one is selected. This 

is because the second control point is directly 
behind the one you can see in the Front 
viewport. 
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To add control for further shaping the tail: 

Before we start to edit the tail further, we will add an additional set of points to the tail portion of the body. 

1 From the Edit menu, click Control Points, and 
then click Insert Knot. 

2 For the Surface for knot insertion, pick the 

body surface. 

A surface isocurve will be displayed. It will 
either be in the U or the V direction.  

3 Change the direction if necessary.  

4 For the Point on surface to add knot, pick a 

point midway between the tail and the center of 
the body. 

  

5 Press Enter to end the command. 

A new set of isocurves and a new row of points have been added to the body. 

6 Window select 
the control 
points at the 
upper part of the 
new isocurve, 

and drag them 

down to further 
form the tail and 
the body. 

7 You can adjust 

the control 
points further     

 until you get the shape you want. 

8 Save your model. 

 

 
Insert Knot 

Remember to use a window to 
select the control points. There 
may be multiple control points in 
the same location in this view. 
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To create the head: 

1 In the Front viewport, select the small sphere. 

2 From the Edit menu, click Control Points, and 
then click Control Points On. 

3 Select the control points on the right side and 

drag them to begin forming the bill. 

 

  

4 Window select 
the control 
points further 
back on the 

same isocurve 
and drag them 
forward to widen 
the bill. 

 

   

5 Window select 
control points at 
the top of the bill 
and drag them 
down as shown. 

6 Press Esc to turn 
control points 
off. 

   

 

Remember to use a window to 
select the control points. There 
may be multiple control points in 
the same location in this view. 
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Separate the bill from the head 

For the final rendering, the bill must be a different color from the body. To do this, they must be separate 
surfaces. You can split a single surface into multiple surfaces many ways. The following technique is just one. 

To split a surface with a curve: 

1 In the Front viewport create a curve that looks 

like the illustration on the right. 

2 Select the head. 

3 From the Edit menu, click Split. 

4 For the Cutting object, pick the curve you just 

created. 

5 Press Enter. 

The bill and head are now separate surfaces. 
This will allow you to render the surfaces with 
different colors.   
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Create the duck’s neck 

The ducky needs a neck. You will first make an edge on the surface of the head and a corresponding edge on the 
surface of the body so you can create a blended surface between the two edges. 

To trim the head and the body: 

1 Draw a Line across the bottom of the head. 

2 Make a copy of the line and adjust it so that it 
intersects the top of the body as illustrated on 
the right. 

It is important that the lines intersect the 
bottom of the head and the body completely. 

3 Select the lines. 

4 From the Edit menu, click Trim. 

 

  

5 For the Object 
to trim, pick the 
bottom of the 
head and the top 

of the body. 

The bottom of 
the head and the 
top of the body is 
trimmed. 

6 Save your 

model. 
   

 
Trim 
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To create the blend surface between the head and body: 

1 From the Surface menu, click Blend Surface. 

2 For the Segment for first edge, pick the edge curve at the bottom of the 
head. 

3 If the whole edge is not selected, click All on the command line.  

4 Press Enter to go to the next stage of the command. 

5 For the Segment for second edge, pick the edge curve at the top of the hole 
in the body. 

6 If the whole edge is not selected, click All on the command line. 

7 Press Enter to go to the next stage of the command. 
 

8 In the Blend Bulge dialog box, check the 
Preview check box. 

The blend surface between the body and the 
head is displayed. 

9 Make any adjustments you desire by moving 
the slider bars in the dialog box, click OK when 
finished. 

If you check the box at the left of the sliders the 
surface adjustments are symmetrical. 

10 Save your model. 

 

 

 

To join the parts: 

1 Select the body the blend surface and the back of the head. 

2 From the Edit menu, click Join. 

The three surfaces are joined into one. The bill is left separate for rendering 
purposes. 

 

 

 
Blend Surface  

 
Join  
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To make an eye: 

For this part of the exercise we will make a curve and revolve it to get the surfaces for the eye. 

1  Toggle Ortho and Snap on to help. 

2 From the Curve menu, click Conic. 

3 In the Front or Right viewport make a conic 
curve as illustrated.  
Start of Conic (1), End of Conic (2), Apex 

(3), Curvature point. 

4 Use SmartTrack, with Point, End and Int 
osnaps on, to help place the two points as 
illustrated. 

These points will be used for placement of the 
eye on the head.  

  

5 From the Curve menu, click Point Object, 
then click Multiple Points. 

6 For the Location of point object, hover over 
the end of the conic until the point activates, 
drag you cursor down and click to place the 
point. 

The point should be placed above the lower end 
of the conic. 

This will be the insertion point for eye.  

7 For the Location of point object, hover over 

the point you just made until the point 
activates, drag you cursor left and click when 
you reach the intersection point. 

This point is for scaling and rotating the eye. 
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To split the curve: 

1  Draw a line that intersects the conic 

2 Select the conic curve, 

3 From the Edit menu, click Split. 

4 For the Cutting object, select the line. 

Splitting the curve allows you to assign a 
different color and material properties for the 
eye and the pupil. 

This step can be done at this stage or after 
you make the surface. 

 

  

To make the surface: 

1  Select both parts of the conic curve. 

2 From the Surface menu, click Revolve. 

3 For the Start of revolve axis, snap to the 

point. 

4 For the End of revolve axis, snap to the end 
of the conic. 

5 For the Start Angle, click FullCircle. 
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To assign display color and material color: 

1  Select the top of the eye. 

2  From the Edit menu, click 
Object Properties. 

3  For the Display color, choose a 
contrasting color. 

4 In the Properties window, on 

the Material page, click Basic, 
click on the Color button, and 
select a color for the pupil of 
the eye, like black. 

5 Repeat these steps for the 
lower part of the surface. Set 
the color for both object display 
and material to white. 

 

  

6 From the Render menu, click Render Preview to see the material color. 

 

To place the eye on the head: 

1 In the Top viewport, select both parts of the eye. 

2 From the Edit menu, click Groups, then click Group. 

The eye parts are grouped as one object. 

3 Select the group. 

4 From the Transform menu, click Orient, then 
click On Surface. 

5 For Reference point 1, snap to the point at 
the center of the eye. 

6 For Reference point 2, snap to the point at 

the edge of the eye. 

7 For Surface to Orient on, pick the head. 

  

 

Object Properties 
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8 In the Orient on Surface dialog, check 
Uniform and Rigid, click OK. 

9 For the Point of surface to orient to, pick a 
point on the head. 

 

 

 

10 Mirror the eye to the other side of the head. 

  

Render a picture of the ducky 

Rendering creates a ―realistic‖ picture of your model with colors you assign. These render colors are different from 

the layer colors you might be using, which control the display in wireframe and shaded mode. 

To render the ducky: 

1 Select the beak.  

2 From the Edit menu, click Object Properties. 

3 In the Properties window, on the Material page, click Basic and click the color swatch. 

4 In the Select Color dialog box, select a color for the beak, like orange. 

5 Select the body. 

6 From the Edit menu, click Object Properties. 

7 In the Properties window, on the Material page, check Basic and select a color for the body, like yellow. 

8 From the Render menu, click Render. 

 
Render 
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To place lights: 

1 From the Render menu, click Create 
Spotlight. 

2 Select a point in the middle of the model. 

 

  

3 Drag the radius until it is approximately three 
times as large as the model. 

4 Pick a point in the Top viewport while holding 
the Ctrl key down to activate elevator mode.  

In the Front viewport pick a point slightly 
above the object. 

5 From the Render menu, click Render. 

  

  

 

 

 
Create Spotlight 
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8  Modeling with Solids 

 

Modeling solids in Rhino is easy. There are several commands that enable you create and edit solid objects.  

Solids in Rhino are closed surfaces or polysurfaces that enclose a volume. Some of the solid primitives are closed 
single-surfaces carefully edge-matched, others are polysurfaces. 

Rhino’s polysurface objects are deformable by using the new UDT (Uniform Deformation Technology) tools. You 
can also extract surfaces and deform the surfaces with control point editing like the last exercise.  

In this part of the class we will focus on making some solids, separating the parts, making changes and then 
joining the parts back together to make a solid. 

Button Command Description 

 
Box Draw a rectangular box from two diagonal corners and a height. 

 

 

Box 3Point Draw a box from two adjacent corners, a point on the edge across from them, and a height. 

  
Sphere Draw a sphere from a center point and a radius. 

  

Sphere 2Point Draw a sphere from the two ends of a diameter. 

  

Sphere 3Point Draw a sphere from three points on its surface. 

  
Cylinder  

 

Draw a solid cylinder from a center point, a radius, and a height. 

  
Tube Draw a solid tube from a center point, two radii, and a height. 

 
Cone  Draw a solid cone from a base point, a base radius, and a height. 

 
TCone  Draw a truncated cone that ends in a circular plane from a base point, two radii, and a height. 
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Button Command Description 

  
Ellipsoid  

 

Draw an ellipsoid from a center point, and three axis endpoints. 

  
Torus  Draw a solid Torus from a center point, a radius for the center of the tube, and a tube radius.  

 
Pipe  

 

Draw a pipe around an existing curve. The pipe has a circular cross-section and optional caps at 
the ends.  

The Thick option lets you specify two radii at each end of the curve to create pipes with holes 
bored through the middle like tubing. 

 
TextObject Draw text as outline curves, surfaces, or solids. 

 
ExtrudeCrv Draw a solid by extruding a closed planar curve vertically.  

 
ExtrudeSrf  Creates a solid by extruding a surface vertically. 

 

 
Cap Creates planar surfaces to close planar holes in a surface or partial solid. 

 
BooleanUnion Boolean operation in Rhino to combine solids. 

 
BooleanDifference Boolean operation in Rhino to subtract surfaces and solids from one another. 

 
BooleanIntersection Boolean operation in Rhino to create the intersection of two surfaces or solids. 

Exercise 55— Model a bar with text 

In the following exercise we will make a solid primitive, extract some surfaces, rebuild a surface and deform it, 
join the new surfaces into a solid, fillet the edges, add text to a surface, and do a Boolean operation on the solid. 

1 Start a new model using the Small Objects - Millimeters template. Save as 
Bar. 

2 From the Solid menu, click Box, and then click Corner to Corner, Height. 

3 For the First corner type 0,0 and press Enter. 

4 For the Length type 15 and press Enter. 

5 For the Width type 6 and press Enter. 

6 For the Height type 1 and press Enter. 

 

 
Box 
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To edit a surface: 

1 From the Solid menu, click Extract Surface. 

2 For the Surface to extract, select the top and 
both end surfaces, press Enter.  

3 Select the two ends and delete them. 

  

4 Select the top surface. 

5 From the Edit menu, click Rebuild. 

6 In the Rebuild Surface dialog box, set the 
Point count to 4 and the Degree to 3 for both 
U and V, click OK. 

7 Press F10 to turn Control Points On. 

 

 

8 In the Right viewport, window select the 
middle points.  

9 Drag the points up approximately one unit. 

10 Press F11 to turn Control Points Off. 

 

  

 

 
Extract Surface 

 
Control Points On 

 
Rebuild Surface 
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To make the bar solid: 

1 Select all of the surfaces. 

2 From the Edit menu, click Join.  

The surfaces are joined making an open 
polysurface. 

3 Select the polysurface. 

4 From the Solid menu, click Cap Planar Holes. 

 Two end caps are created. 

  

 

To fillet the edges: 

1 From the Solid menu, click Fillet Edge, and 
then click Fillet Edge. 

2 Set the Current Radius=1.0. 

3 For Select edges to fillet, pick the four 
vertical edges, press Enter. 

4 For Select fillet handle to edit, press Enter. 

  

5 Repeat the Fillet Edge command. 

6 Set the Current Radius=0.2. 

7 For Select edges to fillet, window select the 
entire bar to get the horizontal edges, press 
Enter. 

8 For Select fillet handle to edit, press Enter. 

 

  

 

 
Cap Planar Holes 

 
Fillet Edge  
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To make a copy of the bar on a different layer: 

We need to make a copy of the finished bar for the next part of this exercise. On one of the copies we will engrave 
text, on the other we will emboss text. 

1 Select the finished bar. 

2 From the Edit menu, click Layers, then Copy 
objects to layer. 

3 In the Select layer to copy objects dialog, pick 
Layer 01 and click OK. 

4 Turn Layer 01 off. 

 

 

 

To make solid text: 

1 Change the layer to Layer 02. 

2 From the Solid menu, click Text. 

3 In the Text Object dialog box, select a 
bold Font, like Arial Black. 

 Under Create click Solids. 

 Under Text size, set the Height to 
3.00, the Solid thickness to 1.00, 
check Group objects, click OK. 

4 For the Insertion point position the 

text in the center of the bar in the Top 
viewport and click. 

5 In the Front or Right viewport, drag the 
text until it protrudes through the top 

surface. 

  

 

 

 

 
Copy Objects to Layer 

 
Text Object 
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To engrave the text in the bar: 

1 Select the bar. 

2 From the Solid menu, click Difference. 

3 For Select second set of surfaces or polysurfaces, set DeleteInput=Yes, 
select the text, press Enter.  

The text is engraved into the bar. 

 

 

Using a model for illustration 

Occasionally you will want to use your 3-D model for illustration purposes. In this case we’re going to divide the 
top surface into pieces. Each piece can then be assigned a material property. When the part is rendered or 
displayed in a rendered viewport, it will appear like a label. 

To make a label: 

1 Turn Layer 01 on and turn the Default layer 

off. 

2 From the Solid menu, click Extract Surface. 

3 Select the top surface, press Enter.  

4 Select the lower part of the bar and Lock it. 

5 Make the Top viewport active. 

6 From the Solid menu, click Text. 

7 In the Text Object dialog box, under Create, 
click Curves, click OK. 

8 For the Insertion point position the text in the 
center of the bar in the Top viewport and click. 
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To split the top surface of the bar with the text: 

1 In the Top or Perspective viewport, select the 
extracted top surface. 

2 From the Edit menu, click Split. 

3 Select the text curves, press Enter. 

Since the Group objects box was checked when 
you created the text, you can pick all of the text 
by clicking on one element. 

The curves have split the surface. Each part of 
the text is a separate surface. 

4 Hide the original text curves. 
  

5 Select the text surfaces. 

Remember to leave the center of letters like R and O out of the selection set. 

6 From the Edit menu, click Group, and then click Group. 

The text surfaces are now grouped for easier selection. 

7 Select the group. 

8 In the Properties window, on the Material page, click Basic and select 

another color for the text. 

9 Right click on the Perspective viewport title. 

10 Select Rendered from the popup menu. 

The letters render in a different color. 
 

 

To emboss the text in the bar: 

1 From the Edit menu, click Select Objects, and then click Previous 
Selection. 

This selects the text surfaces again. 

2 From the Solid menu, click Extrude Surface, and then click Straight. 

3 For the Extrusion distance, click Bothsides=Yes, Cap=Yes, and 
DeleteInput=Yes on the command line. 

4 For the Extrusion distance, type .1 and press Enter. 

The surfaces are extruded perpendicular to the active construction plane by .1 
in both directions. Notice that the top of the text follows the curvature of the 
original surface and the bottom of the text penetrates into the bar.  

 
Extrude Surface 
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5 Hide the extruded text. 

Don’t forget to delete the center of letters. 

6 From the Surface menu, click Surface Edit 
Tools, click Untrim. 

7 For Select an edge to untrim, pick on the 

edge of the text openings. 

  

8 Unlock the bottom part of the bar and Join it 
with top part. 

9 Show the text. 

10 Select the bar and the text. 

11 From the Solid menu, click Union. 

The text and the bar are joined into one closed 
polysurface. 

  

 

 

 
Untrim 

 
Boolean Union 
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9  Creating Surfaces 

 

A Rhino surface is similar to a piece of stretchy fabric. It can take on many different shapes.  

Surfaces are bounded by curves called edges. To visualize the surface shape Rhino displays a grid of isoparametric 
curves (isocurves) on the surface. 

Surfaces have an area, their shape can be changed by moving control points, and they can be meshed. 

Button Command Description 

 
SrfPt Creates a surface by picking three or four points in space for corners. 

 
EdgeSrf Creates a surface by selecting two, three, or four existing curves whose ends meet exactly. 

 
PlanarSrf Creates a surface from planar curves that enclose an area. 

 
Patch Creates a surface that approximates a set of curves and/or point objects. 

 
Revolve Revolves a curve around an axis to create a surface. 

 
Loft Creates a surface from shape curves; the normal, loose, and tight options make a surface with 

no creases as it passes over the shape curves.  

The StraightSections option creates a surface with creases at each shape curve and straight 
sections between the shapes curves. 

 
Sweep1 Creates a surface from shape curves that follow along a rail curve that defines one edge of the 

surface. 

 
Sweep2 Creates a surface from shape curves that follow along two rail curves that define two edges of 

the surface. 

 
FilletSrf Creates a fillet or round between two surfaces. 

 
BlendSrf Makes a smooth surface between two existing surfaces 
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Button Command Description 

 
RailRevolve Revolves a shape curve holding one end along a rail curve. This command is very useful for 

putting a smooth end cap on an irregularly shaped surface. 

 
ExtrudeCrv Extrudes a curve perpendicular to the construction plane with option to taper the surface with a 

draft angle.  

 
ExtrudeCrvAlongCurve Extrudes a curve following along a second curve. 

 
ExtrudeCrvToPoint Extrudes a curve to a point. 

 
Plane Creates a rectangular planar surface parallel to the construction plane from two diagonal 

points. 

 
Plane 3Point Creates a rectangular planar surface from 3 points. 

 
Plane Vertical Creates a rectangular planar surface from 3 points that is vertical to the construction plane. 

Exercise 56—Basic techniques for making surfaces 

In this exercise, you will model some simple surfaces. 

1 Start a new model, use the Small Objects - Millimeters.3dm template. 
Save as Surfaces. 

2 Turn on Snap and Planar. 

3 From the Surface menu, click Plane, and then click Corner to Corner. 

4 For the First corner of plane, pick a point. 

5 For the Other corner, pick another point to make a rectangular plane. 

 

To create a vertical plane:  

1 From the Surface menu, click Plane, and then click Vertical. 

2 For the Start of edge, snap to the endpoint at the right side of the 
surface. 

3 For the End of edge, snap to the other endpoint at the right side of the 

surface. 

4 Drag your cursor up and pick. 

 

 

 
Plane: Corner to Corner 

 
Vertical Plane  
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To create a plane from 3 points: 

1 From the Surface menu, click 
Plane, and then click 3 Points. 

2 For the Start of edge, snap to the 
endpoint at the left of the first 

surface. 

3 For the End of edge, snap to the 
other endpoint at the left side of the 
first surface. 

  

4 For the Height, use SmartTrack to track a point from the top of the vertical plane. Drag the tracking point 
until the surface is tilted slightly and click. 

 

To create a plane from corner points: 

1 From the Surface menu, click 
Corner Points. 

2 For the First corner, snap to an 
endpoint at the edge of the first 
surface. 

3 For the Second corner, snap to the 
endpoint at the edge of the second 
surface. 

4 For the Third corner, snap to an 

endpoint at the edge of the third 
surface. 

  

5 For the Fourth corner, snap to the other endpoint at the edge of the third surface. 

A surface will be created with corners at the points you selected. 

 

 

 

 

 
Rectangular Plane:  3 Points 

 
Surface from 3 or 4 Corner Points 
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To create a surface from planar curves: 

1 Turn Planar mode on. 

2 Draw a curve that starts and ends at the top of the two vertical surfaces 
as shown below.  

Planar mode keeps this curve on the same plane as the surface corners. 

 

3 From the Surface menu, click 
Planar Curves. 

4 Select the curve you just created. 

5 Select the top edge of the three 

surfaces and press Enter. 

A surface is created. 

 

  

 

To create a surface from edge curves: 

1 From the Surface menu, click Edge 
Curves. 

2 Select the four surface edges. 

A surface is created. 

 

  

 

 
Surface from Planar Curves 

 
Surface from 2, 3, or 4 Edge 
Curves 
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Exercise 57—Extruding surfaces 

In this exercise, you will be creating a cordless phone using extrusions. To 

aid in organizing the model, surface and curve layers have been created. 
Make sure you change layers as you are making the extrusions.  

 

 

 

To extrude a curve: 

1 Open the model Extrude.3dm. 

2 Make the Top Surface layer current. 

3 Select the curve as shown. 

4 From the Surface menu, click 

Extrude Curve, and then click 
Straight. 

5 For the Extrusion distance, 
type -3.5 and press Enter. 

If the object being extruded is a 
planar curve, the curve is extruded 
perpendicular to the plane of the 
curve.   

 

 

 

 

 

 

 

 

 
Extrude Straight 
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To extrude a curve along another curve: 

1  Select the curve (1) on the left of 
the first extruded surface. 

2 From the Surface menu, click 
Extrude Curve, and then click 

Along Curve. 

3 Select the path curve (2) near its 
right end. 

The curve is extruded along the path 
of the secondary curve. 

   

 

To extrude a curve with a taper ( draft angle ): 

1 Select the curve on the right. 

2 From the Surface menu, click 
Extrude Curve, and then click 

Tapered. 

3 For the Extrusion distance, click 
DraftAngle on the command line. 

4 For the Draft angle, type -3 and 

press Enter. 

5 For the Extrusion distance, type 
.375 and press Enter. 

  

The curve is extruded with a three-degree draft angle in the positive direction on the y-axis. 

 

 

 

 

 

 

 

 
Extrude Along Curve 

If you do not get the answer you 
expected, undo and try picking 
near the other end of the path 
curve. 
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To create a surface from planar curves: 

1 From the Surface menu, click 
Planar Curves. 

2 Select the edge curves that bound 
the openings of the tapered extrusion 

at the top. 

3 Press Enter. 

A surface is created at the end. 

 

  

4 Select the four surfaces. 

5 From the Edit menu, click Join. 

 

 

To make the extruded surfaces for the other half of the phone: 

Next, we will repeat the previous steps for the other half of the phone. 

1 Make the Bottom Surface layer 
current. 

2 Select the curve as shown. 

3 From the Surface menu, click 
Extrude Curve, and then click 
Straight. 

4 For the Extrusion distance, 

type -3.5 and press Enter. 

If the object being extruded is a 
planar curve, the curve is extruded 

perpendicular to the plane of the 
curve. 

  

 
Surface from Planar Curves 

 
Extrude Straight 
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5  Select the curve (1) on the left of 
the first extruded surface. 

6 From the Surface menu, click 
Extrude Curve, and then click 
Along Curve. 

7 Select the path curve (2) near its 
right end. 

The curve is extruded along the path 
of the secondary curve. 

  

8 Select the curve on the right. 

9 From the Surface menu, click 
Extrude Curve, and then click 
Tapered. 

10 For the Extrusion distance, type 

-1.375 and press Enter. 

The curve is extruded with a three-
degree draft angle in the negative 
direction on the y-axis. 

  

11 From the Surface menu, click 
Planar Curves. 

12 Select the edge curves that bound 

the openings of the tapered extrusion 
at the top. 

13 Press Enter. 

A surface is created at the end. 

14 Select the four surfaces. 

15 From the Edit menu, click Join.   
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To create an extruded surface on both sides of a curve: 

1 Turn on the Extrude Straight-
bothsides layer. 

2 Select the freeform curve as shown. 

3 From the Surface menu, click 
Extrude Curve, and then click 
Straight. 

4 For the Extrusion distance, click 
Bothsides on the command line. 

5 For the Extrusion distance, drag 
the extrusion and pick.  

  

Make sure the surface extends past the other surfaces in both directions.  

The curve is extruded symmetrically from the curve.  

 

 

To trim the surfaces: 

1 Select the joined Top and Bottom 
polysurfaces, and the surface you 
just extruded. 

2 From the Edit menu, click Trim. 

3 For the Object to trim, pick the 

outer edge of each surface. 
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To split the trimmed surface: 

1 Select the trimmed extruded surface. 

2 From the Edit menu, click Split. 

3 For Select cutting objects, click Isocurve on the command line. 

4 Drag you cursor along the surface to determine which isocurve direction 
is selected. Click Toggle on the command line if it’s not the correct 
direction. 

5 For the Split point, snap to the intersection where all three surfaces 
intersect. 

  

  

To join the surfaces: 

Next you will join the surface and the polysurface for the Top and the Bottom of the handset.  

1 Select the upper part of the split surface and the top polysurface 

2 From the Edit menu, click Join. 

3 Select the lower part of the split surface and the bottom polysurface 

4 From the Edit menu, click Join. 
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To round the edges of the polysurfaces: 

1 From the Solid menu, Fillet Edges, 
then Fillet Edges. Use a radius of .2 
to round the edges. 

2 For the Select edges to fillet, select 

the edges around the top of the top 
polysurface and the two horizontal 
edges at the front, press Enter. 

3 For the Select fillet handle to edit, 

click Preview. 

4 Check to make sure the fillet is doing 

what you expect, press Enter. 

  

5 Repeat these steps for the Bottom 
polysurface. 

  

 

To create an extruded surface from a curve to a point: 

1 Turn on the Extrude to a point layer. 

2 Select the U-shaped curve. 

3 From the Surface menu, click Extrude Curve, and then click To Point. 

4 For the Point to extrude to, snap to the point object near the top 
surface. 

The curve is extruded to the point. 

 

 

 
Variable Radius Fillet 

 
Extrude To Point 
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5 Use the BooleanDifference 
command (Solid menu > Difference) 
to remove the surface from the top 
of the phone. 

If the result is not correct, flip the 

normal of the top polysurface and the 
extruded surface with the Dir 
command. The normal of the top 
polysurface and the extruded surface 
should point toward each other. 

  

6 Select the circle. 

7 From the Surface menu, click Extrude Curve, and then click To Point. 

8 For the Point to extrude to, snap to the point object inside the bottom 
surface. 

The curve is extruded to the point. 

 

 

9 Use the BooleanDifference 
command (Solid menu > Difference) 

to remove the surface from the top 
of the phone. 

The normal of the bottom polysurface 
and the extruded surface should point 
toward each other. 

10 Save your model as Phone. 
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To create the buttons: 

1 Turn on the Curves for Buttons layer. 

2 In the Front view, window select the first column of buttons. 

Three curves are selected. 

3 From the Solid menu, click Extrude Planar Curve, and then click 

Straight. 

4 Type -.2 and press Enter. 

 

 

5 Repeat these steps for the other 
columns of buttons. 

6 Use the FilletEdge command (Solid 
menu > Fillet Edge > Fillet Edge) 
with a radius of .05 to round the 
edges. 

 The button edges are rounded. 

7 Save your model. 
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Exercise 58—Lofted surfaces 

1 Open the model Loft.3dm. 

2 Window select all of the curves. 

 

  

3 From the Surface menu, click Loft. 

A surface is fitted over the curves. 

 

 

 

 

4 In the Loft Options dialog box, switch 
Style to Straight sections, and then click 
Preview. 

A surface is fitted through the curves, but 
the sections are straight between the 
curves. 

 

 

 

 

 
Loft 
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5 In the Loft Options dialog box, switch 
Style to Loose, and then click Preview. 

A surface is created that uses the same 
control points as the curves. The surface 
follows the curves more loosely. 

Use this option when you want the surface 
to conform to the control points of the input 
curve. 

 

6 In the Loft Options dialog box, switch 
Style to Normal, and then click OK. 

 

 

7 Mirror the surface to create the 
other half. 

 

8 Join the two halves. 

  

 

To make a seat: 

1 Turn the Hull Curves layer off and 
turn the Seat Curves, and Seat 
layers on. 

2 Make the Seat Curves layer 

current. 

3 In the Front view, select the 
rounded rectangles. 

4 From the Curve menu, click Curve 
From Objects, and then click 
Project.   

Project uses the current construction plane to determine the direction of projection. Make sure you select the 
curves and surface to project onto in the Front viewport. 

 
Mirror 
 

 
Join 

 
Project to Surface 
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5 For the Surface to project onto, 
select the hull. 

The curves will be projected to both 
sides of the hull surface.  

6 Select the curves on the surface. 

 

7 From the Surface menu, click Loft. 

8 In the Loft dialog, click OK. 

  

A surface is fitted over the curves that fits exactly with the shape of the hull. 

 

To create section curves from the surfaces: 

1 Select the hull. 

2 Change to the Sections layer. 

3 From the Curve menu, click Curve 
From Objects, and then click 

Section. 

 

4 For the Start of section, in the Top 

viewport, pick a point to the left at 
the center of the hull.  

  

5 For the End of section, with Ortho on, drag a line to the right and pick. 

A curve is generated on the surface. Repeat this at various locations. 

 

 

 
Section 
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To create contour curves across the hull surfaces: 

1 Select the hull. 

2 Change to the Contours layer. 

3 From the Curve menu, click Curve 
From Objects, and then click 
Contour. 

 

4 For the Contour base point, snap to 
the left end of the canoe. 

  

5 For the Direction perpendicular to contour planes, snap to the other 
end of the canoe. 

6 For the Distance between contours, type 12 and press Enter. 

A curve is generated every foot along the hull. 

 

 

To create an edge curve from the surfaces: 

1 Change to the Top Rail layer. 

2 From the Curve menu, click Curve 

From Objects, and then click 
Duplicate Edge. 

3 Pick the top edge of the hull. 

4 Pick the other top edge and press 
Enter. 

Two curves are generated at the 

edges of the hull 
  

 

 
Contour 

 
Duplicate Edge 
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Exercise 59—Revolved surfaces 

1 Open the model 
Revolve.3dm. 

2 Select the free-
form curve 

3 From the 
Surface menu, 
click Revolve. 

4 Select one end of 

the curve for the 
Start of 

revolve axis.    

5 Select the other end of the curve for the End of revolve axis. 

6 Press Enter to use the default Start Angle. 

7 Press Enter to use the default Revolution Angle. 

A surface is revolved around the axis line. 

 

 

 

 

 

 

 

 

 

 

 

 
Revolve 
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Exercise 60—Using a rail revolve 

Rail Revolve lets you revolve around an axis and along a path curve. 

To create a rail revolve: 

1 Open the model Rail 
Revolve.3dm. 

2 For the Profile Curve, select 
the conic shaped curve. 

3 From the Surface menu, 
click Rail Revolve. 

4 For the Rail curve, select 
the heart shaped curve. 

5 Select one end of the 
RailRevolve axis line. 

   

6 Select the other end of the RailRevolve axis line. 

A surface is revolved around the axis that follows along the curve at the end of the object. 

 

7 Turn the Bowl layer on and other layers off. 

8 Repeat the previous steps to make a bowl. 

  

 

 

 

 

 
Rail Revolve 
Right click this button 
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Exercise 61—Using 1-rail sweeps to create surfaces 

One cross-section: 

1 Open the model 1 Rail Sweep.3dm. 

2 Select the two curves on the left. 

3 From the Surface menu, click Sweep 1 Rail. 

4 In the Sweep 1 Rail Options dialog, click OK. 

  

Two cross-sections: 

1  Select the three curves in middle. 

2 From the Surface menu, click Sweep 1 Rail. 

3 In the Sweep 1 Rail Options dialog, check 
Global shape blending. 

4 In the Sweep 1 Rail Options dialog, click OK. 

  

Multiple cross-sections: 

1 Select the four curves on the right. 

2 From the Surface menu, click Sweep 1 Rail. 

3 In the Sweep 1 Rail Options dialog, uncheck 
Global shape blending. 

4 In the Sweep 1 Rail Options dialog, click OK. 

  

 

 
Sweep 1 Rails 
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To create a 1-rail sweep to a point: 

1 Make Surface 02 layer group current 
and turn off Surface 01 layer group. 

2 From the Surface menu, click 
Sweep 1 Rail. 

3 For the Rail, select the open free-
form curve. 

4 For the Select cross section 
curves, select the three closed curves, 

then click Point on the command 
line.   

5 For the Pick end point, snap to the End of the free-form curve. 

6 In the Sweep 1 Rail Options dialog, click OK. 

 

To create a roadlike 1-rail sweep: 

1 Make Surface 03 layer group current 
and turn off Surface 02 layer group. 

2 Select the helix. 

3 From the Surface menu, click 

Sweep 1 Rail. 

4 For the Select cross section 
curves, select the closed curve, press 

Enter. 

  

5 Change the style to Roadlike Right, 
click Preview. 

6 Change the style to Roadlike Front, 
click Preview. 

7 Change the style to Roadlike Top, 

click Preview, click OK. 
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Exercise 62—Using 2-rail sweeps to create surfaces 

 Open the model 2 Rail Sweep.3dm. 

To create the base —Part 1: 

In the first part of this exercise, we will explore one of the Sweep2 options. To 

illustrate the option we will use one cross-section. In the second part we will use 
the same rail curves with two cross-sections. Lastly, we will use two rails that 
converge to a single point. 

 

 

1 Change to the Base Surface layer. 

2 From the Surface menu, click Sweep 2 Rails. 

3 Select the two rail curves (1). 

4 Select the cross-section curve (2). 

5 Press Enter twice. 

Since we only picked one cross-section, the 

surface doesn’t conform to the circle at the top 
of the sweep. 

 

 

 

6 In the Sweep 2 Rail Options dialog, check 
Maintain height, click Preview. 

Notice that the cross-section maintains the 
same height thoughout the sweep. 

7 In the Sweep 2 Rail Options dialog, click 
Cancel. 

  

 

 
Sweep 2 Rails 
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To create the base—Part 2: 

1 Select the two rail curves (1). 

2 From the Surface menu, click Sweep 2 Rails. 

3 Select both cross-section curves (2). 

4 Press Enter twice. 

5 In the Sweep 2 Rail Options dialog, click OK. 

A surface is created whose edges match the rail curves and the cross-section 
curves. 

To create the housing: 

 

1 Turn the Housing Surface, Housing Curves, 
and Mirror layers on. 

2 Make the Housing Surface layer current. 

3 From the Surface menu, click Sweep 2 Rails. 

4 Select the two rail curves (1). 

5 For the cross-section, select the outer edge of 

the cylinder, press Enter twice. 

6 In the Sweep 2 Rail Options dialog, click OK. 

A surface is created. 
  

To join the two parts: 

  

1 Select the base 

and the 
housing 
surfaces. 

2 From the Solid 

menu, click 
Union. 

3 Use FilletEdge 
with a radius of 

.25 to round the 
intersecting 
edge. 
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Exercise 63—Using a network of curves to create surfaces 

1 Open the model Networksurf.3dm. 

 

2 From the Surface menu, click Curve 
Network. 

 

3 For Select curves in network, pick 

the two edge curves and the cross-
section curves, and press Enter. 

  

4 In the Surface From Curve 
Network dialog box, change the 
edge matching to Curvature, 
click OK. 

A surface is created that has 
curvature continuity with the other 
two surfaces. 
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Exercise 64— Practice using one-rail sweeps: 

In this exercise you use one rail sweeps to make an end table with free-form tapered legs. 

To create the legs: 

1 Open the model 
Table.3dm. 

2 From the 
Surface menu, 

click Sweep 1 
Rail. 

3 Select the path 

curve for the leg. 

4 Select the shape 
curve for both 
ends of the leg.    

5 Press Enter. 

6 Press Enter. 

7 In the Sweep 1 Rail Options dialog box, click OK. 

The table leg is created. Note the nice transition from one cross-section curve to the other. 

 

To create the brace: 

1 Change to the 
Braces layer. 

2 Repeat the 
previous process 
to create the 

brace.  
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To create the top and finish the table: 

1 Change to the 
Top layer. 

2 From the 
Surface menu, 

click Sweep 1 
Rail. 

3 Select the 
ellipse. 

4 Select the shape 
curve. 

5 Press Enter. 
   

6 In the Sweep 1 Rail Options dialog box, click OK. 

The surface for the rim of top is created. 

7 Select all of the surfaces you created. 

8 From the Solid menu, click Cap Planar Holes. 

Six caps were created. 

9 Use Mirror to copy the brace and the leg to finish the model. 

Mirror them around 0,0 in the Top viewport. 
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Exercise 65— Creating a toy hammer: 

In this exercise you will use most of the techniques that you’ve learned in 

the previous sessions.  

Some models require more attention to detail. This is an example of a 
model that requires precise modeling techniques. This exercise also requires 
a number of different surface creation techniques. The technical drawing is 
included to help you create a very precise model. 

 

1 Open the model Hammer.3dm.  

In addition the following layers have been created: Construction Lines, Curves, Handle, Tang, Head, 

Hole, Cutout, and Claw. Use the appropriate layer when constructing the model. 
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2 Draw outlines for the hammer in the Top viewport. 

Drawing outlines helps while drawing the curves. You can either draw lines, polylines, or rectangles to create 
the outlines. Use the dimensions on the technical drawing to get accurate outlines. 
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To create the claw: 

When modeling the shape of the claw, you will use circles, arcs, and curves. You can trim the circles and arcs and 
then join them together to create a closed curve. You can rebuild the curve and adjust the control points to get a 
more sculptural shape. 

1 Change to the Curves layer 

2 Draw a curve defining the shape of the claw in the Top viewport. 

You can use a free-form curve or use a combination of arcs and circles 

that are trimmed and joined to create the curve. Following is a systematic 
approach to creating the curve for the claw part of the hammer using arcs 
and circles. 

Start by drawing two circles. 

3 Use the Circle command (Curve menu > Circle > Tangent to 3 curves) to 
create a circle at the lower end of the claw. 

Draw the circles tangent to the construction geometry 
 

4 Use the Circle command (Curve menu > Circle > Tangent, Tangent, Radius) to 
create a circle at the upper end of the claw that is tangent to the upper right 

corner with a 4 mm radius. 

Draw the circles tangent to the construction geometry. 

 

5 Use the Arc command (Curve menu > Arc > 
Tangent, Tangent, Radius) to create arcs that 
are tangent to the two circles. 
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6 Use the Trim command (Edit menu > Trim) to trim the inside part of the 
circles. 

7 Use the Join command (Edit menu > Join) to join the arc segments. 

 

8 Change to the Claw layer. 

9 Select the joined segments. 

10 Use the ExtrudeCrv command (Solid menu > Extrude Planar Curve > 
Straight) to extrude the curve on both sides of the construction plane. 
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To create the head: 

1 Change to the Curves layer. 

2 Use the Curve command (Curve menu > Free-form > Control Points) to create 
the curve for the cross-section of the head. 

Make sure the curve intersects the claw part. This makes joining the two pieces 
easier. 

 

3 Change to the Head layer. 

4 Use the Revolve command (Surface menu > 
Revolve) to revolve the curve. 

Use the midpoint of the construction line for 
the revolve axis. 

5 Save your model. 

  

 

To add the head to the claw part: 

1 Use the BooleanUnion command (Solid menu 
> Union) to join the head with the claw. 

If the result is not correct, flip the normal of the 
head surface with the Dir command. The normal 
of the head surface should be towards out. 

2 Use the FilletEdge command (Solid menu > 

Fillet Edge) fillet the intersection between the 
head and the claw. 

3 Save your model. 
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To create slot for the claw part of the hammer: 

1 Use the Curve command (Curve menu > Free-
form > Control Points) to draw a curve for the 
slotted part of the claw. 

Make sure the curve is symmetrical.  

2 Use the Line command (Curve menu > Line > 
Single Line) to draw a line between the 

endpoints. 

3 Use the Join command (Edit menu > Join) to 
join the curve and the line. 

 
  

4 Drag the closed curve closer to the claw. 

5 Use the Rotate command (Transform menu > 
Rotate) to rotate the curve to align more closely 
with the curve of the claw. 

6 Change to the Claw layer. 

7 Use the ExtrudeCrv command (Solid menu > 
Extrude Planar Curve > Straight) to extrude the 
curve through the claw. 

 

  

8 Save your model. 

9 Use the BooleanDifference command (Solid 

menu > Difference) to subtract the slot from 
the claw. 

10 Use the FilletEdge command (Solid menu > 
Fillet Edge) to make the fillets around the top 

and bottom of the claw, and the slot. 
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To create the shape curve for the tang and the handle: 

Create the shape curve for the tang in the Right viewport. This curve will also be used for the handle. 

1 Change to the Curves layer and turn on 
Ortho. 

2 Use the Curve command (Curve menu > Free-
form > Control Points) to draw a curve for the 
upper cross-section of the tang. 

Make sure the curve is symmetrical. 

  

3  Use the Mirror command (Transform menu > Mirror) to create the other 
curve. 

4 Use the Join command (Edit > Join) to join the curves. 

5 Save your model. 
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To create the tang: 

1 Use the Curve command (Curve menu > Free-
form > Control Points) to draw one of the 
curves for the tang of the hammer. 

Make sure that it intersects the claw. 

2 Use the Mirror command (Transform menu > 
Mirror) to create the other curve. 

3 Change to the Tang layer. 

  

4 Use the Sweep2 command (Surface menu > Sweep 2 Rails) to make the 
surface. 

5 Use the Cap command (Solid menu > Cap Planar Holes) to make the tang a 
closed polysurface. 

6 Save your model. 

 

 

To finish the hammer head: 

1 Select the tang and the claw. 

2 Use the BooleanUnion command (Solid menu 

> Union) to join the tang with the claw and the 
head. 

3 Use the FilletEdge command (Solid menu > 
Fillet Edge) to make the fillets at the 

intersection between the tang and the claw. 

The edge has a round on it. 

4 Save your model. 
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To create the handle: 

1 Change to the Curves layer. 

2 Use the Curve command (Curve 
menu > Free-form > Control Points) 
to draw a curve for the top edge of 

the handle. 

Make it start at the endpoint of the 
tang profile curve and end on the 
centerline. 

3 Use the Mirror command (Transform 
menu > Mirror) to make the other 

half. 

  

4 Change to the Handle layer. 

5 Use the Sweep2 command (Surface 
menu > Sweep 2 Rails) to make the 
surface using the tang curve as the 
profile curve. 

A surface is created. 

6 Use the Cap command (Solid menu 
> Cap Planar Holes) to cap the open 
end. 

7 Save your model. 
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To create the hole for the handle: 

1 Use the Circle command (Curve 
menu > Circle > Center, Radius) to 
make a circle 25mm from the end of 
the handle. 

You may have to draw a construction 
line to help you position the circle. 

2 Use the ExtrudeCrv command (Solid 
menu > Extrude Planar Curve > 
Straight) to extrude the curve on 
both sides of the construction plane.   

Make sure the extrusion intersects both sides of the handle. 

3 Save your model. 

4 Use the BooleanDifference command (Solid menu > Difference) to 
subtract the hole from the handle. 

5 Use the FilletEdge command (Solid menu > Fillet Edge) to make the 
fillets at the edges of the hole. 

The edges have rounds on them. 

6 Save your model. 
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Exercise 66— Creating a squeeze bottle: 

Some models require more attention to detail. This is an example of a model that requires precise modeling 
techniques. This exercise also requires a number of different surface creation techniques.  

The technical drawing is included to help you create a very precise model. 

50

 

 

 

1 Start a new model, use the Small Objects - Inches.3dm template. 

2 Save as Bottle. 

3 Make the following layers: Construction, Curve, Bottle, BottleTop, Threads, Cap1, Cap2, and CapTop. 

4 Change to the Construction layer. 
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Create the bottle shape 

To create the bottle shape, you will draw a curve that defines the bottom and top edge, and then draw a curve 
that represents the side shape. You will then create a surface from these defining curves. 

To draw the construction curves: 

1 Use the Rectangle command (Curve menu > 

Rectangle > Corner to Corner) to make 
rectangles in the Front and Right views that 
define the overall size of the bottle shape of the 
bottle. 

 The rectangles will be used as guides for 

building the bottle curves. 

2 Use the Lock command (Edit menu > 
Visibility > Lock) to lock the two rectangles. 

3 Use the Ellipse command (Curve menu > 
Ellipse > From Center) to make the shape for 
the bottom of the bottle. 

  

4 Snap to the intersection of the rectangles for the center of the ellipse. 

5 Use the Move command (Transform menu > Move) to move the ellipse up 
.25 in the Front view. 

6 Use the Circle command (Curve menu > Circle > Center, Radius) to draw a 

circle for the top shape of the bottle. 

7 Snap to the intersection at the top of the rectangles for the center of the circle. 

 

 

 

 

 
Rectangle 
 

 
Ellipse 
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To draw the profile curves: 

1 Change to the 
Curve layer. 

2 Use the Curve 
command (Curve 

menu > Free-
Form > Control 
Points) to define 
the edge of the 
bottle in the 
Front and Right 

viewport. 

 
   

Use the rectangle and object snaps to help you establish the correct size. The curve will be used to create the 
surface of the bottle. 

 

3 Use the Mirror command (Transform menu > Mirror) to create the other curves. 

 

To create the surface for the bottle: 

1 Change to the Bottle layer. 

2 Use the Loft command (Surface menu > Loft) to make the bottle surface. 

3 For Select curves to loft, select the profile curves in a clockwise direction, 
press Enter. 

4 In the Loft Options dialog, check Closed loft, set the Style=Normal, 
click OK. 

 

 

 

 

 
Loft 
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Cap the top and bottom 

If you close the bottle, thereby creating a solid, Rhino can calculate the bottle’s volume. If you were creating this 
bottle in real life, knowing the volume would be important. Normally, a bottle would have to be designed to hold a 
specified volume. 

If the edges of the remaining open surfaces are planar curves, you can use the Cap command to close them. The 
open edges on the bottle are the top circular shape and the bottom elliptical shape, and they are planar. 

To cap the top and bottom: 

1 Select the surface. 

2 Use the Cap command (Solid menu > Cap Planar Holes) to close the holes. 

 

 

 

 

 

 

 

 

 

 

 

 

 
Cap Planer Holes  
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Flatten the sides 

In this part of the exercise you will create a custom surfaces to trim an area on each side of the bottle for a label. 
The new surface will have curvature in only one direction. 

To create the trimming surface: 

1 Change to the Curve layer. 

2 In the Front viewport, draw three lines. One 
line in the middle and one on each side.  

Make sure the lines extend a little below and 
above the height of the bottle. 

3 In the Right viewport, Move the lines so that 

they will intersect the bottle, like the illustration 
on the right. 

The technical drawing gives dimensions for 
these curves, but for this exercise you can use 

the construction rectangles to help. If you would 
like to go further, try to figure out on your own 
how to draw the curves to the exact 
specifications. 

  

4 Select the three curves you just created. 

5 Use the Loft command (Surface menu > Loft) 

to make the cutting surface. 

6 In the Loft Options dialog, uncheck Closed loft, 
click OK. 

A lofted surface intersects the bottle. 

7 Mirror the surface to the other side of the 
bottle. 

8 Save your model. 

   

 

  

 
Loft 
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To remove the surface from the bottle: 

1 Change to the Bottle layer. 

2 Use the Dir command (Analyze menu > 
Direction) to check the surface normal 
direction. Flip the normals if necessary. 

The normals should be pointing toward the 
center of the bottle. 

3 Select the bottle. 

4 Use the BooleanDifference command (Solid 

menu > Difference) to subtract the two lofted 
surfaces from the bottle. 

  

 

Create the bottle’s top 

To create the bottle throat, you are going to revolve a profile curve to create the surface, and then add threads. 

To create the profile curve: 

1 Change to the Curve layer. 

2 In the Front viewport, use the Lines command (Curve menu > Line > 
Line Segments) and the Arc command (Curve menu > Arc > Center, 

Start, Angle) to create a profile curve for the outside and the inside of the 
top. 

3 Use the drawing to the right to draw the correct dimensions. 

4 Begin the drawing anywhere in the viewport.  

You will move it to a precise location after it is made. 

5 Use the Join command (Edit menu > Join) to join the segments 

together. 

 

 

 

 

 
Boolean Difference 
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Tip When drawing line segments, you can use object snaps, the distance constraint, and ortho to draw 
precisely. For example, for the first line type .5,7.25 for the starting point, then simply type .25 to 
constrain the line to .25 units. Turn Ortho on and drag the line to the right and click. The line stops at .25 
units from the beginning of the line. For the vertical line on the left, use the End object snap to pick the 

end of the first line, type .375 to constrain the distance, and drag the line in an upward direction. 

6 Use the Move command (Transform menu > 
Move) to move the profile from the midpoint of 
the bottom edge to the quadrant of the top of 
the bottle. 

7 Change to the Bottle Top layer. 

  

 

To create the top surface: 

1 Select the profile curve. 

2 Use the Revolve command (Surface menu > 
Revolve) to make the surface. 

3 Type 0 and press Enter for the first axis point 

4 Turn Ortho on and pick another point up or 
down from the first point for the other axis 
point. 

5 For the  Start Angle, click FullCircle. 

The top is created. 

  

 

Note: Practice additional surface modeling techniques by creating threads on the bottle top and the caps for the 

model. Use the technical drawing to help. 

 
Revolve 
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Adding the threads 

To add the threads, you will sweep a profile shape along a path drawn with the Helix command. 

To create the path curve helix: 

1 Change to the Curve layer. 

2 From the Curve menu, click Helix. 

3 Snap to the center point at the bottom of the area to be threaded. 

4 Snap to the center at the top of the area to be threaded. 

5 Click Turns. 

6 Type 1.5 and press Enter. 

7 Pick a point near the edge that is slightly smaller than the outside edge of the 
area to be threaded. 

To draw the thread profile:  

1 Draw a triangle using the Polygon command 
for the thread as shown below. 

2 Select the triangle you created. 

3 From the Transform menu, click Array, and 
then click Along Curve. 

4 Select the helix near the bottom. 

5 In the Array Along Curve Options dialog, 
change the Number of items to 5, click 
Roadlike then click OK. 

  

 

6 Click in the Top viewport. 

It might be a good idea at this point to change 
your perspective view so you can see the profile 
curves more easily. 

7 Delete the first and last profile curve. 

You will use the remaining profile curves to 
create a surface. 

  

 
Helix 
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To create the thread surface: 

1 Change to the BottleTop layer. 

You can see the helix and profile curves easier if 
you Hide the bottle top at this point. 

Use the Sweep1 command to create a surface 
that starts a point at one end of the helix, goes 
through each profile, and ends at a point at the 
other end of the helix. 

2 From the Surface menu, click Sweep 1 Rail. 

3 Select the helix. 

4 To start the surface at a point, at the Select 

cross-section curves ( Point ) prompt, type P 
and press Enter.  

 

   

5 Use the End object snap to pick one end of the 
helix. 

6 Select the profile curves in order. 

7 To end the surface at a point, at type P and 

press Enter. 

8 Use the End object snap to pick the other end 

of the helix. 

9 Press Enter. 

10 In the Sweep 1 Rail Options dialog box, 
change the Style to Roadlike Top, and 
click OK. 

  

11 Show the bottle. 

12 Select the helical thread and the bottle top. 

13 Use the BooleanUnion command (Solid menu > Union) to join the thread and the bottle top. 

 

 

 

 

 

 

 
Sweep 1  Rail 



 

Notes: 

Robert McNeel & Associates 217 

 10  Importing and Exporting Models 

 

Rhino supports many different import and export formats, making it possible to model in Rhino and then export 
your model to downstream processes. For a complete list of import and export options refer to Rhino Help. Search 
the index for ―import and export.‖ 

Importing and Exporting Rhino File Information 

When you export to a format like 3DS, STL or DWG, Rhino has to convert from smooth NURBS surfaces to a 
polygon mesh representation made of triangles. To do a good approximation of the curved surfaces, Rhino can 

sometimes use many polygons. The density of triangles can be adjusted when exporting. You can create a mesh 
object and export it, or Rhino can create the mesh during the export process. 

There are two methods to export models to other formats. You can ―Save As‖ and choose a specific export format 

to export an entire model. You can select some objects and ―Export Selected‖ then choose a specific export format 

to export a portion of the model. In the following exercise you will use the ―Save As‖ method to export three of 
the most common file formats.  
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Exercise 67— Exporting models 

To export a model to a mesh format: 

1 Open the model Export.3dm. 

2 From the File menu, click Save As. 

3 In the Save dialog box, change the 

Save as type to Stereo 
lithography (*.stl). 

4 In the file name box type Export and 
click Save. 

5 In the STL Mesh Export Options 
dialog box, set the Tolerance to 
0.01, and click Preview. 

 

 

 

 

 

 

6 Set the Tolerance to 0.1, click Preview, and then click OK. 

7 In the STL Export Options dialog box, select Binary, check Export 

open objects, and click OK. 

Detailed mesh controls are discussed in more depth in the Level 2 training 
class. 
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To export a model to IGES: 

1 From the File menu, click Save As. 

2 In the Save dialog box, change the Save as type to IGES (*.igs). 

3 In the IGES Export Options dialog box, select Pro E Windows 
solids as the IGES type, click Detailed Controls. 

Detailed controls allow the user more input. 

4 Click Cancel to terminate, or OK to create the IGES file. 

 

 

 

To export a model to STEP: 

1 From the File menu, click Save As. 

2 In the Save As dialog box, change the Save as type to STEP (*.stp, *.step). 

3 In the STEP Options dialog box, use the default setting. 
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 11  Rendering 

 

Rendering is available for showing your model as if it was photographed. While the Rhino renderer may be good 
enough for much of your work, use another rendering program such as Rhino’s Flamingo plug-in for higher quality 
results. Flamingo is available as a plug-in to Rhino 2.0. Visit www.flamingo3d.com for more information. 

Rhino’s renderer uses color, spotlights, displays shadows, and does antialiasing. It also allows the attachment of 
textures and bump maps. In this exercise we will focus on the full rendering capability. 

Exercise 68— Practice rendering a model 

1 Open the model Render.3dm. 

2 From the Render menu, click Current Renderer, and then click Rhino 

Render. 

3 Right click on the Perspective title bar, and then click Rendered 

display. 

The viewport mimics but does not exactly duplicate what you will get in a 
Render. 

 

 

 
Rendered Viewport 
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To assign a color to the handle: 

1 In the Layers dialog box, 
click on the Materials 
column for the Handle layer. 

2 In the Material dialog box, 

click Basic, 

To give the handle a 
highlight, change the Gloss 
finish setting. 

 

 

A highlight of 0 means that 

the object is not shiny at all 

and it will not have a specular 
highlight. A low value of 
highlight makes the shiny 
spot to be small, and the 
object will look glossier. As 
the highlight increases in 
value, the shiny spot gets 

large—this makes the object 
look more like it is made out 
of a reflective material. 

The shiny spot only appears 
when you are looking at an 

object at a certain angle 
relative to the angle of the 
light. 

 

3 Change the Gloss finish setting to 90, and then click the Color swatch. 

4 In the Select Color dialog box, select a color, like Red, and click OK. 

5 Repeat the steps above to assign a material to the Blade layer. 

6 From the Render menu, click Render. 

A display window appears with the current viewport rendered in colors, but it 
will probably lack detail. You can close the Display Window without disturbing 
your model. Placing lights will add depth and detail to the rendered image. 

 

 

 

 
Render 
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To place a light: 

Start with a standard lighting scheme. You can experiment to develop your own lighting schemes later. 

1 Zoom out in the Top and the Front viewport. 

2 Change to the Lights layer. 

3 From the Render menu, click Create 
Spotlight. 

4 For the Base of cone, type 0 and press Enter. 

5 For the Radius, pick a point so that the circle is 
larger than the entire screwdriver in the Top 

viewport. 

6 For the End of cone, hold down the control 
key, and pick a point below and to the right in 
the Top viewport. 

  

This starts elevator mode. 

7 For the End of cone, pick above the object in 
the Front viewport. 

This will be your main light. 

8 Click in the Perspective viewport. 

9 From the Render menu, click Render. 

 The image has some highlights and shadows. 

 

  

 

  

  

  

  

  

 
Create Spotlight 
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To place a second light: 

1 Zoom out in the Top and the Front viewport. 

2 From the Render menu, click Create 
Spotlight. 

3 For the Base of cone, type 0 and press Enter. 

4 For the Radius, pick a point so that the circle is 
larger than the handle of the screwdriver in the 

Top viewport. 

5 For the End of cone, hold down the control 
key, and pick a point below and to the left in 
the Top viewport. 

  

This starts elevator mode. 

6 For the End of cone, pick above the object in 
the Front viewport. 

This will be your secondary (fill) light. 

7 Click in the Perspective viewport. 

8 From the Render menu, click Render. 

 

  

 

To assign properties to the light: 

1 Select the new light. 

2 From the Edit menu, click Object Properties. 

3 On the Light page, change the Shadow 
intensity to 0 and the Spotlight hardness to 
60. 

Experiment with these settings to get the 
desired effect. 

4 Click in the Perspective viewport. 

5 From the Render menu, click Render. 
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To add a bumpy surface to the handle:  

1 In the Layers dialog box, 
click on the Materials 
column for the Handle layer. 

2 In the Material Editor dialog 

box, check Bump.  

You can use any bitmap file 
for a bump. 

 

 

The bumps come from the pattern of light and 
dark in the bitmap image. 

3 In the Open Bitmap dialog box, select 

HandleBump.jpg, and then click Open. 

4 In the Material Editor dialog box, for Bump 
Tiling, click Modify. 

5 In the Offset and Tiling dialog box, change 
the U tiling to 4.0 and the V tiling to 6.0, click 
OK. 

 

6 Click OK to close the Material Editor dialog 
box. 

7 From the Render menu, click Render. 

The surface of the handle has a bumpy 
appearance. 
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To add a texture to the handle: 

1 In the Layers dialog box, 
click on the Materials 
column for the Handle layer. 

2 In the Material Editor dialog 

box, uncheck Bump. 

3 In the Material Editor dialog 
box, check Texture. 

 

 

4 In the Open Bitmap dialog box, select 
Wood.jpg, and then click Open. 

5 In the Offset and Tiling dialog box, change 
the U tiling to 4.0 and the V tiling to 6.0, click 
OK. 

 

6 Click OK to close the Material Editor dialog 
box. 

7 From the Render menu, click Render. 

The surface of the handle has a wood texture 
appearance. 
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To make the handle transparent: 

1 In the Layers dialog box, 
click on the Materials 
column for the Handle layer. 

2 In the Material Editor dialog 

box, uncheck Texture. 

 
 

 

3 In the Material Editor dialog box, change 
the Transparency setting to 50. 

4 Click OK to close the Material Editor 

dialog box. 

5 From the Render menu, click Render. 

The handle will look transparent. 
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To add a surface for a ground plane: 

1 Use the Plane command (Surface 
menu > Plane > Corner to Corner) to 
draw a flat surface in the Top 
viewport. 

2 Select the surface. 

3 Use the Properties command (Edit 
menu > Object Properties...) on the 
Material page, click Basic. 

4 In the Texture section assign the 
Wood.jpg to the plane.  

5 From the Render menu, click 
Render. 

  

 

Rendering with Flamingo 

In this part of the exercise you will use Flamingo to assign materials from the material library and set up an 
environment. You will use the same lights and model. 

To assign a material: 

1 Select the flat surface. 

2 Use the Hide command (Edit menu > Visibility > Hide) to hide it. 

3 From the Render menu, click Current Renderer, and then click Flamingo Raytrace. 

4 In the Layers dialog box, click on the Materials column for the Handle layer. 

5 In the Material Editor dialog box, click Plug-in, and then click Browse. 

6 In the Material Library dialog box, in the Plastics library, in the 
Transparent folder, select a material, press OK. 

7 In the Material Editor dialog box, press OK. 

8 Repeat this process for the Blade layer. 

9 Choose a shiny metal material, like Metal\Steel\Polished\Plain. 

10 Render the model. 
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To set up an environment: 

1 Use the Options command (Tools menu > Options...) to setup the Flamingo environment options 

2 In the Rhino Options dialog box, on the Flamingo page, click the Environment button. 

3 On the Environment dialog box, change to a 3 Color Gradient. 

 Use the default setting. 

4 Check the Ground Plane check box. 

5 On the Ground Plane page, click the Material button, and select a 

material for the ground plane, like Metal\Aluminum\Satin\Checker 
Plate. 

6 On the Environment dialog box, press OK. 

7 On the Rhino Options dialog box, press OK. 

8 Render the model. 

Notice that you also get reflections. 

 

 

 

A more complete discussion of Flamingo rendering is included in Level 2 training. 

For extra practice use the canoe, the hammer, or the bottle you made in the earlier exercises. 
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12  Dimensions 

Dimensions 

You can create simple dimensions on all viewports. 

Dimension Types 

 

Button Command Description 

 
Dim Linear Dimension creates a horizontal or a vertical dimension. 

 
DimAligned Creates an aligned dimension. 

 
DimRotated Creates a rotated dimension. 

 
DimAngle Creates an angular dimension. 

 
DimRadius Creates a radius dimension. 
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Button Command Description 

 
DimDiameter Creates a diameter dimension. 

 
Text Creates 2-D annotation text. 

 
Leader Draw an arrow leader. 

 
Properties Edit dimensions and text. 

 
DimRecenterText Returns text that has been moved away from its default position to its original 

location. 

 
Make2-D Creates curves from the selected objects as silhouettes relative to the active 

construction plane. The silhouette curves are projected flat and then placed on 
the world x,y-plane. 

Exercise 69— Practice dimensioning 

 

1 Open the model Dimension.3dm. 

2 From the Tools menu, click Options. 

3 In the Rhino Options dialog box, on the 
Dimensions page, make the following 
changes. 

 

 

 

 
Options 
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4 From the Dimension menu click Linear Dimension. 

5 Snap to the lower left end of the part in Top viewport. 

6 Snap to the lower right end of the part in the Top viewport. 

7 Pick a point below the part in the Top viewport. 

 

 

8 From the Dimension menu, click 

Radial Dimension. 

9 Select the lower right quadrant of the 
arc in the Top viewport. 

10 Click to place the dimension text. 

11 From the Dimension menu, click 
Diameter Dimension. 

12 Select the upper right quadrant of 
the hole in the Top viewport. 

13 Click to place the dimension text. 
  

14 Dimension the rest of the drawing 

using leaders, text blocks, horizontal, 
vertical, radius, and diameter 
dimensions. 

15 Save your model. 

 

 
 

 

 

 
Linear dimension 

Use object snaps to locate the 
extension line origins. 
 
To move extension line or text 
locations for dimensions, turn on 
control points for the dimension and 
move the control points. 

 
Radial dimension 
 

 
Diameter dimension 
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Making a 2-D Drawing from a 3-D Model 

Rhino has the ability to generate a two-dimensional drawing from a three-dimensional model, by projecting the 
geometry to the world coordinate plane, and aligning the views. Options for first angle projection or third angle 

projection are available. In addition to the three orthographic views, a two-dimensional perspective drawing is 
also generated. Hidden lines are removed and placed on a separate layer. 

Options for creating four views > three parallel viewports and a perspective viewport, or single views of individual 
viewports are supported.  

The Make2-D command makes a two-dimensional drawing for all four views.  

Exercise 70— Practice making a 2-D drawing for export 

1 Open the model Make2D.3dm. 

2 From the Dimension menu, click Make 
2-D Drawing. 

3 In the 2-D Drawing Options dialog box, 
click 4-view (USA) and check Show 
hidden lines, and then click OK. 

The 2-D drawings are created on the Top 
CPlane near the origin on the world xy 
plane. View them in the Top viewport.  

4 Dimension the 2-D drawing. 

 

 

 

 

 

 

 

 
Make 2-D Drawing 
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13  Layout and Printing 

 
Layouts and Details 

 Layout viewports can include various views of the model and annotations like title blocks and notes. When these 
viewports are tabbed with the model viewports, they can be easily accessed from the tabs.  

Geometry in a layout viewport does not appear in the model viewports. Layout viewports include a background 
with one or more detail views of the model. The detail edge appearance is controlled with the Properties command 
and has exactly the same object properties as any curve, including Layer, Display Color, Print Color, and Print 
Width.  

The Print Width—No Print property is set by default. Detail properties include Locked status and Scale. 

Exercise 71— Practice making layouts 

1 Open the model 
SimpleLayout_Print.3dm. 

2 Click in the Top viewport. 

3 From the View menu, click Page 
Layout, click New Page Layout. 

4 In the New Page Layout dialog, click 

Landscape. Set the Initial Detail 
Count to 4. Adjust any other options 

appropriate for your printer or plotter, 
click OK.  

 
A layout page opens and tabs appear at the lower edge of the Rhino 
window labeling the modeling windows and the layout page. 
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The new layout has four detail 
views, showing the object from the 
same direction as the four default 

Rhino viewports. 

Rhino turns on the tabbed viewports 
to make it easier to navigate among 
multiple layouts and modeling 

viewports.  

 

 

Details are windows into the 3-D 
model. They can be activated as 

modeling viewports by double-

clicking in the viewport. 

5 Double-click in the Right 
viewport. 
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Set scale and lock details: 

1 If the Properties window is not 
open, open it now (Edit>Object 
Properties) and dock it to one 
side.  

 

With nothing selected, the 
properties window shows the 
viewport properties.  

 

With no detail active, the 

properties shown are for the 
layout as a whole. 

   

2 Click the Edit button to edit the 
title, and size and printer 
properties.  

3 On the command line, for the 
Distance on page (mm), set it 

to 1, press Enter. 

4 On the command line, for the 

Distance in model (m), set it 
to 1, press Enter. 

5 Change the title to Right 
Profile, and Lock the detail. 

6 Repeat this in the Top and 
Front details to set all of these 
details to the same scale. 

7 Activate the Perspective detail. 

8 From the View menu, click 
Shaded. 
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To draw borders and title blocks in the layout space: 

1 Double-click in the Perspective detail to deactivate it and make the 
layout space active. 

2 Draw a Rectangle (Curve>Rectangle>Corner to corner) around the 
viewports on the Layout. 

3 From the File menu, click Insert. 

4 On the Insert dialog, check Prompt for Insertion point, uncheck 

Prompt for Scale and Rotation. 

5 On the Insert dialog, click File…, select TitleBlock.3dm, click Open, 
click OK. 

 

6 For the Insertion Point, snap to the lower right corner of the rectangle. 

A title block is inserted on the layout. 

7 You can add information to the title block with the text command.  

To edit the text on the title block, explode it first. 

 

 

To add dimensions to the layout space: 

1 On the layout use Linear dimensions to measure some features. 

The dimensions are located on the layout. The will not display in the 
model views. 

2 Add more dimensions as needed to the other layout viewports. 
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To set linetypes and line weights for curves: 

These are used in printing and can be displayed in the Rhino views using the PrintDisplay and LinetypeDisplay 
commands.  

1 From the Edit menu, click Layers, then click Edit Layers. 

2 On the Layers dialog, in the Print Width column, change the width of 
some of the layers. 

3 Select the Border rectangle and the Title Block. 

4 On the Object Properties dialog, change the Print Width to a thicker 
weight. 

5 Type PrintDisplay on the command line, click State=Off on the 

command line, change it to On. 

Note the difference in thickness of the curves. 

Linetypes can be adjusted the same way. 

 

Printing 

Exercise 72— Practice printing  

To print the layout: 

1 From the File menu, click Print. 

2 On the Print dialog, set the print Destination to the desired printer. 

In addition to your Windows printers, the list of printers includes pdf print 
drivers, if available, as well as Image File which allows printing to an image 
file like *.png, *.jpg., *.bmp, *.tif, or *.tga. 

 

 The detailed settings below the list of destinations will change, depending 
on  the selected printer or driver. Generally, the settings control print 
quality, orientation (landscape or portrait), paper size, number of copies to 
print, and a button to access the printer properties. 

3 For Printer output, set it to raster.  

To print layouts or viewports that contain a shaded display, the raster 
settiing is required.  

To print layouts or viewports as curves or lines only, use the vector setting. 

 

 

 
Print 
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4 For the Output color, set it to Print Color. 

Output color can be set on any one of the following: 

Print Color uses object color for the print color. This can be set  to any 
color per object or per layer. An object that is displayed with a blue 
wireframe in the viewport can print to any other color. 

Display Color is the default setting in the print dialog. Objects print the 
color of the wireframe in the viewport. 

Black and White forces black and white printing only, ignoring the display 
or print colors of objects. 

In the SimpleLayout file, the wireframes of the various objects are of 
varying color. Some of them correspond to the layer color of the layer they 

are on, like the hull, which displays green.  Others have their display color 
set by object to override the layer color. 

 

5 Set the View and Output Scale. Set the View to Extents, and the Scale 
to 1:1. 

The reason we can set this to 1:1 is because we set up our layout to the 
paper size and we scaled the viewports to the correct scale. 

6 Cancel the Print, unless you have a printer available. 
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14  Rhino Settings 

Options 

The Rhino Options dialog box displays most of the settings that affect your modeling environment. Use it to 
toggle the settings or redefine them.  

The Document Properties settings are saved with the Rhino model. The Rhino Options settings are saved in 
the Windows registry and affect every Rhino model. 

Exercise 73— Practice with options 

To change modeling aids: 

1 From the Tools menu, click Options.  

2 In the Rhino Options dialog box, click the Modeling Aids page. 

The Modeling Aids page controls Grid Snap, Ortho, Planar mode, 
and Object Snap options. 

These options can be toggled on and off from the dialog box or 
from the status bar. To change the options for Ortho or object 
snap, type new values in the boxes. In an earlier exercise you 
changed the Ortho setting so that it snapped every 30 degrees. 

3 Modeling Aids also contains pages for SmartTrack options, 
Nudge controls, and Cursor ToolTips. 

 

 
Options 
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To change Rhino’s screen appearance: 

1 Click the Appearance page. 

The Appearance page controls the appearance of the Rhino window. 

2 Click the white rectangle next to Background color and change it 
to a different color. 

3 Check the Crosshairs box. 

 

To change or create shortcuts: 

1 Open the Keyboard page. 

The Keyboard page sets up shortcut keys for Rhino commands. 

2 Type DisableOsnap _Toggle in the box next to the F4 key. 

This gives you a key that toggles your persistent object snaps 
between on and disabled.  
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To change or create command aliases: 

1 Click the Aliases page. 

The command Aliases page allows the user to create custom aliases 
for Rhino commands. 

2 Click New. 

A cursor moves into the white area of the dialog box.   

3 Type L, press the tab key. 

4 Type ! Lines. 

The exclamation point acts as a cancel. 

Now you will be able to type L and press Enter at the command 
line, to begin the Lines command. 

 

 

 

To change view options: 

 Click the View page. 

 The View page has pan, zoom, rotate, and redraw controls. 

To change general options: 

 Click the General page. 

 The General page controls the number of undo’s retained in memory, startup commands, recent command list 
limit, AutoSave control, and do not repeat commands, default isocurve density for new surfaces. 

To set file options: 

1 Click the Files page. 

 The Files page sets the location of template files and the autosave files. 

2 Click OK to close the Options dialog box. 

3 Try the Lines alias and the DisableOsnap toggle.  

 Note how your cursor has changed. 
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Document Properties 

Document properties are all of the settings that are saved with the Rhino model.  

Exercise 74— Practice with document properties 

To change the grid: 

1 From the File menu, click Properties. 

2 Click the Grid page. 

 The Grid page configures grid, grid axes, and axis icons. You changed the snap spacing in an earlier exercise. 

To change render options: 

1 Click the Rhino Render or Flamingo page. 

 The Render page controls most of the render options. 

2 Click the Mesh page. 

 This page controls the mesh properties. It will also affect performance. 

To set units: 

 Click the Units page. 

 The Units page controls the unit system and the tolerance settings. 

 
Document Properties 
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15  Custom Toolbar Layouts 

 

The toolbar layout is the arrangement of toolbars containing command buttons on the screen. The toolbar layout 
is stored in a toolbar collection file that you can open and save. Rhino comes with a default toolbar layout, and 
automatically saves the active toolbar layout before closing. You can create your own custom layouts and save 

them for later use. 

You must use an external file manager to delete a toolbar collection file.  

Exercise 75— Customizing a toolbar layout 

1 Begin a new model. 

2 From the Tools menu, click Toolbar Layout. 

3 In the Toolbars dialog box, from the File menu, click Save As. 

4 In the Save Toolbars Collection dialog box, in the File name box type Level 1, 
and click Save. 

A new toolbar collection file has been created. Toolbar collection files are saved with 
a .tb extension. You will use this new toolbar collection to do some customization. 

 

To show another toolbar: 

1 From the Tools menu, click Toolbar Layout. 

2 In the Toolbars dialog box, check Curve Tools to show the toolbar. 

3 In the Toolbars dialog box, clear Curve Tools to hide the toolbar. 

4 Show the Curve Tools toolbar again, and then click Close. 
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5 To dock the Curve Tools 
toolbar at the bottom, drag 
down until it changes to a 
horizontal shape, then 
releasing your mouse 
button. 

 

To save your toolbar layout: 

 In the Toolbars dialog box, from the File menu, click Save. 

To create a new toolbar: 

1 From the Tools menu, click Toolbar Layout. 

2 In the Toolbars dialog box, from the Toolbar menu, click New. 

3 In the Toolbar Properties dialog box, in the Name box, type Test, 
and click OK. 

A new toolbar is created with one blank button in it. 

4 Close the Toolbars dialog box.  
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To edit the new button: 

1 Hold down the Shift key and right-click the blank button. 

2 To enter the tooltips for the left and right mouse buttons, in 
the Edit Toolbar Button dialog box, under Tooltips, in 
the Left edit box, type Change Last Object to Layer. 

In the Right edit box, type Change All Curves to Layer. 

3 In the Left mouse button command box, type ! SelLast 

ChangeLayer. 

4 In the Right mouse button command box, type ! SelCrv 
ChangeLayer. 

 

 

5 Click Edit Bitmap. 

6 In the Edit Bitmap dialog box, make a picture for the 
button face image, and click OK. 

7 In the Edit Toolbar Button dialog box, click OK. 
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To copy a button from one toolbar to another: 

1 From the Standard toolbar, flyout the Layer toolbar, and tear it off. 

2 While holding down the Ctrl key, drag the button you just created to the layer 
toolbar and drop it. 

 

 

To add a button to a toolbar: 

1 From the Tools menu, click Toolbar Layout. 

2 In the Toolbar dialog box, check the Test toolbar in the list to show the 
toolbar. 

3 Right click on the Test toolbar in the list, and select Add Button. 

A blank button is added to the Test toolbar. 

4 Close the dialog box. 

Many toolbar functions are available by right-clicking a toolbar’s title bar. 

  
 

 

 

 

 


	List of Exercises
	Part One: Introduction
	Duration:
	Course Objectives
	Example Schedule
	The Rhino for Windows Interface
	The Rhino Screen
	Menus
	Toolbars
	Tooltips
	Flyouts

	Graphics Area
	Viewports
	Viewport tabs

	Command Area
	The Mouse
	Entering Commands
	Clickable options
	Autocomplete command name
	Repeating commands
	Canceling commands

	Help
	View the Command Line History
	View Recent Commands
	Exercise 1—Rhino basics

	Navigating Around the Model
	Zooming in and out
	Zooming extents

	Move Objects
	Copy Objects
	Changing the View of Your Model
	Viewports
	Parallel vs. Perspective Projection

	Panning and Zooming
	Resetting Your View
	Exercise 2—Display options


	Part Two: Creating Geometry
	Drawing Lines
	Exercise 3—Drawing lines

	Drawing Free-form Curves
	Exercise 4—Drawing interpolated curves
	Exercise 5—Drawing curves from control points

	Modeling Aids
	Snap
	Ortho
	Planar
	History
	Grid
	Exercise 6—Drawing lines and curves using mode functions


	Model Setup
	Saving Your Work
	Layers
	Exercise 7—Layers
	Exercise 8—Selecting objects

	Selecting Objects
	Exercise 9—Practice using selection options
	Additional selection options

	Absolute Coordinates
	Exercise 10(Setting up a model
	Exercise 11—Entering absolute coordinates

	Relative Coordinates
	Exercise 12—Entering relative coordinates

	Polar Coordinates
	Exercise 13—Entering polar coordinates

	Distance and Angle Constraint Entry
	Exercise 14—Distance constraint entry
	Exercise 15—Distance and angle constraint entry
	Exercise 16—Practice using distance and angle constraint entry
	Exercise 17—Practice using distance and angle constraints

	Object Snaps
	Exercise 18—Using object snaps

	Other modeling aids
	Exercise 19—Smart Track
	Exercise 20 – Tab Constraint
	Exercise 21 – Project Constraint
	Exercise 22 – Planar Constraint

	Viewports and Construction Planes
	Exercise 23—Viewports and construction planes
	Viewports
	Construction planes
	Exercise 24—Modeling in 3-D space


	Analysis Commands
	Drawing Circles
	Exercise 25—Drawing circles
	Exercise 26—Using circle-related object snaps

	Drawing Arcs
	Arc options
	Exercise 27—Practice drawing arcs (1)
	Exercise 28—Practice drawing arcs (2)


	Drawing Ellipses and Polygons
	Ellipses
	Polygons
	Polygon options
	Rectangles
	Exercise 29—Practice drawing ellipses and polygons


	Modeling Free-Form Curves
	Exercise 30—Practice drawing curves (1)

	Modeling Helix and Spiral
	Exercise 31—Practice drawing curves (2)
	Exercise 32—Drawing free-form curves

	Fillet
	Exercise 33—Fillet

	Blend
	Chamfer
	Exercise 34—Chamfer
	Exercise 35—Practice with Fillet and Chamfer

	Move
	Exercise 36—Move

	Copy
	Exercise 37—Copy

	Undo and Redo
	Rotate
	Exercise 38—Rotate

	Group
	Exercise 39—Grouping

	Mirror
	Exercise 40—Mirror

	Join
	Exercise 41—Join

	Scale
	Exercise 42—Scale

	Array
	Exercise 43—Polar Array

	Trim
	Exercise 44—Trim

	Split
	Exercise 45—Split

	Extend
	Exercise 46—Extend

	Offset
	Exercise 47—Offset
	Exercise 48—Practice
	Exercise 49—Practice
	Exercise 50—Practice
	Exercise 51—Practice
	A few facts about control points, edit points, and knots
	Exercise 52—Control point editing


	Nudge Controls
	Exercise 53—Practice with curves and control point editing


	Part Three: 3-D Modeling and Editing
	Exercise 54—Creating a rubber duck
	Create the body and head shapes
	Separate the bill from the head
	Create the duck’s neck
	Render a picture of the ducky
	Exercise 55— Model a bar with text

	Using a model for illustration
	Exercise 56—Basic techniques for making surfaces
	Exercise 57—Extruding surfaces
	Exercise 58—Lofted surfaces
	Exercise 59—Revolved surfaces
	Exercise 60—Using a rail revolve
	Exercise 61—Using 1-rail sweeps to create surfaces
	Exercise 62—Using 2-rail sweeps to create surfaces
	Exercise 63—Using a network of curves to create surfaces
	Exercise 64— Practice using one-rail sweeps:
	Exercise 65— Creating a toy hammer:
	Exercise 66— Creating a squeeze bottle:

	Create the bottle shape
	Cap the top and bottom
	Flatten the sides
	Create the bottle’s top
	Adding the threads
	Importing and Exporting Rhino File Information
	Exercise 67— Exporting models
	Exercise 68— Practice rendering a model

	Rendering with Flamingo
	Dimensions
	Dimension Types
	Exercise 69— Practice dimensioning


	Making a 2-D Drawing from a 3-D Model
	Exercise 70— Practice making a 2-D drawing for export

	Layouts and Details
	Exercise 71— Practice making layouts

	Printing
	Exercise 72— Practice printing


	Part Four: Customizing Workspaces and Toolbars
	Options
	Exercise 73— Practice with options

	Document Properties
	Exercise 74— Practice with document properties
	Exercise 75— Customizing a toolbar layout



